]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blob - apache-mod_auth_any.spec
- updated to 1.2.1 (bugdix release).
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
1 %define         mod_name        auth_any
2 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
3 Summary(cs):    Základní autentizace pro WWW server Apache pomocí shellových pøíkazù
4 Summary(da):    En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
5 Summary(de):    Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
6 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
7 Summary(it):    Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
8 Summary(no):    En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
9 Summary(pl):    Podstawowy modu³ autentykacji dla Apache, u¿ywaj±cy poleceñ pow³oki
10 Summary(pt):    Um módulo de autenticação de LDAP para o servidor Web Apache
11 Summary(sl):    Osnovna avtentikacija za spletni stre¾nik Apache, z uporabo poljubnih lupinskih ukazov
12 Summary(sv):    Grundläggande autentisering för webbservern Apache med valfria skalkommandon
13 Name:           apache-mod_%{mod_name}
14 Version:        1.2.1
15 Release:        1
16 License:        GPL
17 Group:          Networking/Daemons
18 Group(cs):      Sí»ové/Démoni
19 Group(da):      Netværks/Dæmoner
20 Group(de):      Netzwerkwesen/Server
21 Group(es):      Red/Servidores
22 Group(fr):      Réseau/Serveurs
23 Group(is):      Net/Púkar
24 Group(it):      Rete/Demoni
25 Group(no):      Nettverks/Daemoner
26 Group(pl):      Sieciowe/Serwery
27 Group(pt):      Rede/Servidores
28 Group(ru):      óÅÔØ/äÅÍÏÎÙ
29 Group(sl):      Omre¾ni/Stre¾niki
30 Group(sv):      Nätverk/Demoner
31 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
32 Source0:        ftp://ftp.itlab.musc.edu/pub/toolbox/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
33 URL:            http://www.itlab.musc.edu/~nafees/mod_%{mod_name}.html
34 Prereq:         /usr/sbin/apxs
35 Requires:       apache(EAPI)
36 BuildRequires:  /usr/sbin/apxs
37 BuildRequires:  apache(EAPI)-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
41
42 %description
43 This module allows you to use any command line program (such as
44 webNIS) to authenticate a user.
45
46 %description -l cs
47 Balíèek mod_auth_any slou¾í pro omezení pøístupu k dokumentùm, které
48 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
49 jakéhokoliv pøíkazu (jeho návratovým kódem).
50
51 %description -l de
52 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
53 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
54 gegebenen arbiträren Befehls prüft.
55
56 %description -l es
57 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
58 desde un servidor web verificando el código de retorno de un comando
59 arbitrario especificado.
60
61 %description -l fr
62 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
63 servis par un serveur Web en vérifiant le code de retour d'une
64 commande spécifiée arbitraire.
65
66 %description -l it
67 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
68 serviti da un server Web controllando il codice di ritorno di un dato
69 comando arbitrario.
70
71 %description -l ja
72 Mod_auth_any ¤ÏǤ°Õ¤Ë»ØÄꤵ¤ì¤¿¥³¥Þ¥ó¥É¤ÎÌá¤ê¥³¡¼¥É¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
73 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
74 ¤¬¤Ç¤­¤Þ¤¹¡£
75
76 %description -l pl
77 Ten modu³ pozwala na u¿ycie dowolnego programu dzia³aj±cego z linii
78 poleceñ (jak np. webNIS) do autentykacji u¿ytkownika.
79
80 %description -l sv
81 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
82 servade av en webbserver genom att kontrollera returkoden från ett
83 godtyckligt angivet kommando.
84
85 %prep
86 %setup -q -n mod_%{mod_name}
87
88 %build
89 /usr/sbin/apxs -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_pkglibdir}
94
95 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
96
97 gzip -9nf docs/*
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
104 if [ -f /var/lock/subsys/httpd ]; then
105         /etc/rc.d/init.d/httpd restart 1>&2
106 fi
107
108 %preun
109 if [ "$1" = "0" ]; then
110         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
111         if [ -f /var/lock/subsys/httpd ]; then
112                 /etc/rc.d/init.d/httpd restart 1>&2
113         fi
114 fi
115
116 %files
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_pkglibdir}/*
119 %doc docs/*.gz
This page took 0.106862 seconds and 3 git commands to generate.