]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blob - apache-mod_auth_any.spec
323211c39d1652a1cb31acc82fcac3e168c76c25
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
1 %define mod_name        auth_any
2 %define apxs            /usr/sbin/apxs
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí shellových pøíkazù
5 Summary(da):    En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de):    Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it):    Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(nb):    En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl):    Podstawowy modu³ uwierzytelnienia dla Apache, u¿ywaj±cy poleceñ pow³oki
11 Summary(pt):    Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl):    Osnovna avtentikacija za spletni stre¾nik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv):    Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache-mod_%{mod_name}
15 Version:        1.2.2
16 Release:        1
17 Epoch:          1
18 License:        BSD
19 Group:          Networking/Daemons
20 Source0:        http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}-apache2.tar.gz
21 # Source0-md5:  e9a1825b818d108e1204692da3d7bfd0
22 URL:            http://www.itlab.musc.edu/webNIS/mod_auth_any.html
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache-devel >= 2
25 Requires(post,preun):   %{apxs}
26 Requires:       apache >= 2
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
30
31 %description
32 This module allows you to use any command line program (such as
33 webNIS) to authenticate a user.
34
35 %description -l cs
36 Balíèek mod_auth_any slou¾í pro omezení pøístupu k dokumentùm, které
37 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
38 jakéhokoliv pøíkazu (jeho návratovým kódem).
39
40 %description -l de
41 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
42 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
43 gegebenen arbiträren Befehls prüft.
44
45 %description -l es
46 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
47 desde un servidor web verificando el código de retorno de un comando
48 arbitrario especificado.
49
50 %description -l fr
51 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
52 servis par un serveur Web en vérifiant le code de retour d'une
53 commande spécifiée arbitraire.
54
55 %description -l it
56 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
57 serviti da un server Web controllando il codice di ritorno di un dato
58 comando arbitrario.
59
60 %description -l ja
61 Mod_auth_any ¤ÏǤ°Õ¤Ë»ØÄꤵ¤ì¤¿¥³¥Þ¥ó¥É¤ÎÌá¤ê¥³¡¼¥É¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
62 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
63 ¤¬¤Ç¤­¤Þ¤¹¡£
64
65 %description -l pl
66 Ten modu³ pozwala na u¿ycie dowolnego programu dzia³aj±cego z linii
67 poleceñ (jak np. webNIS) do uwierzytelniania u¿ytkownika.
68
69 %description -l sv
70 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
71 servade av en webbserver genom att kontrollera returkoden från ett
72 godtyckligt angivet kommando.
73
74 %prep
75 %setup -q -n mod_%{mod_name}-%{version}-apache2
76
77 %build
78 %{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so -Wl,-shared
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{_pkglibdir}
83
84 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
91 if [ -f /var/lock/subsys/httpd ]; then
92         /etc/rc.d/init.d/httpd restart 1>&2
93 fi
94
95 %preun
96 if [ "$1" = "0" ]; then
97         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
98         if [ -f /var/lock/subsys/httpd ]; then
99                 /etc/rc.d/init.d/httpd restart 1>&2
100         fi
101 fi
102
103 %files
104 %defattr(644,root,root,755)
105 %doc docs/*
106 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.06571 seconds and 2 git commands to generate.