]> git.pld-linux.org Git - packages/anyterm.git/blob - anyterm.spec
8def04cd5698643c43f6506a114273dfd9e1cc5c
[packages/anyterm.git] / anyterm.spec
1 %define         apxs            /usr/sbin/apxs
2 Summary:        Terminal emulator in a web browser
3 Name:           anyterm
4 Version:        1.1.4
5 Release:        0.3
6 Epoch:          0
7 License:        GPL
8 Group:          Networking/Daemons
9 Source0:        http://anyterm.org/download/%{name}-%{version}.tbz2
10 # Source0-md5:  cf841703b7438866e573f5a33137ff6f
11 Patch0:         %{name}-makefile.patch
12 URL:            http://anyterm.org/
13 BuildRequires:  apache-devel >= 2.0.52-2
14 BuildRequires:  apr-devel
15 BuildRequires:  rote-devel >= 0.2.8
16 BuildRequires:  rpmbuild(macros) >= 1.228
17 BuildRequires:  %{apxs}
18 Requires:       apache >= 2.0.52-2
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _appdir         %{_datadir}/%{name}
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir /etc/httpd
24
25 %description
26 An apache module plus scripts to make a terminal within a web browser.
27
28 %prep
29 %setup -q
30 %patch0 -p1
31 mv -f browser/.htaccess htaccess
32
33 %build
34 %{__make} -C apachemod \
35         INCLUDES='-I%{_includedir}/apr-util' \
36         APXS2=%{apxs} \
37         APR_CONFIG=apr-1-config
38 %{__make} -C anygetty
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/httpd.conf,%{_pkglibdir},%{_mandir}/man8,%{_appdir}}
43
44 cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_anyterm.conf <<END
45 LoadModule anyterm modules/%{name}.so
46 <IfModule anyterm>
47         Alias /%{name} "%{_appdir}"
48         anyterm_command '%{_sbindir}/anygetty --remotehost "Anyterm: %h"'
49
50         <Files anyterm-module>
51                 SetHandler anyterm
52         </Files>
53 </IfModule>
54 # vim: filetype=apache ts=4 sw=4 et
55 END
56
57 install apachemod/.libs/%{name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{name}.so
58 cp -a browser/* $RPM_BUILD_ROOT%{_appdir}
59 install anygetty/anygetty $RPM_BUILD_ROOT/%{_sbindir}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %service httpd restart
66
67 %banner %{name} <<EOF
68 For full function, setuid %{_sbindir}/anygetty.
69 EOF
70
71 %preun
72 if [ "$1" = "0" ]; then
73         %service -q httpd restart
74 fi
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README CHANGELOG htaccess
79 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*
80 %attr(755,root,root) %{_pkglibdir}/%{name}.so
81 %attr(755,root,root) %{_sbindir}/anygetty
82 %{_appdir}
This page took 0.049429 seconds and 2 git commands to generate.