]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
- added securityfixes patch (advised by author), release 4
[packages/anubis.git] / anubis.spec
1 #
2 # Conditional build:
3 %bcond_with     gnutls          # use GnuTLS library instead of OpenSSL
4 %bcond_without  tcp_wrappers    # disable using tcp_wrappers for access control
5 %bcond_without  pam             # disable using of PAM authentcation
6 %bcond_without  gpgme           # disable using gpgme library for signing/encrypting with gnupg
7 %bcond_without  pcre            # disable using pcre library
8 #
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        An outgoing mail processor, and the SMTP tunnel
11 Summary(pl):    Procesor wychodz±cej poczty i tunel SMTP
12 Name:           anubis
13 Version:        3.6.2
14 Release:        4
15 License:        GPL
16 Group:          Applications/Mail
17 Source0:        ftp://ftp.gnu.org/gnu/anubis/%{name}-%{version}.tar.gz
18 # Source0-md5:  9e705e38cafe4a57025a6ad89fd73226
19 Source1:        %{name}.init
20 Source2:        %{name}.pamd
21 Patch0:         %{name}-info.patch
22 Patch1:         %{name}-configure_gpgme.patch
23 Patch2:         %{name}-boundary.patch
24 Patch3:         %{name}-nolibnsl.patch
25 Patch4:         %{name}-securityfixes.patch
26 URL:            http://www.gnu.org/software/anubis/
27 BuildRequires:  gettext-devel >= 0.12.1
28 BuildRequires:  autoconf >= 2.54
29 BuildRequires:  automake >= 1.7
30 BuildRequires:  bison
31 %{?with_gnutls:BuildRequires:   gnutls-devel}
32 %{?with_gpgme:BuildRequires:    gpgme-devel >= 0.3.12}
33 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
34 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7c}
35 %{?with_pam:BuildRequires:      pam-devel}
36 %{?with_pcre:BuildRequires:     pcre-devel}
37 BuildRequires:  rpm-perlprov
38 BuildRequires:  texinfo
39 PreReq:         rc-scripts
40 Requires(post,preun):   /sbin/chkconfig
41 Requires:       identserver
42 Requires:       pam >= 0.77.3
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 GNU Anubis is an outgoing mail processor. It goes between the MUA
47 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
48 on the fly various sorts of processing and conversion on the outgoing
49 mail in accord with the sender's specified rules, based on a highly
50 configurable regular expressions system. It operates as a proxy
51 server, independently from mail user agents. GNU Anubis can edit
52 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
53 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
54 using the TLS/SSL encryption even if your mail user agent doesn't
55 support it, or tunnel a connection through a SOCKS proxy. Moreover,
56 GNU Anubis supports the remailers (it allows sending mail in an
57 anonymous way).
58
59 Remember, that to use per-user configuration files ident server has to
60 be running. Without it only system-wide configuration file is used.
61
62 If you want to use GNU Anubis with mutt mail client, install msg2smtp
63 package.
64
65 %description -l pl
66 GNU Anubis zajmuje siê przetwarzaniem poczty wychodz±cej. Znajduje siê
67 on pomiêdzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i mo¿e
68 wykonywaæ w locie ró¿ne rodzaje przetwarzania i konwersji poczty
69 wychodz±cej zale¿nie od podanych regu³, bazuj±cych na wysoce
70 konfigurowalnym systemie wyra¿eñ regularnych. GNU Anubis dzia³a jako
71 serwer proxy, niezale¿nie od programów pocztowych. Potrafi on zmieniaæ
72 nag³ówki listów, szyfrowaæ lub podpisywaæ jest przy pomocy GNU Privacy
73 Guard, tworzyæ bezpieczne tunele SMTP u¿ywaj±c szyfrowania TLS/SSL
74 nawet, gdy Twój program pocztowy nie ma takich mo¿liwo¶ci. Mo¿liwe
75 jest te¿ tunelowanie po³±czeñ przez SOCKS proxy.
76 Co wiêcej, GNU Anubis wspiera tak¿e remailery (czyli pozawala na
77 anonimowe wysy³anie poczty).
78
79 Pamiêtaj, ¿e aby u¿ywaæ plików konfiguracyjnych u¿ytkowników, serwer
80 ident musi byæ aktywny. Inaczej, u¿yty bêdzie tylko g³ówny plik
81 konfiguracyjny.
82
83 Je¶li chcesz u¿ywaæ GNU Anubis z klientem poczty mutt, zainstaluj
84 pakiet msg2smtp.
85
86 %package -n msg2smtp
87 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
88 Summary(pl):    msg2smtp wysy³a pocztê przyjmowan± na wej¶ciu do serwera SMTP
89 Group:          Applications/Mail
90
91 %description -n msg2smtp
92 The msg2smtp script is a bridge between MUA programs which use
93 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
94 particularly useful when used in connection with GNU Anubis mail
95 processor.
96
97 %description -n msg2smtp -l pl
98 Skrypt msg2smtp jest pomostem miêdzy programami pocztowymi u¿ywaj±cymi
99 polecenia "sendmail" do wysy³ania listów (np. Mutt), a serwerem smtp.
100 Jest on szczególnie przydatny w po³±czeniu z procesorem poczty GNU
101 Anubis.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109 %patch4 -p1
110
111 %build
112 %{__gettextize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__automake}
116 %configure \
117 %{!?with_gnutls:        --without-gnutls} \
118 %{!?with_gnutls:        --with-openssl} \
119 %{?with_pam:            --with-pam} \
120 %{?with_pcre:           --with-pcre} \
121 %{!?with_gpgme:         --without-gpgme} \
122 %{?with_tcp_wrappers:   --with-tcp-wrappers} \
123         --disable-dependency-tracking
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
135 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
136 install ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
137 %{?with_pam:install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
138 cp -f ./examples/1anubisrc examples/anubisrc
139
140 %find_lang %{name}
141
142 %clean
143 rm -fr $RPM_BUILD_ROOT
144
145 %post
146 /sbin/chkconfig --add anubis
147 if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
148         /etc/rc.d/init.d/anubis restart >&2
149 else
150         echo "Run \"/etc/rc.d/init.d/anubis start\" to start anubis." >&2
151 fi
152 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
153
154
155 %preun
156 if [ "$1" = "0" ]; then
157         if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
158                 /etc/rc.d/init.d/anubis stop
159         fi
160         /sbin/chkconfig --del anubis
161 fi
162
163 %postun
164 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc
169 %{?with_pam:%doc examples/pam}
170 %attr(754,root,root) /etc/rc.d/init.d/anubis
171 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/anubisrc
172 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/anubis}
173 %attr(755,root,root) %{_sbindir}/anubis
174 %{_mandir}/man1/*
175 %{_infodir}/*info*
176
177 %files -n msg2smtp
178 %defattr(644,root,root,755)
179 %doc contrib/msg2smtp.txt
180 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.072984 seconds and 3 git commands to generate.