]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
9e07db96856d41c068db1493f45c34142dbcf2b4
[packages/anubis.git] / anubis.spec
1 #
2 # Conditional build:
3 %bcond_with     gnutls          # use GnuTLS library instead of OpenSSL
4 %bcond_without  tcp_wrappers    # disable using tcp_wrappers for access control
5 %bcond_without  pam             # disable using of PAM authentcation
6 %bcond_without  gpgme           # disable using gpgme library for signing/encrypting with gnupg
7 %bcond_without  pcre            # disable using pcre library
8 #
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        An outgoing mail processor, and the SMTP tunnel
11 Summary(pl):    Procesor wychodz±cej poczty i tunel SMTP
12 Name:           anubis
13 Version:        3.6.2
14 Release:        3
15 License:        GPL
16 Group:          Applications/Mail
17 Source0:        ftp://ftp.gnu.org/gnu/anubis/%{name}-%{version}.tar.gz
18 # Source0-md5:  9e705e38cafe4a57025a6ad89fd73226
19 Source1:        %{name}.init
20 Source2:        %{name}.pamd
21 Patch0:         %{name}-info.patch
22 Patch1:         %{name}-configure_gpgme.patch
23 Patch2:         %{name}-boundary.patch
24 Patch3:         %{name}-nolibnsl.patch
25 URL:            http://www.gnu.org/software/anubis/
26 BuildRequires:  gettext-devel >= 0.12.1
27 BuildRequires:  autoconf >= 2.54
28 BuildRequires:  automake >= 1.7
29 BuildRequires:  bison
30 %{?with_gnutls:BuildRequires:   gnutls-devel}
31 %{?with_gpgme:BuildRequires:    gpgme-devel >= 0.3.12}
32 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
33 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7c}
34 %{?with_pam:BuildRequires:      pam-devel}
35 %{?with_pcre:BuildRequires:     pcre-devel}
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  texinfo
38 PreReq:         rc-scripts
39 Requires(post,preun):   /sbin/chkconfig
40 Requires:       identserver
41 Requires:       pam >= 0.77.3
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GNU Anubis is an outgoing mail processor. It goes between the MUA
46 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
47 on the fly various sorts of processing and conversion on the outgoing
48 mail in accord with the sender's specified rules, based on a highly
49 configurable regular expressions system. It operates as a proxy
50 server, independently from mail user agents. GNU Anubis can edit
51 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
52 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
53 using the TLS/SSL encryption even if your mail user agent doesn't
54 support it, or tunnel a connection through a SOCKS proxy. Moreover,
55 GNU Anubis supports the remailers (it allows sending mail in an
56 anonymous way).
57
58 Remember, that to use per-user configuration files ident server has to
59 be running. Without it only system-wide configuration file is used.
60
61 If you want to use GNU Anubis with mutt mail client, install msg2smtp
62 package.
63
64 %description -l pl
65 GNU Anubis zajmuje siê przetwarzaniem poczty wychodz±cej. Znajduje siê
66 on pomiêdzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i mo¿e
67 wykonywaæ w locie ró¿ne rodzaje przetwarzania i konwersji poczty
68 wychodz±cej zale¿nie od podanych regu³, bazuj±cych na wysoce
69 konfigurowalnym systemie wyra¿eñ regularnych. GNU Anubis dzia³a jako
70 serwer proxy, niezale¿nie od programów pocztowych. Potrafi on zmieniaæ
71 nag³ówki listów, szyfrowaæ lub podpisywaæ jest przy pomocy GNU Privacy
72 Guard, tworzyæ bezpieczne tunele SMTP u¿ywaj±c szyfrowania TLS/SSL
73 nawet, gdy Twój program pocztowy nie ma takich mo¿liwo¶ci. Mo¿liwe
74 jest te¿ tunelowanie po³±czeñ przez SOCKS proxy.
75 Co wiêcej, GNU Anubis wspiera tak¿e remailery (czyli pozawala na
76 anonimowe wysy³anie poczty).
77
78 Pamiêtaj, ¿e aby u¿ywaæ plików konfiguracyjnych u¿ytkowników, serwer
79 ident musi byæ aktywny. Inaczej, u¿yty bêdzie tylko g³ówny plik
80 konfiguracyjny.
81
82 Je¶li chcesz u¿ywaæ GNU Anubis z klientem poczty mutt, zainstaluj
83 pakiet msg2smtp.
84
85 %package -n msg2smtp
86 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
87 Summary(pl):    msg2smtp wysy³a pocztê przyjmowan± na wej¶ciu do serwera SMTP
88 Group:          Applications/Mail
89
90 %description -n msg2smtp
91 The msg2smtp script is a bridge between MUA programs which use
92 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
93 particularly useful when used in connection with GNU Anubis mail
94 processor.
95
96 %description -n msg2smtp -l pl
97 Skrypt msg2smtp jest pomostem miêdzy programami pocztowymi u¿ywaj±cymi
98 polecenia "sendmail" do wysy³ania listów (np. Mutt), a serwerem smtp.
99 Jest on szczególnie przydatny w po³±czeniu z procesorem poczty GNU
100 Anubis.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108
109 %build
110 %{__gettextize}
111 %{__aclocal} -I m4
112 %{__autoconf}
113 %{__automake}
114 %configure \
115 %{!?with_gnutls:        --without-gnutls} \
116 %{!?with_gnutls:        --with-openssl} \
117 %{?with_pam:            --with-pam} \
118 %{?with_pcre:           --with-pcre} \
119 %{!?with_gpgme:         --without-gpgme} \
120 %{?with_tcp_wrappers:   --with-tcp-wrappers} \
121         --disable-dependency-tracking
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
133 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
134 install ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
135 %{?with_pam:install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
136 cp -f ./examples/1anubisrc examples/anubisrc
137
138 %find_lang %{name}
139
140 %clean
141 rm -fr $RPM_BUILD_ROOT
142
143 %post
144 /sbin/chkconfig --add anubis
145 if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
146         /etc/rc.d/init.d/anubis restart >&2
147 else
148         echo "Run \"/etc/rc.d/init.d/anubis start\" to start anubis." >&2
149 fi
150 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
151
152
153 %preun
154 if [ "$1" = "0" ]; then
155         if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
156                 /etc/rc.d/init.d/anubis stop
157         fi
158         /sbin/chkconfig --del anubis
159 fi
160
161 %postun
162 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc
167 %{?with_pam:%doc examples/pam}
168 %attr(754,root,root) /etc/rc.d/init.d/anubis
169 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/anubisrc
170 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/anubis}
171 %attr(755,root,root) %{_sbindir}/anubis
172 %{_mandir}/man1/*
173 %{_infodir}/*info*
174
175 %files -n msg2smtp
176 %defattr(644,root,root,755)
177 %doc contrib/msg2smtp.txt
178 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.036469 seconds and 2 git commands to generate.