]> git.pld-linux.org Git - packages/antlr.git/commitdiff
- rel 8; fixed build (patch from gentoo) auto/th/antlr-2_7_7-8
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 24 Nov 2010 08:19:04 +0000 (08:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    antlr-gentoo.patch -> 1.1
    antlr.spec -> 1.60

antlr-gentoo.patch [new file with mode: 0644]
antlr.spec

diff --git a/antlr-gentoo.patch b/antlr-gentoo.patch
new file mode 100644 (file)
index 0000000..d8ccfbb
--- /dev/null
@@ -0,0 +1,89 @@
+diff -Naur antlr-2.7.7.orig/lib/cpp/antlr/CharScanner.hpp antlr-2.7.7/lib/cpp/antlr/CharScanner.hpp
+--- antlr-2.7.7.orig/lib/cpp/antlr/CharScanner.hpp     2006-11-01 22:37:17.000000000 +0100
++++ antlr-2.7.7/lib/cpp/antlr/CharScanner.hpp  2008-03-19 20:09:21.000000000 +0100
+@@ -10,6 +10,7 @@
+ #include <antlr/config.hpp>
++#include <cstring>
+ #include <map>
+ #ifdef HAS_NOT_CCTYPE_H
+--- antlr/lib/cpp/antlr/CharScanner.hpp~      2008-11-11 21:24:02.000000000 +0000
++++ anrlt/lib/cpp/antlr/CharScanner.hpp       2008-11-11 21:24:33.000000000 +0000
+@@ -10,6 +10,7 @@
+
+ #include <antlr/config.hpp>
+
++#include <cstdio>
+ #include <cstring>
+ #include <map>
+
+diff -Nur antlr-2.7.7/examples/cpp/inherit.tinyc/Makefile.in antlr-2.7.7_patched/examples/cpp/inherit.tinyc/Makefile.in
+--- antlr-2.7.7/examples/cpp/inherit.tinyc/Makefile.in 2006-11-01 23:37:17.000000000 +0200
++++ antlr-2.7.7_patched/examples/cpp/inherit.tinyc/Makefile.in 2009-03-30 02:09:28.000000000 +0300
+@@ -143,7 +143,7 @@
+ @abs_this_builddir@/examples/cpp/tinyc/TinyCLexer.cpp \
+ @abs_this_builddir@/examples/cpp/tinyc/TinyCLexer.hpp \
+       :
+-      @ @MAKE@ -C @abs_this_builddir@/examples/cpp/tinyc
++      @ $(MAKE) -C @abs_this_builddir@/examples/cpp/tinyc
+ $(objdir)/.subc.g : $(srcdir)/subc.g $(objdir)/TinyCParserTokenTypes.txt @ANTLR_JAR@
+       @ANTLRFLAGS="-glib `@CYGPATH_W@ $(_srcdir)/../tinyc/tinyc.g` -o `@CYGPATH_W@ $(thisdir)`" @ANTLR_COMPILE_CMD@ $(srcdir)/subc.g
+diff -Nur antlr-2.7.7/examples/java/inherit.tinyc/Makefile.in antlr-2.7.7_patched/examples/java/inherit.tinyc/Makefile.in
+--- antlr-2.7.7/examples/java/inherit.tinyc/Makefile.in        2006-11-01 23:37:17.000000000 +0200
++++ antlr-2.7.7_patched/examples/java/inherit.tinyc/Makefile.in        2009-03-30 02:07:25.000000000 +0300
+@@ -77,7 +77,7 @@
+       @ @CP@ $< $@
+ @abs_this_builddir@/examples/java/tinyc/TinyCParserTokenTypes.txt     :
+-      @ @MAKE@ -C @abs_this_builddir@/examples/java/tinyc test
++      @ $(MAKE) -C @abs_this_builddir@/examples/java/tinyc test
+ ## How to generated *.java ..
+diff -Nur antlr-2.7.7/examples/python/inherit.tinyc/Makefile.in antlr-2.7.7_patched/examples/python/inherit.tinyc/Makefile.in
+--- antlr-2.7.7/examples/python/inherit.tinyc/Makefile.in      2006-11-01 23:37:18.000000000 +0200
++++ antlr-2.7.7_patched/examples/python/inherit.tinyc/Makefile.in      2009-03-30 02:09:07.000000000 +0300
+@@ -61,11 +61,11 @@
+ ## file resides. Therefore we are going to "make" the base
+ ## grammar first and then copy required vocabulary over ..
+ TinyCTokenTypes.txt : 
+-      @MAKE@ -C ../tinyc
++      $(MAKE) -C ../tinyc
+       @CP@ ../tinyc/$@ $@
+ @abs_this_builddir@/examples/python/tinyc/%.py :
+-      @MAKE@ -C ../tinyc
++      $(MAKE) -C ../tinyc
+ test :: test1
+diff -Nur antlr-2.7.7/Makefile.in antlr-2.7.7_patched/Makefile.in
+--- antlr-2.7.7/Makefile.in    2006-11-01 23:37:18.000000000 +0200
++++ antlr-2.7.7_patched/Makefile.in    2009-03-30 02:05:41.000000000 +0300
+@@ -31,7 +31,7 @@
+ test clean distclean install ::
+       @ if test -f examples/Makefile ; then \
+-              @MAKE@ -C examples $@ ; \
++              $(MAKE) -C examples $@ ; \
+       fi
+ # Rule  to  remove  all objects, cores, ANTLR generated,
+diff -Nur antlr-2.7.7/scripts/config.make.in antlr-2.7.7_patched/scripts/config.make.in
+--- antlr-2.7.7/scripts/config.make.in 2006-11-01 23:37:18.000000000 +0200
++++ antlr-2.7.7_patched/scripts/config.make.in 2009-03-30 02:04:54.000000000 +0300
+@@ -47,9 +47,9 @@
+               *) \
+               if test -f "$${d}/Makefile" ; then \
+                 echo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>" ; \
+-                echo ">> @MAKE@ -C $(subdir)/$${d} $@                          " ; \
++                echo ">> $(MAKE) -C $(subdir)/$${d} $@                          " ; \
+                       echo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>" ; \
+-                      @MAKE@ -C "$$d" $@ || exit 1 ;\
++                      $(MAKE) -C "$$d" $@ || exit 1 ;\
+               fi ; \
+               ;; \
+               esac ; \
index 98f8e50cc36bc4c4b3f36d08a20a68353eaf8095..369fb6e56111892c95ad5327bdd78c34ceef61a9 100644 (file)
@@ -21,13 +21,14 @@ Summary:    ANother Tool for Language Recognition
 Summary(pl.UTF-8):     Jeszcze jedno narzędzie do rozpoznawania języka
 Name:          antlr
 Version:       2.7.7
-Release:       7
+Release:       8
 License:       Public Domain
 Group:         Development/Tools
 Source0:       http://www.antlr2.org/download/%{name}-%{version}.tar.gz
 # Source0-md5: 01cc9a2a454dd33dcd8c856ec89af090
 Patch0:                %{name}-DESTDIR.patch
 Patch1:                %{name}-strcasecmp.patch
+Patch2:                %{name}-gentoo.patch
 URL:           http://www.antlr2.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -106,6 +107,7 @@ Przykładowe programy używające ANTLR.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 cp -f /usr/share/automake/config.sub scripts
This page took 0.07355 seconds and 4 git commands to generate.