]> git.pld-linux.org Git - packages/ant-cpptasks.git/blob - ant-cpptasks.spec
- adapterized
[packages/ant-cpptasks.git] / ant-cpptasks.spec
1
2 %if "%{pld_release}" == "ti"
3 %bcond_without  java_sun        # build with gcj
4 %else
5 %bcond_with     java_sun        # build with java-sun
6 %endif
7 #
8 %include        /usr/lib/rpm/macros.java
9
10 %define         _rc     b5
11
12 Summary:        C/C++, FORTRAN, MIDL and Windows Resource compilers tasks for ant
13 Name:           ant-cpptasks
14 Version:        1.0
15 Release:        0.%{_rc}.1
16 License:        Apache v2.0
17 Group:          Development/Languages/Java
18 Source0:        http://dl.sourceforge.net/project/ant-contrib/ant-contrib/cpptasks-1.0-beta5/cpptasks-%{version}%{_rc}.tar.gz
19 # Source0-md5:  7f0f7732acd0c82f7efb228f667ec79a
20 URL:            http://sf.net/projects/ant-contrib
21 BuildRequires:  ant
22 %{!?with_java_sun:BuildRequires:        java-gcj-compat-devel}
23 %{?with_java_sun:BuildRequires: java-sun}
24 BuildRequires:  java-xerces
25 BuildRequires:  jpackage-utils
26 BuildRequires:  rpm >= 4.4.9-56
27 BuildRequires:  rpm-javaprov
28 BuildRequires:  rpmbuild(macros) >= 1.300
29 # for %{_javadir}
30 Requires:       jpackage-utils
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The cc task can compile various source languages and produce
36 executables, shared libraries (aka DLL's) and static libraries.
37 Compiler adaptors are currently available for C/C++, FORTRAN, MIDL and
38 Windows Resource compilers.
39
40 %prep
41 %setup -q -n cpptasks-%{version}%{_rc}
42
43 %build
44 export JAVA_HOME="%{java_home}"
45
46 required_jars="xerces-j2"
47 CLASSPATH=$(build-classpath $required_jars)
48
49 %ant
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_javadir}/ant
54
55 # jars
56 cp -a target/lib/cpptasks.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-cpptasks.jar
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %{_javadir}/ant/*.jar
This page took 0.075538 seconds and 3 git commands to generate.