]> git.pld-linux.org Git - packages/ansible.git/commitdiff
new, version 1.1
authorElan Ruusamäe <glen@delfi.ee>
Tue, 7 May 2013 11:52:15 +0000 (14:52 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 7 May 2013 11:52:15 +0000 (14:52 +0300)
ansible.spec [new file with mode: 0644]

diff --git a/ansible.spec b/ansible.spec
new file mode 100644 (file)
index 0000000..09c95f3
--- /dev/null
@@ -0,0 +1,61 @@
+Summary:       Minimal SSH command and control
+Name:          ansible
+Version:       1.1
+Release:       0.1
+License:       GPL v3+
+Group:         Development/Libraries
+Source0:       https://github.com/ansible/ansible/archive/release%{version}.tar.gz
+# Source0-md5: 92e66d233fd7130ea23dfb61ba3b4856
+URL:           http://ansible.github.com/
+BuildRequires: rpmbuild(macros) >= 1.219
+Requires:      python-PyYAML
+Requires:      python-jinja2
+Requires:      python-paramiko
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Ansible is a radically simple model-driven configuration management,
+multi-node deployment, and remote task execution system. Ansible works
+over SSH and does not require any software or daemons to be installed
+on remote nodes. Extension modules can be written in any language and
+are transferred to managed machines automatically.
+
+%prep
+%setup -q -n %{name}-release%{version}
+
+%build
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install \
+       --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+%py_postclean
+
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_datadir}/%{name},%{_mandir}/man1}
+cp -p examples/hosts $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
+cp -p docs/man/man1/ansible.1 $RPM_BUILD_ROOT%{_mandir}/man1/ansible.1
+cp -p docs/man/man1/ansible-playbook.1 $RPM_BUILD_ROOT%{_mandir}/man1/ansible-playbook.1
+cp -a library/* $RPM_BUILD_ROOT%{_datadir}/%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc VERSION *.md
+%dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/hosts
+%attr(755,root,root) %{_bindir}/ansible
+%attr(755,root,root) %{_bindir}/ansible-doc
+%attr(755,root,root) %{_bindir}/ansible-playbook
+%attr(755,root,root) %{_bindir}/ansible-pull
+%{_mandir}/man1/ansible.1*
+%{_mandir}/man1/ansible-playbook.1*
+%{_datadir}/%{name}
+%{py_sitescriptdir}/ansible
+%{py_sitescriptdir}/ansible-%{version}-*.egg-info
This page took 0.110478 seconds and 4 git commands to generate.