]> git.pld-linux.org Git - packages/anjuta.git/blob - anjuta.spec
8353d78150625015c92ac2d165a4e8c9256a5953
[packages/anjuta.git] / anjuta.spec
1 Summary:        GNOME integrated development environment
2 Summary(es):    Entorno integrado de desarrollo (IDE) de GNOME
3 Summary(pl):    Zintegrowane ¶rodowisko programowania dla GNOME
4 Summary(pt_BR): Ambiente de desenvolvimento integrado C e C++
5 Name:           anjuta
6 Version:        2.0.2
7 Release:        1
8 Epoch:          1
9 License:        GPL
10 Group:          Development/Tools
11 Source0:        http://dl.sourceforge.net/anjuta/%{name}-%{version}.tar.gz
12 # Source0-md5:  e0d1e216da809df32816d233d7c55165
13 #Patch0: %{name}-home_etc.patch
14 Patch1:         %{name}-desktop.patch
15 URL:            http://anjuta.sourceforge.net/
16 BuildRequires:  ORBit2-devel >= 1:2.12.1
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  autogen
19 BuildRequires:  automake
20 BuildRequires:  devhelp-devel
21 BuildRequires:  gdl-devel >= 0.6.1
22 BuildRequires:  gettext-devel
23 BuildRequires:  gnome-build-devel
24 BuildRequires:  gnome-common >= 2.8.0
25 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
26 BuildRequires:  gtk-doc
27 BuildRequires:  intltool
28 BuildRequires:  libglade2-devel >= 1:2.5.1
29 BuildRequires:  libgnomeprintui-devel >= 2.10.2
30 BuildRequires:  libgnomeui-devel >= 2.10.0-2
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool
33 BuildRequires:  libxml2-devel >= 1:2.6.19
34 BuildRequires:  ncurses-devel
35 BuildRequires:  neon-devel
36 BuildRequires:  pcre-devel >= 3.9
37 BuildRequires:  pkgconfig
38 BuildRequires:  popt-devel
39 BuildRequires:  rpmbuild(macros) >= 1.197
40 BuildRequires:  scrollkeeper
41 BuildRequires:  subversion-devel
42 BuildRequires:  vte-devel >= 0.11.0
43 Requires(post,postun):  scrollkeeper
44 # Requires:     gnome-terminal
45 Requires:       libanjuta = %{epoch}:%{version}-%{release}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Anjuta is a very versatile integrated development environment for C
50 and C++ for GNU/Linux. Written in GTK/GNOME and written for GTK/GNOME,
51 it features many advanced programming tools and utilities. Besides
52 many other, it has project management, application wizards, onboard
53 interactive debugger, and a powerful source editor with source
54 browsing.
55
56 %description -l es
57 Anjuta es un entorno integrado de desarrollo para C y C++ para
58 GNU/Linux. Escrito en y para GTK/GNOME, proporciona muchas
59 herramientas de programación avanzadas. Entre otros, habilita
60 manejamiento de proyectos, wizards de aplicaciones, depurador
61 interactivo y un editador potente de código fuente que permite
62 hojearlo.
63
64 %description -l pl
65 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
66 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
67 GTK/GNOME, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
68 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
69 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
70
71 %description -l pt_BR
72 O Anjuta é um ambiente de desenvolvimento integrado (IDE) versátil
73 para as linguagens C e C++. Foi escrito para o GTK/GNOME e tem uma
74 série de características de programação avançadas. Basicamente é uma
75 interface gráfica com o usuário para um conjunto de utilitários de
76 linha de comando e ferramentas para programação para o Linux. Estas
77 são geralmente executadas em um console em modo texto e podem ser não
78 amigáveis.
79
80 %package -n libanjuta
81 Summary:        libanjuta library
82 Group:          Development/Libraries
83 Conflicts:      %{name} < 1:2.0.2-1
84
85 %description -n libanjuta
86 libanjuta library.
87
88 %package -n libanjuta-devel
89 Summary:        Header files and develpment documentation for libanjuta
90 Group:          Development/Libraries
91 Requires:       libanjuta-devel = %{epoch}:%{version}-%{release}
92
93 %description -n libanjuta-devel
94 Header files and develpment documentation for libanjuta.
95
96 %prep
97 %setup -q
98 #%patch0 -p1 NEEDS checking
99 %patch1 -p1
100
101 %{__perl} -pi -e 's@^(packageplugindir=)lib/@$1%{_lib}/@' configure.in
102
103 %build
104 CXXFLAGS="%{rpmcflags} -fno-exceptions"
105 CFLAGS="%{rpmcflags} -fno-omit-frame-pointer"
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoheader}
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         --with-html-dir=%{_gtkdocdir} \
113         --with-apr-config=%{_bindir}/apr-1-config \
114         --with-apu-config=%{_bindir}/apu-1-config \
115         --with-neon-config=%{_bindir}/neon-config \
116         --disable-static
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT \
124         gnomemenudir=%{_desktopdir}
125
126 # *.la not needed - *.so loaded through libgmodule
127 rm -f $RPM_BUILD_ROOT%{_libdir}/anjuta/lib*.la
128
129 rm -r $RPM_BUILD_ROOT%{_datadir}/mime-info
130
131 %find_lang %{name} --with-gnome
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 %scrollkeeper_update_post
138
139 %postun
140 %scrollkeeper_update_postun
141
142 %post   -n libanjuta -p /sbin/ldconfig
143 %postun -n libanjuta -p /sbin/ldconfig
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog FUTURE NEWS README TODO doc/ScintillaDoc.html
148 %attr(755,root,root) %{_bindir}/*
149 %dir %{_libdir}/%{name}
150 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
151 %{_libdir}/%{name}/*.plugin
152 %{_pixmapsdir}/%{name}
153 %{_datadir}/%{name}
154 %{_datadir}/application-registry/*.*
155 %{_datadir}/mime/packages/*.*
156 %{_desktopdir}/*.desktop
157 %{_mandir}/man1/*
158 %{_omf_dest_dir}/%{name}
159 %{_sysconfdir}/gconf/schemas/*.*
160 %{_iconsdir}/*/*/*/*.*
161
162 %files -n libanjuta
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/*.so.*
165
166 %files -n libanjuta-devel
167 %defattr(644,root,root,755)
168 %{_includedir}/libanjuta-*
169 %attr(755,root,root) %{_libdir}/*.so
170 %{_libdir}/*.la
171 %{_pkgconfigdir}/*.pc
172 %{_gtkdocdir}/libanjuta
This page took 0.055286 seconds and 2 git commands to generate.