]> git.pld-linux.org Git - packages/amrita2.git/blob - amrita2.spec
- added
[packages/amrita2.git] / amrita2.spec
1 %define         ruby_archdir    %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')
2 %define         ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
3 Summary:        An HTML/XHTML template library for Ruby
4 Summary(pl):    Biblioteka szablonów HTML/XHTML dla jêzyka Ruby
5 Name:           amrita2
6 Version:        1.9.2
7 Release:        1
8 License:        GPL
9 Group:          Development/Libraries
10 Source0:        http://rubyforge.org/frs/download.php/3289/%{name}_050304.tar.gz
11 # Source0-md5:  61ea202b26b36f9780f9229d74737171
12 Source1:        setup.rb
13 URL:            http://amrita2.rubyforge.org/
14 BuildRequires:  ruby
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 An HTML/XHTML template library for Ruby.
19
20 %description -l pl
21 Biblioteka szablonów HTML/XHTML dla jêzyka Ruby.
22
23 %prep
24 %setup -q -n %{name}
25 cp %{SOURCE1} .
26
27 %build
28 ruby setup.rb config \
29         --site-ruby=%{ruby_rubylibdir} \
30         --so-dir=%{ruby_archdir}
31
32 ruby setup.rb setup 
33
34 rdoc --op rdoc -S --main README README docs/*
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 ruby setup.rb install \
40         --prefix=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc ChangeLog sample rdoc/*
48 %attr(755,root,root) %{_bindir}/amrita_r
49 %dir %{ruby_rubylibdir}/%{name}
50 %{ruby_rubylibdir}/%{name}/*.rb
51 %{ruby_rubylibdir}/%{name}.rb
This page took 0.065707 seconds and 3 git commands to generate.