]> git.pld-linux.org Git - packages/amrita.git/blob - amrita.spec
ff44faed9de95ae0e5226c09e3dbd1a79568224e
[packages/amrita.git] / amrita.spec
1 %define ruby_archdir    %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')
2 %define ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
3 Summary:        An HTML/XHTML template library for Ruby
4 Summary(pl):    Biblioteka szablonów HTML/XHTML dla jêzyka Ruby
5 Name:           amrita
6 Version:        1.8.2
7 Release:        2
8 License:        GPL
9 Group:          Development/Libraries
10 Source0:        http://www.brain-tokyo.jp/research/amrita/%{name}-%{version}.tar.gz
11 # Source0-md5:  36dd153cef9481d853d09094b8daece7
12 Patch0:         %{name}-REXML.patch
13 URL:            http://www.brain-tokyo.jp/research/amrita/
14 BuildRequires:  ruby
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 An HTML/XHTML template library for Ruby.
19
20 %description -l pl
21 Biblioteka szablonów HTML/XHTML dla jêzyka Ruby.
22
23 %prep
24 %setup -q
25 %patch0 -p1
26
27 %build
28 ruby install.rb config \
29         --site-ruby=%{ruby_rubylibdir} \
30         --so-dir=%{ruby_archdir}
31
32 ruby install.rb setup 
33 rdoc docs README -o rdoc
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 ruby install.rb install \
39         --prefix=$RPM_BUILD_ROOT
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc ChangeLog docs README RELEASENOTE sample rdoc
47 %lang(ja) %doc README_ja
48 %attr(755,root,root) %{_bindir}/ams
49 %attr(755,root,root) %{_bindir}/amx
50 %attr(755,root,root) %{_bindir}/amshandler
51 %dir %{ruby_rubylibdir}/amrita
52 %{ruby_rubylibdir}/amrita/*.rb
53 %attr(755,root,root) %{ruby_archdir}/amrita_accel.so
This page took 0.051539 seconds and 2 git commands to generate.