]> git.pld-linux.org Git - packages/amavis.git/blob - amavis.spec
- Amavis-0.3.12 is the direct successor to amavis-perl-11
[packages/amavis.git] / amavis.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define         sub_ver pre2
3
4 Summary:        A Mail Virus Scanner
5 Summary(pl):    Antywirusowy skaner poczty elektronicznej
6 Name:           amavis
7 Version:        0.3.13%{sub_ver}
8 Release:        0.1
9 URL:            http://www.amavis.org/
10 Source0:        http://www.amavis.org/dist/perl/%{name}-%{version}.tar.gz
11 # Source0-md5:  2b90dba30a5ea2b73c2b348e26967f30
12 License:        GPL
13 Group:          Applications/Mail
14 Obsoletes:      AMaViS
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake
17 BuildRequires:  perl-modules
18 BuildRequires:  perl-Convert-UUlib
19 BuildRequires:  perl-Convert-TNEF
20 BuildRequires:  perl-Unix-Syslog
21 BuildRequires:  perl-Archive-Tar
22 BuildRequires:  perl-Archive-Zip
23 BuildRequires:  perl-Compress-Zlib
24 BuildRequires:  perl-MIME-tools
25 BuildRequires:  file
26 BuildRequires:  sh-utils
27 BuildRequires:  arc
28 BuildRequires:  bzip2
29 BuildRequires:  lha
30 BuildRequires:  unarj
31 BuildRequires:  ncompress
32 BuildRequires:  unrar
33 BuildRequires:  zoo
34 Requires(pre):  /bin/id
35 Requires(pre):  /usr/sbin/useradd
36 Requires(postun):       /usr/sbin/userdel
37 Requires:       file
38 Requires:       sh-utils
39 Requires:       arc
40 Requires:       bzip2
41 Requires:       lha
42 Requires:       unarj
43 Requires:       ncompress
44 Requires:       unrar
45 Requires:       zoo
46 Requires:       /usr/sbin/sendmail
47 Obsoletes:      amavisd
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 AMaViS is a script that interfaces a mail transport agent (MTA) with
52 one or more virus scanners.
53
54 %description -l pl
55 AMaViS to skrypt po¶rednicz±cy pomiêdzy agentem transferu poczty (MTA)
56 a jednym lub wiêcej programów antywirusowych.
57
58 %prep
59 %setup -q
60
61 %build
62 %{__aclocal}
63 %{__automake}
64 %{__autoconf}
65 %configure \
66         --enable-all \
67         --with-sendmail-wrapper=%{_sbindir}/sendmail \
68         --with-runtime-dir=/var/spool/amavis/runtime \
69         --with-virusdir=/var/spool/amavis/virusmails \
70         --with-mailto="postmaster" \
71         --with-amavisuser=amavis \
72         --with-perl=%{__perl}
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         amavisuser=$(id -u) \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %pre
87 if [ -n "`id -u amavis 2>/dev/null`" ]; then
88         if [ "`id -u amavis`" != "97" ]; then
89                 echo "Error: user amavis doesn't have uid=97. Correct this before installing amavis." 1>&2
90                 exit 1
91         fi
92 else
93         /usr/sbin/useradd -u 97 -r -d /var/spool/amavis  -s /bin/false -c "Anti Virus Checker" -g nobody  amavis 1>&2
94 fi
95
96 %postun
97 if [ "$1" = "0" ]; then
98         /usr/sbin/userdel amavis
99 fi
100
101 %files
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_sbindir}/*
104 %doc README* AUTHORS BUGS ChangeLog FAQ HINTS TODO doc/amavis.html doc/amavis.png
105 %attr(750,amavis,root) /var/spool/amavis
This page took 0.065133 seconds and 3 git commands to generate.