]> git.pld-linux.org Git - packages/amavis-stats.git/blob - amavis-stats.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/amavis-stats.git] / amavis-stats.spec
1 #
2 # TODO:
3 #   - add trigger to update apache configuration when upgrading from
4 #     older versions (not sure if this is required)
5 #
6 Summary:        Simple amavisd-new statistics generator
7 Summary(pl.UTF-8):      Prosty generator statystyk dla amavisd-new
8 Name:           amavis-stats
9 Version:        0.1.22
10 Release:        1
11 License:        GPL
12 Group:          Applications/System
13 Source0:        http://downloads.topicdesk.com/amavis_stats/%{name}-%{version}.tar.gz
14 # Source0-md5:  5bea6811c00a4fda4b96b6a318a04a92
15 Source1:        %{name}.init
16 Patch0:         %{name}-gzip.patch
17 Patch1:         %{name}-Makefile.patch
18 Patch2:         %{name}-pid.patch
19 URL:            http://osx.topicdesk.com/content/view/42/59/
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 BuildRequires:  sed >= 4.0
22 Provides:       %{name}-%{version}-%{release}
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _pkglibdir      /var/lib/%{name}
27 %define         _pkgcachedir    /var/cache/%{name}
28 %define         _webapps        /etc/webapps
29 %define         _webapp         %{name}
30 %define         _webappdir      %{_webapps}/%{_webapp}
31 %define         _appdir         %{_datadir}/%{_webapp}
32
33 %description
34 amavis-stats is a simple amavis statistics generator based on rrdtool.
35 It produces graphs from amavisd-new log entries of infections broken
36 down by virus.
37
38 %description -l pl.UTF-8
39 amavis-stats jest prostym generatorem statystyk opartym na rrdtool.
40 Tworzy wykresy zainfekowanych wiadomości, w rozbiciu na poszczególne
41 wirusy, na podstawie logów amavisd-new.
42
43 %package php
44 Summary:        PHP interface for amavis-stats
45 Summary(pl.UTF-8):      Interfejs PHP dla amavis-stats
46 Group:          Applications/System
47 Requires:       %{name}-%{version}-%{release}
48 Requires:       php(pcre)
49 Requires:       webapps
50 Requires:       webserver(php)
51
52 %description php
53 PHP interface for amavis-stats.
54
55 %description php -l pl.UTF-8
56 Interfejs PHP dla amavis-stats.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63
64 %build
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 sed -i -e '/basic_machine=powerpc-apple/s/$/\n\t\t;;\n\tnoarch-*)\n\t\tbasic_machine=noarch/;' config.sub
71 %configure \
72         --with-user=root \
73         --with-group=http \
74         --with-log-file=/var/log/maillog
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_webapps}/%{_webapp}}
84 mv $RPM_BUILD_ROOT{%{_datadir}/amavis-stats/amavis-stats.alias.conf,%{_webapps}/%{_webapp}/httpd.conf}
85 mv $RPM_BUILD_ROOT{%{_datadir}/amavis-stats/amavis-stats.php.conf,%{_webapps}/%{_webapp}}
86 ln -s %{_webapps}/%{_webapp}/amavis-stats.php.conf $RPM_BUILD_ROOT%{_datadir}/%{name}/amavis-stats.php.conf
87 cp $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/{httpd,apache}.conf
88 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/amavis-stats
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %triggerin php -- apache1 < 1.3.37-3, apache1-base
94 %webapp_register apache %{_webapp}
95
96 %triggerun php -- apache1 < 1.3.37-3, apache1-base
97 %webapp_unregister apache %{_webapp}
98
99 %triggerin php -- apache < 2.2.0, apache-base
100 %webapp_register httpd %{_webapp}
101
102 %triggerun php -- apache < 2.2.0, apache-base
103 %webapp_unregister httpd %{_webapp}
104
105 %triggerpostun php -- %{name}-php < 0.1.13-0.rc6.4.1
106 if [ -f /etc/httpd/httpd.conf ]; then
107         sed -i -e "/^Include.*%{name}\/apache.conf/d" /etc/httpd/httpd.conf
108 fi
109
110 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
111         cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
112         mv -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
113 fi
114
115 rm -f /etc/httpd/httpd.conf/99_%{name}.conf
116 /usr/sbin/webapp register httpd %{_webapp}
117 %service -q httpd reload
118
119 %files
120 %defattr(644,root,root,755)
121 %doc README ChangeLog
122 %attr(754,root,root) /etc/rc.d/init.d/amavis-stats
123 %attr(755,root,root) %{_sbindir}/amavis-stats
124 %dir %{_pkglibdir}
125 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/amavis-stats.conf
126 %{_mandir}/man1/*
127
128 %files php
129 %defattr(644,root,root,755)
130 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
133 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/amavis-stats.php.conf
134 %dir %{_appdir}
135 %{_appdir}/amavis-stats.php.conf
136 %{_appdir}/img
137 %{_appdir}/includes
138 %{_appdir}/index.php
139 %{_appdir}/templates
140 %{_appdir}/%{name}.php
141 %{_appdir}/%{name}.html
142 %{_appdir}/*.png
143 %{_appdir}/*.ttf
144 %attr(775,root,http) %dir %{_pkgcachedir}
This page took 0.047257 seconds and 3 git commands to generate.