]> git.pld-linux.org Git - packages/amavis-stats.git/blob - amavis-stats.spec
- updated to 0.1.22, not tested
[packages/amavis-stats.git] / amavis-stats.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Simple amavisd-new statistics generator
3 Summary(pl.UTF-8):      Prosty generator statystyk dla amavisd-new
4 Name:           amavis-stats
5 Version:        0.1.22
6 Release:        0.1
7 License:        GPL
8 Group:          Applications/System
9 Source0:        http://downloads.topicdesk.com/amavis_stats/%{name}-%{version}.tar.gz
10 # Source0-md5:  5bea6811c00a4fda4b96b6a318a04a92
11 Source1:        %{name}.cron
12 Patch0:         %{name}-gzip.patch
13 Patch1:         %{name}-Makefile.patch
14 URL:            http://osx.topicdesk.com/content/view/42/59/
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Provides:       %{name}-%{version}-%{release}
17 #BuildArch:     noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      /var/lib/%{name}
21 %define         _pkgcachedir    /var/cache/%{name}
22 %define         _webapps        /etc/webapps
23 %define         _webapp         %{name}
24 %define         _webappdir      %{_webapps}/%{_webapp}
25 %define         _appdir         %{_datadir}/%{_webapp}
26
27 %description
28 amavis-stats is a simple amavis statistics generator based on rrdtool.
29 It produces graphs from amavisd-new log entries of infections broken
30 down by virus.
31
32 %description -l pl.UTF-8
33 amavis-stats jest prostym generatorem statystyk opartym na rrdtool.
34 Tworzy wykresy zainfekowanych wiadomości, w rozbiciu na poszczególne
35 wirusy, na podstawie logów amavisd-new.
36
37 %package php
38 Summary:        PHP interface for amavis-stats
39 Summary(pl.UTF-8):      Interfejs PHP dla amavis-stats
40 Group:          Applications/System
41 Requires:       %{name}-%{version}-%{release}
42 Requires:       php(pcre)
43 Requires:       webapps
44 Requires:       webserver(php)
45
46 %description php
47 PHP interface for amavis-stats.
48
49 %description php -l pl.UTF-8
50 Interfejs PHP dla amavis-stats.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56
57 %build
58 %{__libtoolize}
59 %{__aclocal}
60 %{__autoconf}
61 %{__autoheader}
62 %{__automake}
63 %configure \
64         --with-user=http \
65         --with-group=http \
66         --with-log-file=/var/log/maillog
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT/etc/cron.d
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amavis-stats
77 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
78 mv $RPM_BUILD_ROOT{%{_datadir}/amavis-stats/amavis-stats.alias.conf,%{_webapps}/%{_webapp}/httpd.conf}
79 mv $RPM_BUILD_ROOT{%{_datadir}/amavis-stats/amavis-stats.php.conf,%{_webapps}/%{_webapp}}
80 ln -s %{_webapps}/%{_webapp}/amavis-stats.php.conf $RPM_BUILD_ROOT%{_datadir}/%{name}/amavis-stats.php.conf
81 cp $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/{httpd,apache}.conf
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %triggerin php -- apache1 < 1.3.37-3, apache1-base
87 %webapp_register apache %{_webapp}
88
89 %triggerun php -- apache1 < 1.3.37-3, apache1-base
90 %webapp_unregister apache %{_webapp}
91
92 %triggerin php -- apache < 2.2.0, apache-base
93 %webapp_register httpd %{_webapp}
94
95 %triggerun php -- apache < 2.2.0, apache-base
96 %webapp_unregister httpd %{_webapp}
97
98 %triggerpostun php -- %{name}-php < 0.1.13-0.rc6.4.1
99 if [ -f /etc/httpd/httpd.conf ]; then
100         sed -i -e "/^Include.*%{name}\/apache.conf/d" /etc/httpd/httpd.conf
101 fi
102
103 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
104         cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
105         mv -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
106 fi
107
108 rm -f /etc/httpd/httpd.conf/99_%{name}.conf
109 /usr/sbin/webapp register httpd %{_webapp}
110 %service -q httpd reload
111
112 %files
113 %defattr(644,root,root,755)
114 %doc README ChangeLog
115 %attr(755,root,root) %{_sbindir}/amavis-stats
116 %dir %{_pkglibdir}
117 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/amavis-stats
118 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/amavis-stats.conf
119 %{_mandir}/man1/*
120
121 %files php
122 %defattr(644,root,root,755)
123 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
124 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
125 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
126 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/amavis-stats.php.conf
127 %dir %{_appdir}
128 %{_appdir}/amavis-stats.php.conf
129 %{_appdir}/img
130 %{_appdir}/includes
131 %{_appdir}/index.php
132 %{_appdir}/templates
133 %{_appdir}/%{name}.php
134 %{_appdir}/%{name}.html
135 %{_appdir}/*.png
136 %{_appdir}/*.ttf
137 %attr(775,root,http) %dir %{_pkgcachedir}
This page took 0.085216 seconds and 3 git commands to generate.