]> git.pld-linux.org Git - packages/amarok.git/commitdiff
- add patch from gentoo
authorlisu <lisu@pld-linux.org>
Fri, 1 Jul 2011 14:11:07 +0000 (14:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    amarok-upnp-dep.patch -> 1.1
    amarok.spec -> 1.253

amarok-upnp-dep.patch [new file with mode: 0644]
amarok.spec

diff --git a/amarok-upnp-dep.patch b/amarok-upnp-dep.patch
new file mode 100644 (file)
index 0000000..c41c74b
--- /dev/null
@@ -0,0 +1,36 @@
+diff -urN amarok-2.4.0.90.orig/CMakeLists.txt amarok-2.4.0.90/CMakeLists.txt
+--- amarok-2.4.0.90.orig/CMakeLists.txt        2011-04-19 00:03:27.910000016 +0000
++++ amarok-2.4.0.90/CMakeLists.txt     2011-04-19 00:06:17.466666683 +0000
+@@ -105,6 +105,10 @@
+     macro_optional_find_package(QJSON)
+     macro_log_feature( QJSON_FOUND "QJson" "Qt JSON Parser used for the Playdar Collection" "http://qjson.sourceforge.net/" FALSE "" "" )
++    # HUpnp is required for the upnp plugin
++    macro_optional_find_package(HUpnp)
++    macro_log_feature ( HUPNP_FOUND "HUpnp" "HUpnp is an universal Plug and Play Library" "http://herqq.org/" FALSE "" "" )
++
+     # macro_optional_find_package(Strigi)
+     # macro_log_feature( STRIGI_FOUND "strigi" "Index metadata of files" "http://strigi.sourceforge.net" FALSE "" "" )
+diff -urN amarok-2.4.0.90.orig/src/core-impl/collections/CMakeLists.txt amarok-2.4.0.90/src/core-impl/collections/CMakeLists.txt
+--- amarok-2.4.0.90.orig/src/core-impl/collections/CMakeLists.txt      2011-04-19 00:03:27.940000015 +0000
++++ amarok-2.4.0.90/src/core-impl/collections/CMakeLists.txt   2011-04-19 00:07:06.753333348 +0000
+@@ -25,4 +25,6 @@
+ if( QJSON_FOUND )
+     add_subdirectory( playdarcollection )
+ endif( QJSON_FOUND )
+-add_subdirectory( upnpcollection )
++if( HUPNP_FOUND )
++    add_subdirectory( upnpcollection )
++endif( HUPNP_FOUND )
+diff -urN amarok-2.4.0.90.orig/cmake/modules/FindHUpnp.cmake amarok-2.4.0.90/cmake/modules/FindHUpnp.cmake
+--- amarok-2.4.0.90.orig/cmake/modules/FindHUpnp.cmake 2011-04-19 01:59:14.313333349 +0000
++++ amarok-2.4.0.90/cmake/modules/FindHUpnp.cmake      2011-04-19 02:14:13.670000016 +0000
+@@ -6,7 +6,7 @@
+ # HUPNP_LIBRARIES
+ # HUPNP_FOUND
+-find_path(HUPNP_INCLUDE_DIR HUpnp HINTS ${KDE4_INCLUDE_DIR})
++find_path(HUPNP_INCLUDE_DIR HUpnp HINTS ${KDE4_INCLUDE_DIR} /usr/include/HUpnpCore)
+ find_library(HUPNP_LIBRARIES HUpnp PATHS ${KDE4_LIB_DIR})
index 5d14ce3c2cbc28ee43b23ca88063ad7b8299ff1f..f12a936189b2607965c8441482e8b5611f49cf41 100644 (file)
@@ -19,6 +19,7 @@ Source0:      ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{vers
 # Source0-md5: 4c65c5cd4d7bd267bdbef8e912fd6cb6
 Patch0:                %{name}-disable_qtscriptbindings_check_fix.patch
 Patch1:                %{name}-ffmpeg08.patch
+Patch2:                %{name}-upnp-dep.patch
 URL:           http://amarok.kde.org/
 BuildRequires: QtNetwork-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
@@ -115,6 +116,7 @@ Więcej o skryptach w amaroKu można dowiedzieć się stąd:
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 install -d build
This page took 0.09469 seconds and 4 git commands to generate.