]> git.pld-linux.org Git - packages/amarok.git/commitdiff
- fix daglib detection auto/th/amarok-2.8.0-8
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 21 Mar 2016 14:31:03 +0000 (15:31 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 21 Mar 2016 14:31:03 +0000 (15:31 +0100)
- fix building with ffmpeg 3
- rel 8

amarok.spec
ffmpeg3.patch [new file with mode: 0644]
find-taglib.patch [new file with mode: 0644]

index 88592296d1fde9301a308b5e380acef4e92a39fe..d9b0f65fa039421438cf924dfe8647d9f78ac12b 100644 (file)
@@ -15,15 +15,24 @@ Summary:    A KDE audio player
 Summary(pl.UTF-8):     Odtwarzacz audio dla KDE
 Name:          amarok
 Version:       2.8.0
-Release:       7
+Release:       8
 License:       GPL v2+ and LGPL v2.1+
 Group:         X11/Applications/Multimedia
 Source0:       ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
 # Source0-md5: 53cfcb4819668b10e13b061478c7b32a
 Patch0:                %{name}-upnp-dep.patch
+Patch1:                find-taglib.patch
+Patch2:                ffmpeg3.patch
 URL:           http://amarok.kde.org/
+BuildRequires: QtCore-devel >= %{qtver}
+BuildRequires: QtGui-devel >= %{qtver}
 BuildRequires: QtNetwork-devel >= %{qtver}
+BuildRequires: QtOpenGL-devel >= %{qtver}
+BuildRequires: QtScript-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
+BuildRequires: QtSvg-devel >= %{qtver}
+BuildRequires: QtWebKit-devel >= %{qtver}
+BuildRequires: QtXml-devel >= %{qtver}
 BuildRequires: automoc4 >= 0.9.88
 BuildRequires: cmake >= 2.8.0
 BuildRequires: curl-devel
@@ -116,6 +125,8 @@ Więcej o skryptach w amaroKu można dowiedzieć się stąd:
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 install -d build
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
new file mode 100644 (file)
index 0000000..930d57f
--- /dev/null
@@ -0,0 +1,56 @@
+--- amarok-2.8.0/src/musicbrainz/MusicDNSAudioDecoder.cpp~     2013-08-14 22:22:52.000000000 +0200
++++ amarok-2.8.0/src/musicbrainz/MusicDNSAudioDecoder.cpp      2016-03-21 14:51:57.751931980 +0100
+@@ -223,7 +223,7 @@
+             {
+                 if( !decodedFrame )
+                 {
+-                    decodedFrame = avcodec_alloc_frame();
++                    decodedFrame = av_frame_alloc();
+                     if( !decodedFrame )
+                     {
+                         warning() << "Unable to allocate enough memory to decode file.";
+@@ -231,7 +231,7 @@
+                         break;
+                     }
+                     else
+-                        avcodec_get_frame_defaults( decodedFrame );
++                        av_frame_unref( decodedFrame );
+                 }
+                 decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
+@@ -341,7 +341,7 @@
+             {
+                 if( !decodedFrame )
+                 {
+-                    decodedFrame = avcodec_alloc_frame();
++                    decodedFrame = av_frame_alloc();
+                     if( !decodedFrame )
+                     {
+                         warning() << "Unable to allocate enough memory to decode file.";
+@@ -349,7 +349,7 @@
+                         break;
+                     }
+                     else
+-                        avcodec_get_frame_defaults( decodedFrame );
++                        av_frame_unref( decodedFrame );
+                 }
+                 decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
+@@ -459,7 +459,7 @@
+             {
+                 if( !decodedFrame )
+                 {
+-                    decodedFrame = avcodec_alloc_frame();
++                    decodedFrame = av_frame_alloc();
+                     if( !decodedFrame )
+                     {
+                         warning() << "Unable to allocate enough memory to decode file.";
+@@ -467,7 +467,7 @@
+                         break;
+                     }
+                     else
+-                        avcodec_get_frame_defaults( decodedFrame );
++                        av_frame_unref( decodedFrame );
+                 }
+                 decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt );
diff --git a/find-taglib.patch b/find-taglib.patch
new file mode 100644 (file)
index 0000000..5988406
--- /dev/null
@@ -0,0 +1,24 @@
+--- amarok-2.8.0/cmake/modules/FindTaglib.cmake.orig   2013-08-14 22:22:51.000000000 +0200
++++ amarok-2.8.0/cmake/modules/FindTaglib.cmake        2016-03-21 14:48:05.512394878 +0100
+@@ -29,10 +29,10 @@
+   exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --version RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_VERSION)
+-  if(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
++  if("${TAGLIB_MIN_VERSION}" VERSION_GREATER TAGLIB_VERSION)
+      message(STATUS "TagLib version too old: version searched :${TAGLIB_MIN_VERSION}, found ${TAGLIB_VERSION}")
+      set(TAGLIB_FOUND FALSE)
+-  else(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}")
++  else("${TAGLIB_MIN_VERSION}" VERSION_GREATER TAGLIB_VERSION)
+      exec_program(${TAGLIBCONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE TAGLIB_LIBRARIES)
+@@ -42,7 +42,7 @@
+         set(TAGLIB_FOUND TRUE)
+      endif(TAGLIB_LIBRARIES AND TAGLIB_CFLAGS)
+      string(REGEX REPLACE " *-I" ";" TAGLIB_INCLUDES "${TAGLIB_CFLAGS}")
+-  endif(TAGLIB_VERSION STRLESS "${TAGLIB_MIN_VERSION}") 
++  endif("${TAGLIB_MIN_VERSION}" VERSION_GREATER TAGLIB_VERSION)
+   mark_as_advanced(TAGLIB_CFLAGS TAGLIB_LIBRARIES TAGLIB_INCLUDES)
+ else(TAGLIBCONFIG_EXECUTABLE)
This page took 0.207223 seconds and 4 git commands to generate.