]> git.pld-linux.org Git - packages/amarok.git/commitdiff
- arts subpackage added auto/ac/amarok-1_1_1-2
authorhavner <havner@pld-linux.org>
Mon, 1 Nov 2004 23:24:46 +0000 (23:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- link with system sqlite3
- rel 2

Changed files:
    amarok.spec -> 1.33

amarok.spec

index 729dd9f714973d61a35bf52cc7806fc02246d70e..1efede28d8d992aaf79b9be62f451c50a67a03b3 100644 (file)
@@ -1,20 +1,20 @@
 #
-# TODO: separate arts plugin
-#
 # Conditional builds:
+%bcond_without arts            # disable arts engine
 %bcond_without gstreamer       # disable gstreamer
-%bcond_without xmms            # disable xmms wrapping
 %bcond_without xine            # disable xine engine
+%bcond_without xmms            # disable xmms wrapping
 #
 Summary:       A KDE audio player
 Summary(pl):   Odtwarzacz audio dla KDE
 Name:          amarok
 Version:       1.1.1
-Release:       1
+Release:       2
 License:       GPL
 Group:         X11/Applications/Multimedia
 Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
 # Source0-md5: 6c0cccd4c8b508a2e0c9b0f187a907cf
+Patch0:                %{name}-sqlite3.patch
 URL:           http://amarok.kde.org/
 Buildrequires: alsa-lib-devel
 Buildrequires: arts-qt-devel
@@ -23,7 +23,7 @@ Buildrequires:        automake
 BuildRequires: kdemultimedia-devel >= 9:3.1.93
 BuildRequires: rpmbuild(macros) >= 1.129
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite-devel >= 2.8
+BuildRequires: sqlite3-devel
 BuildRequires: taglib-devel >= 1.3
 BuildRequires: unsermake >= 040511
 %{?with_xine:BuildRequires:    xine-lib-devel >= 2:1.0-0.rc5.0}
@@ -32,6 +32,7 @@ Buildrequires:        libmusicbrainz-devel
 Buildrequires: libvisual-devel >= 0.1.6-1
 Buildrequires: pcre-devel
 #BuildRequires:        kdebindings-kjsembed-devel 
+Requires:      %{name}-plugin = %{version}-%{release}
 Requires:      kdebase-core >= 9:3.1.93
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -41,11 +42,25 @@ A KDE audio player.
 %description -l pl
 Odtwarzacz audio dla KDE.
 
+%package arts
+Summary:       Plugin arts
+Summary(pl):   Wtyczka arts
+Group:         X11/Applications/Multimedia
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
+
+%description arts
+Plugin arts.
+
+%description arts -l pl
+Wtyczka arts.
+
 %package gstreamer
 Summary:       Plugin gstreamer
 Summary(pl):   Wtyczka gstreamer
 Group:         X11/Applications/Multimedia
 Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
 
 %description gstreamer
 Plugin gstreamer.
@@ -58,6 +73,7 @@ Summary:      Plugin xine
 Summary(pl):   Wtyczka xine
 Group:         X11/Applications/Multimedia
 Requires:       %{name} = %{version}-%{release}
+Provides:      %{name}-plugin = %{version}-%{release}
 
 %description xine
 Plugin xine.
@@ -67,6 +83,7 @@ Wtyczka xine.
 
 %prep
 %setup -q -n %{name}-%{version}
+%patch0 -p1
 
 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
        amarok/src/amarok.desktop \
@@ -80,6 +97,7 @@ export UNSERMAKE=%{_datadir}/unsermake/unsermake
 
 %configure \
        --disable-rpath \
+       %{!?with_arts:--without-arts} \
        %{!?with_xine:--without-xine} \
        %{!?with_gstreamer:--without-gstreamer} \
        --with-qt-libraries=%{_libdir} \
@@ -108,19 +126,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/amarokapp
 %attr(755,root,root) %{_bindir}/amarok_libvisual
 %attr(755,root,root) %{_bindir}/release_amarok
-%{_libdir}/kde3/libamarok_artsengine_plugin.la
-%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
 %{_libdir}/kde3/libamarok_void-engine_plugin.la
 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
-%{_libdir}/libamarokarts.la
-%attr(755,root,root) %{_libdir}/libamarokarts.so
-%{_libdir}/mcop/Amarok
-%{_libdir}/mcop/amarokarts.mcopclass
-%{_libdir}/mcop/amarokarts.mcoptype
 %{_datadir}/apps/amarok
 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
 %{_datadir}/config.kcfg/amarok.kcfg
-%{_datadir}/services/amarok_artsengine_plugin.desktop
 %{_datadir}/services/amarok_void-engine_plugin.desktop
 %{_datadir}/servicetypes/amarok_plugin.desktop
 %{_desktopdir}/kde/amarok.desktop
@@ -128,6 +138,19 @@ rm -rf $RPM_BUILD_ROOT
 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
 %{_datadir}/config/*
 
+%if %{with arts}
+%files arts
+%defattr(644,root,root,755)
+%{_libdir}/kde3/libamarok_artsengine_plugin.la
+%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
+%{_libdir}/libamarokarts.la
+%attr(755,root,root) %{_libdir}/libamarokarts.so
+%{_libdir}/mcop/Amarok
+%{_libdir}/mcop/amarokarts.mcopclass
+%{_libdir}/mcop/amarokarts.mcoptype
+%{_datadir}/services/amarok_artsengine_plugin.desktop
+%endif
+
 %if %{with gstreamer}
 %files gstreamer
 %defattr(644,root,root,755)
This page took 0.050514 seconds and 4 git commands to generate.