]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- typo and more fixes
[packages/amarok.git] / amarok.spec
index c1202ace78a16a87225873ee4596d6f9b3583f5b..9383599f2a0e8cd32e2207eaf77a38ca42a84efd 100644 (file)
@@ -1,81 +1,59 @@
-# TODO:
-# - postgresql support alongside mysql
-# - NMM audio backend support (fix build - propably some BRs)
-# - make descriptions less useless
-# - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
-# - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
-# - main package pulls /usr/bin/ruby
-# - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
-# - karma & MFS (see README)
-# - ProjectM (see README)
 #
-# Conditional builds:
-%bcond_with    gstreamer       # enable gstreamer (gst10 not stable)
-%bcond_without mas             # disable MAS audio backend
-%bcond_without xine            # disable xine engine
-%bcond_without zeroconf        # disable support for zeroconf
-%bcond_without included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
-%bcond_without helix           # disable HelixPlayer engine
-%bcond_without mp3players      # disable iPod and iRiver MP3 players support
-%bcond_with    nmm             # enable NMM audio backend
-%bcond_with    mysql           # enable MySQL support
-%bcond_with    pgsql           # enable PostgreSQL support
+# TODO
+# - use mysql-embedded in the future and try not to link with static mysqld lib
+# - does not run
 #
-%ifarch i386
-%undefine      with_helix
-%endif
+
+%define                state   stable
+%define                qtver   4.7.1
+%define                kdever  4.5.5
 
 Summary:       A KDE audio player
 Summary(pl.UTF-8):     Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       1.4.9.1
-Release:       1
-License:       GPL
+Version:       2.4.1
+Release:       0.1
+License:       GPL v2+ and LGPL v2.1+
 Group:         X11/Applications/Multimedia
-Source0:       ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: aa588778379a391ad3f4b3fc770217e4
-Patch0:                %{name}-helixplayer-morearchs.patch
-Patch1:                %{name}-libnjb.patch
-Patch2:                %{name}-smp.patch
-Patch3:                %{name}-sparc.patch
-Patch4:                kde-ac260-lt.patch
-Patch5:                kde-common-PLD.patch
-Patch6:                %{name}-gcc4.patch
-Patch7:                %{name}-titleorder.patch
+Source0:       ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
+# Source0-md5: 4c65c5cd4d7bd267bdbef8e912fd6cb6
+Patch0:                %{name}-disable_qtscriptbindings_check_fix.patch
+Patch1:                %{name}-ffmpeg08.patch
 URL:           http://amarok.kde.org/
-BuildRequires: SDL-devel
-BuildRequires: alsa-lib-devel
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: dbus-glib-devel
+BuildRequires: QtNetwork-devel >= %{qtver}
+BuildRequires: QtSql-devel >= %{qtver}
+BuildRequires: automoc4 >= 0.9.88
+BuildRequires: cmake >= 2.8.0
+BuildRequires: curl-devel
+BuildRequires: ffmpeg-devel >= 0.7.1
 BuildRequires: gettext-devel
-%{?with_gstreamer:BuildRequires:       gstreamer-devel >= 0.10.0}
-BuildRequires: kdebase-devel
-%{?with_akode:BuildRequires:   kdemultimedia-akode}
-BuildRequires: kdemultimedia-devel >= 9:3.1.93
-%{?with_mp3players:BuildRequires:      libgpod-devel >= 0.6.0}
-%{?with_mp3players:BuildRequires:      libifp-devel >= 1.0.0.2}
-BuildRequires: libltdl-devel
-%{?with_mp3players:BuildRequires:      libmtp-devel >= 0.1.1}
-%{?with_mp3players:BuildRequires:      libnjb-devel >= 2.2.4}
-%{?with_pgsql:BuildRequires:           libpqxx-devel}
-BuildRequires: libtunepimp-devel >= 0.5.1-6
-BuildRequires: libvisual-devel >= 0.4.0
-BuildRequires: mpeg4ip-devel >= 1:1.6
-%{?with_mysql:BuildRequires:           mysql-devel}
+BuildRequires: glib2-devel
+BuildRequires: kde4-kdelibs-devel >= %{kdever}
+BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
+BuildRequires: libaio-devel
+BuildRequires: libgpod-devel >= 0.7.0
+BuildRequires: liblastfm-devel
+BuildRequires: libmtp-devel >= 0.3.0
+BuildRequires: libofa-devel
+BuildRequires: libwrap-devel
+BuildRequires: loudmouth-devel
+BuildRequires: mysql-devel >= 5.1.31-3
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.129
-BuildRequires: ruby-devel >= 1.8
-BuildRequires: sed >= 4.0
-%{!?with_included_sqlite:BuildRequires:        sqlite3-devel >= 3.3}
-BuildRequires: taglib-devel >= 1.4
-%{?with_xine:BuildRequires:    xine-lib-devel >= 1.1.1}
-Requires(post):        /sbin/ldconfig
-Requires:      %{name}-plugin = %{version}-%{release}
-Requires:      kdebase-core >= 9:3.1.93
-Requires:      kdemultimedia-audiocd >= 9:3.1.93
+BuildRequires: qca-devel
+BuildRequires: qt4-build >= %{qtver}
+BuildRequires: qt4-qmake >= %{qtver}
+BuildRequires: qtscriptbindings
+BuildRequires: rpmbuild(macros) >= 1.600
+BuildRequires: soprano-devel
+BuildRequires: strigi-devel >= 0.7.0
+BuildRequires: taglib-devel >= 1.6
+BuildRequires: taglib-extras-devel >= 1.0.0
+BuildRequires: xorg-lib-libXpm-devel
+Requires(post,postun): /sbin/ldconfig
+Requires:      kde4-kdemultimedia-audiocd
+Requires:      kde4-phonon
+Requires:      qtscriptbindings
 Suggests:      libvisual-plugin-actor-JESS
 Suggests:      libvisual-plugin-actor-bumpscope
 Suggests:      libvisual-plugin-actor-corona
@@ -92,7 +70,6 @@ Suggests:     libvisual-plugin-actor-madspin
 Suggests:      libvisual-plugin-actor-nastyfft
 Suggests:      libvisual-plugin-actor-oinksie
 Suggests:      libvisual-plugin-input-alsa
-Suggests:      libvisual-plugin-input-esd
 Suggests:      libvisual-plugin-input-jack
 Suggests:      libvisual-plugin-input-mplayer
 Suggests:      libvisual-plugin-morph-alphablend
@@ -101,110 +78,25 @@ Suggests: libvisual-plugin-morph-slide
 Suggests:      libvisual-plugin-morph-tentacle
 Obsoletes:     amarok-arts
 Obsoletes:     amarok-xmms
+# It should require mysql-embeded
+Requires:      mysql >= 5.1.31-3
+Conflicts:     mysql < 5.1.31-3
 # sr@Latn vs. sr@latin
 Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# temporary hack for proper libgpod::itdb_get_mountpoint() detection.
-%define                filterout_ld    -Wl,--as-needed
-
 %description
 A KDE audio player.
 
 %description -l pl.UTF-8
 Odtwarzacz audio dla KDE.
 
-%package akode
-Summary:       Plugin akode
-Summary(pl.UTF-8):     Wtyczka akode
-Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
-Provides:      %{name}-plugin = %{version}-%{release}
-
-%description akode
-Plugin akode.
-
-%description akode -l pl.UTF-8
-Wtyczka akode.
-
-%package helix
-Summary:       Helix/Realplayer playback support for amarok
-Summary(pl.UTF-8):     Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
-Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
-Requires:      helix-core
-Provides:      %{name}-plugin = %{version}-%{release}
-
-%description helix
-Helix/Realplayer playback support for amarok.
-
-%description helix -l pl.UTF-8
-Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
-
-%package gstreamer
-Summary:       Plugin gstreamer
-Summary(pl.UTF-8):     Wtyczka gstreamer
-Group:         X11/Applications/Multimedia
-# deps, to get it working:
-# mp3 decoder: gstreamer-mad
-# ogg decoder: gstreamer-vorbis
-# audio output driver: gstreamer-audiosink-alsa
-# from gstreamer-audio-effects to control volume, etc
-# needed libs:
-#  at least /usr/lib/gstreamer-0.8/libgstresample.so
-#  probably /usr/lib/gstreamer-0.8/libgstadder.so
-#  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
-# gstreamer-musicbrainz for being able to edit id3 tags on files.
-Requires:      %{name} = %{version}-%{release}
-Requires:      gstreamer-audio-effects
-Requires:      gstreamer-audiosink
-Requires:      gstreamer-mad
-Requires:      gstreamer-musicbrainz
-Requires:      gstreamer-vorbis
-Provides:      %{name}-plugin = %{version}-%{release}
-
-%description gstreamer
-Plugin gstreamer.
-
-%description gstreamer -l pl.UTF-8
-Wtyczka gstreamer.
-
-%package xine
-Summary:       Plugin xine
-Summary(pl.UTF-8):     Wtyczka xine
-Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
-Requires:      xine-plugin-audio
-Provides:      %{name}-plugin = %{version}-%{release}
-
-%description xine
-Plugin xine.
-
-%description xine -l pl.UTF-8
-Wtyczka xine.
-
-%package zeroconf
-Summary:       Zeroconf data
-Summary(pl.UTF-8):     Dane dla zeroconf
-Group:         X11/Applications/Multimedia
-Requires:      %{name} = %{version}-%{release}
-Requires:      kdenetwork-kdnssd
-Provides:      %{name}-plugin = %{version}-%{release}
-
-%description zeroconf
-Zeroconf data.
-
-%description zeroconf -l pl.UTF-8
-Dane dla zeroconf.
-
 %package scripts
 Summary:       amaroK scripts
 Summary(pl.UTF-8):     Skrypty amaroKa
 Group:         X11/Applications/Multimedia
 Requires:      %{name} = %{version}-%{release}
-Requires:      kdebase-kdialog
-Requires:      python-PyQt
-Requires:      ruby-modules
+Requires:      kde4-kdebase-kdialog
 
 %description scripts
 amaroK scripts allow you extend amaroK functionality.
@@ -222,260 +114,201 @@ Więcej o skryptach w amaroKu można dowiedzieć się stąd:
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
-
-%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
-       amarok/src/amarok.desktop \
-
-# see kde bug #110909
-%{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
-
-# kill env, call interpreter directly, so rpm automatics could rule
-%{__sed} -i -e '
-       1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
-       1s,#!.*bin/env.*python,#!%{__python},
-' amarok/src/scripts/*/*.{py,rb} amarok/src/amarok_proxy.rb
 
 %build
-cp -f /usr/share/automake/config.sub admin
-%{__make} -f admin/Makefile.common cvs
-
-# hack: passing something other than "no" or "yes" to --with-helix allows
-# us to pass HELIX_LIBS
-%configure \
-       HELIX_LIBS=%{_libdir}/helixplayer \
-       --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
-       --disable-rpath \
-       --with%{!?with_mas:out}-mas \
-       --with%{!?with_xine:out}-xine \
-       --with%{!?with_gstreamer:out}-gstreamer10 \
-       --with%{!?with_akode:out}-akode \
-       --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
-       --with%{!?with_nmm:out}-nmm \
-       --with%{!?with_mp3players:out}-libgpod \
-       --with%{!?with_mp3players:out}-libnjb \
-       --with%{!?with_mp3players:out}-libmtp \
-       --with%{!?with_mp3players:out}-ifp \
-       --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
-       --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
-       --disable-final \
-       --with-mp4v2 \
-       --with-qt-libraries=%{_libdir} \
-       --with%{!?with_included_sqlite:out}-included-sqlite
+install -d build
+cd build
+%cmake \
+       -DWITH_MYSQL_EMBEDDED=OFF \
+       ../
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT \
        kde_htmldir=%{_kdedocdir} \
        kde_libs_htmldir=%{_kdedocdir}
 
-# remove bogus dir
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
+# remove unsupported locale
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
 
-rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
-rm $RPM_BUILD_ROOT%{_libdir}/ruby_lib/libhttp11.la
+# remove .so symlinks so that noone gets the stupid idea to package them
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
 
-[ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
-       mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
-%find_lang amarok --all-name --with-kde
+%find_lang %{name} --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
-%postun        -p /sbin/ldconfig
+%post          -p /sbin/ldconfig
+%postun                -p /sbin/ldconfig
 
-%files -f amarok.lang
+%files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
 %attr(755,root,root) %{_bindir}/amarok
-%attr(755,root,root) %{_bindir}/amarokapp
+%attr(755,root,root) %{_bindir}/amarokpkg
 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
-%attr(755,root,root) %{_bindir}/amarok_libvisual
-%attr(755,root,root) %{_bindir}/amarok_proxy.rb
-%attr(755,root,root) %{_bindir}/amarok_daapserver.rb
-%attr(755,root,root) %{_libdir}/libamarok.so
-%attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
-%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
-%dir %{_libdir}/ruby_lib
-%{_libdir}/ruby_lib/http11.rb
-%attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so
-%attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
+%attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
+%attr(755,root,root) %{_bindir}/amarok_afttagger
+%attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
+%attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
+%attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
+%attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
+%attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
+%attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
+%attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
+#%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
+#%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
+%attr(755,root,root) %{_libdir}/libampache_account_login.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
+#%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
 %dir %{_datadir}/apps/amarok
 %dir %{_datadir}/apps/amarok/scripts
-%{_datadir}/apps/amarok/ruby_lib
-%{_datadir}/apps/amarok/*.rc
 %{_datadir}/apps/amarok/data
 %{_datadir}/apps/amarok/icons
 %{_datadir}/apps/amarok/images
-%{_datadir}/apps/amarok/themes
-%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
-%{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
-%{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
-%{_datadir}/apps/konqsidebartng/add/amarok.desktop
-%{_datadir}/apps/konqsidebartng/entries/amarok.desktop
-%{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
-%{_datadir}/apps/profiles/amarok.profile.xml
-%{_datadir}/config/amarokrc
-%{_datadir}/config.kcfg/amarok.kcfg
-%{_datadir}/services/amarok_generic-mediadevice.desktop
-%{_datadir}/services/amarok_void-engine_plugin.desktop
-%{_datadir}/services/amarok_daap-mediadevice.desktop
-%{_datadir}/services/amarok_massstorage-device.desktop
-%{_datadir}/services/amarok_nfs-device.desktop
-%{_datadir}/services/amarok_smb-device.desktop
-%{_datadir}/services/amaroklastfm.protocol
-%{_datadir}/services/amarokitpc.protocol
-%{_datadir}/services/amarokpcast.protocol
-%{_datadir}/servicetypes/amarok_codecinstall.desktop
-%{_datadir}/servicetypes/amarok_plugin.desktop
-%{_desktopdir}/kde/amarok.desktop
+%{_datadir}/apps/amarok/amarok.notifyrc
+%{_datadir}/apps/desktoptheme
+%{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
+%{_datadir}/config.kcfg/amarokconfig.kcfg
+%{_datadir}/config/amarok.knsrc
+%{_datadir}/config/amarokapplets.knsrc
+%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
+%{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
+%{_desktopdir}/kde4/amarok_containers.desktop
+%{_datadir}/kde4/services/amarok.protocol
+%{_datadir}/kde4/services/amaroklastfm.protocol
+%{_datadir}/kde4/services/amarokitpc.protocol
+%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
+%{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
+#%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
+%{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
+%{_datadir}/kde4/services/amarok_collection-umscollection.desktop
+%{_datadir}/kde4/services/amarok-containment-vertical.desktop
+%{_datadir}/kde4/services/amarok-context-applet-albums.desktop
+%{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
+%{_datadir}/kde4/services/amarok-context-applet-info.desktop
+%{_datadir}/kde4/services/amarok-context-applet-labels.desktop
+%{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
+%{_datadir}/kde4/services/amarok-context-applet-photos.desktop
+%{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
+%{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
+%{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
+%{_datadir}/kde4/services/amarok-data-engine-current.desktop
+%{_datadir}/kde4/services/amarok-data-engine-info.desktop
+%{_datadir}/kde4/services/amarok-data-engine-labels.desktop
+%{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
+%{_datadir}/kde4/services/amarok-data-engine-photos.desktop
+%{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
+%{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
+%{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
+%{_datadir}/kde4/services/amarok_device_massstorage.desktop
+%{_datadir}/kde4/services/amarok_device_nfs.desktop
+%{_datadir}/kde4/services/amarok_device_smb.desktop
+%{_datadir}/kde4/services/amarok_service_ampache.desktop
+%{_datadir}/kde4/services/amarok_service_ampache_config.desktop
+%{_datadir}/kde4/services/amarok_service_jamendo.desktop
+%{_datadir}/kde4/services/amarok_service_lastfm.desktop
+%{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
+%{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
+%{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
+%{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
+%{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
+%{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
+%{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
+%{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
+%{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
+%{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
+%{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
+%{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
+%{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
+%{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
+%{_datadir}/kde4/servicetypes/amarok_plugin.desktop
+%{_desktopdir}/kde4/amarok.desktop
 %{_iconsdir}/*/*/apps/amarok.*
-# TODO: move to subpackage
-%if %{with mp3players}
-%attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
-%attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
-%{_datadir}/services/amarok_ifp-mediadevice.desktop
-%{_datadir}/services/amarok_ipod-mediadevice.desktop
-%{_datadir}/services/amarok_mtp-mediadevice.desktop
-%{_datadir}/services/amarok_njb-mediadevice.desktop
-%endif
-
-%if %{with akode}
-%files akode
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
-%{_datadir}/services/amarok_aKode-engine.desktop
-%endif
-
-%if %{with gstreamer}
-%files gstreamer
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
-%{_datadir}/config.kcfg/gstconfig.kcfg
-%{_datadir}/services/amarok_gst10engine_plugin.desktop
-%endif
-
-%if %{with helix}
-%files helix
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
-%{_datadir}/config.kcfg/helixconfig.kcfg
-%{_datadir}/services/amarok_helixengine_plugin.desktop
-%endif
-
-%if %{with xine}
-%files xine
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
-%{_datadir}/config.kcfg/xinecfg.kcfg
-%{_datadir}/services/amarok_xine-engine.desktop
-%endif
-
-%if 0
-%if %{with zeroconf}
-%files zeroconf
-%defattr(644,root,root,755)
-#%{_datadir}/apps/zeroconf/_shoutcast._tcp
-%endif
-%endif
+%{_datadir}/config/amarok_homerc
 
 %files scripts
 %defattr(644,root,root,755)
-%dir %{_datadir}/apps/amarok/scripts/common
-%{_datadir}/apps/amarok/scripts/common/Publisher.py
-%{_datadir}/apps/amarok/scripts/common/Zeroconf.py
-
-%dir %{_datadir}/apps/amarok/scripts/templates
-%{_datadir}/apps/amarok/scripts/templates/amarok.rb
-%{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
-%{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
-
-# amarok searches for executable programs for scripts
-# to figure out which files need to have execute permission, use this
-# find command:
-# $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
-
-#%dir %{_datadir}/apps/amarok/scripts/graphequalizer
-#%{_datadir}/apps/amarok/scripts/graphequalizer/README
-#%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
-
-%dir %{_datadir}/apps/amarok/scripts/playlist2html
-%{_datadir}/apps/amarok/scripts/playlist2html/README
-%{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
-
-%dir %{_datadir}/apps/amarok/scripts/webcontrol
-%{_datadir}/apps/amarok/scripts/webcontrol/README
-%{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
-%{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
-%{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
-%{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
-%{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
-%{_datadir}/apps/amarok/scripts/webcontrol/main.css
-%{_datadir}/apps/amarok/scripts/webcontrol/main.js
-%{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
-%{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
-%{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
-%{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
-%{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
-%{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
-%{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
-%{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
-%{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
-%{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
-%{_datadir}/apps/amarok/scripts/webcontrol/star.png
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
-
-%dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
-%{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
-%{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
-%{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
-
-%dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
-%{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
-%{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
-%{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
-
-%dir %{_datadir}/apps/amarok/scripts/score_default
-%{_datadir}/apps/amarok/scripts/score_default/COPYING
-%{_datadir}/apps/amarok/scripts/score_default/README
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
-%{_datadir}/apps/amarok/scripts/score_default/score_default.spec
-%dir %{_datadir}/apps/amarok/scripts/score_impulsive
-%{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
-%{_datadir}/apps/amarok/scripts/score_impulsive/README
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
-%{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
-
-%dir %{_datadir}/apps/amarok/scripts/ruby_debug
-%{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
-
-%if 0
-%dir %{_datadir}/apps/amarok/scripts/amarok_live
-%{_datadir}/apps/amarok/scripts/amarok_live/README
-%{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
-%{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
-%attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
-%endif
+%dir %{_datadir}/apps/amarok/scripts/radio_station_service
+%{_datadir}/apps/amarok/scripts/radio_station_service/main.js
+%{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
+%dir %{_datadir}/apps/amarok/scripts/script_console
+%{_datadir}/apps/amarok/scripts/script_console/main.js
+%{_datadir}/apps/amarok/scripts/script_console/script.spec
+%dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
+%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
+%{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
+%dir %{_datadir}/apps/amarok/scripts/librivox_service
+%{_datadir}/apps/amarok/scripts/librivox_service/main.js
+%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
+%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
+%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
+%{_datadir}/apps/amarok/scripts/librivox_service/script.spec
+%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
+%{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
+%{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.097953 seconds and 4 git commands to generate.