]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- nchc.dl is not browsable
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 #
22 Summary:        A KDE audio player
23 Summary(pl):    Odtwarzacz audio dla KDE
24 Name:           amarok
25 Version:        1.3.7
26 Release:        0.1
27 License:        GPL
28 Group:          X11/Applications/Multimedia
29 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
30 # Source0-md5:  e2297042070643c105f8bb0e524c73ad
31 Patch0:         kde-common-gcc4.patch
32 Patch1:         %{name}-lyricsurl.patch
33 Patch2:         %{name}-libtunepimp-0.4.0.patch
34 URL:            http://amarok.kde.org/
35 #BuildRequires: kdebindings-kjsembed-devel
36 #BuildRequires: unsermake >= 040511
37 BuildRequires:  SDL-devel
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  arts-qt-devel
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
43 BuildRequires:  kdebase-devel
44 %{?with_akode:BuildRequires:    kdemultimedia-akode}
45 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
46 BuildRequires:  libltdl-devel
47 BuildRequires:  libtunepimp-devel >= 0.4.0
48 BuildRequires:  libvisual-devel >= 0.2.0
49 %{?with_mysql:BuildRequires:            mysql-devel}
50 %{?with_pgsql:BuildRequires:            libpqxx-devel}
51 BuildRequires:  pcre-devel
52 BuildRequires:  rpm-pythonprov
53 BuildRequires:  rpmbuild(macros) >= 1.129
54 BuildRequires:  sed >= 4.0
55 %{?with_helix:BuildRequires: helix-core}
56 %{?!with_included_sqlite:BuildRequires: sqlite3-devel}
57 BuildRequires:  taglib-devel >= 1.4
58 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
59 %{?with_xmms:BuildRequires:             xmms-devel}
60 Requires:       %{name}-plugin = %{version}-%{release}
61 Requires:       kdebase-core >= 9:3.1.93
62 Requires:       kdemultimedia-audiocd >= 9:3.1.93
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 A KDE audio player.
67
68 %description -l pl
69 Odtwarzacz audio dla KDE.
70
71 %package arts
72 Summary:        Plugin arts
73 Summary(pl):    Wtyczka arts
74 Group:          X11/Applications/Multimedia
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-plugin = %{version}-%{release}
77
78 %description arts
79 Plugin arts.
80
81 %description arts -l pl
82 Wtyczka arts.
83
84 %package akode
85 Summary:        Plugin akode
86 Summary(pl):    Wtyczka akode
87 Group:          X11/Applications/Multimedia
88 Requires:       %{name} = %{version}-%{release}
89 Provides:       %{name}-plugin = %{version}-%{release}
90
91 %description akode
92 Plugin akode.
93
94 %description akode -l pl
95 Wtyczka akode.
96
97 %package helix
98 Summary:        Helix/Realplayer playback support for amarok
99 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       helix-core
103 Provides:       %{name}-plugin = %{version}-%{release}
104
105 %description helix
106 Helix/Realplayer playback support for amarok.
107
108 %description helix -l pl
109 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
110
111
112 %package gstreamer
113 Summary:        Plugin gstreamer
114 Summary(pl):    Wtyczka gstreamer
115 Group:          X11/Applications/Multimedia
116 # deps, to get it working:
117 # mp3 decoder: gstreamer-mad
118 # ogg decoder: gstreamer-vorbis
119 # audio output driver: gstreamer-audiosink-alsa
120 # from gstreamer-audio-effects to control volume, etc
121 # needed libs:
122 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
123 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
124 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
125 # gstreamer-musicbrainz for being able to edit id3 tags on files.
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       gstreamer-audio-effects
128 Requires:       gstreamer-audiosink
129 Requires:       gstreamer-mad
130 Requires:       gstreamer-musicbrainz
131 Requires:       gstreamer-vorbis
132 Provides:       %{name}-plugin = %{version}-%{release}
133
134 %description gstreamer
135 Plugin gstreamer.
136
137 %description gstreamer -l pl
138 Wtyczka gstreamer.
139
140 %package xine
141 Summary:        Plugin xine
142 Summary(pl):    Wtyczka xine
143 Group:          X11/Applications/Multimedia
144 Requires:       %{name} = %{version}-%{release}
145 Requires:       xine-plugin-audio
146 Provides:       %{name}-plugin = %{version}-%{release}
147
148 %description xine
149 Plugin xine.
150
151 %description xine -l pl
152 Wtyczka xine.
153
154 %package zeroconf
155 Summary:        Zeroconf data
156 Summary(pl):    Dane dla zeroconf
157 Group:          X11/Applications/Multimedia
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       kdenetwork-kdnssd
160 Provides:       %{name}-plugin = %{version}-%{release}
161
162 %description zeroconf
163 Zeroconf data.
164
165 %description zeroconf -l pl
166 Dane dla zeroconf.
167
168 %package scripts
169 Summary:        amaroK scripts
170 Summary(pl):    Skrypty amaroKa
171 Group:          X11/Applications/Multimedia
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       kdebase-kdialog
174 Requires:       python-PyQt
175
176 %description scripts
177 amaroK scripts allow you extend amaroK functionality.
178
179 You can learn more about scripts in amaroK from here:
180 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
181
182 %description scripts -l pl
183 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
184
185 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
186 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
187
188 %prep
189 %setup -q
190 %patch0 -p1
191 %{?with_altlyrics:%patch1 -p1}
192 %patch2 -p1
193 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
194         amarok/src/amarok.desktop \
195
196 # see kde bug #110909
197 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
198
199 %build
200 cp -f /usr/share/automake/config.sub admin
201
202 #export UNSERMAKE=/usr/share/unsermake/unsermake
203
204 %{__make} -f admin/Makefile.common cvs
205
206 %configure \
207         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
208         --disable-rpath \
209         --with%{!?with_arts:out}-arts \
210         --with%{!?with_mas:out}-mas \
211         --with%{!?with_xine:out}-xine \
212         --with%{!?with_gstreamer:out}-gstreamer \
213         --with%{!?with_akode:out}-akode \
214         --with%{!?with_helix:out}-helix \
215         --with%{!?with_nmm:out}-nmm \
216         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
217         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
218         --disable-final \
219         --with-qt-libraries=%{_libdir} \
220         --with%{!?with_included_sqlite:out}-included-sqlite
221
222 %{__make}
223
224 %install
225 rm -rf $RPM_BUILD_ROOT
226
227 %{__make} install \
228         DESTDIR=$RPM_BUILD_ROOT \
229         kde_htmldir=%{_kdedocdir} \
230         kde_libs_htmldir=%{_kdedocdir}
231
232 # remove bogus dir
233 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
234
235 %find_lang amarok --all-name --with-kde
236
237 %clean
238 rm -rf $RPM_BUILD_ROOT
239
240 %post
241 if [ "$1" = 1 ]; then
242         echo "Remember to install libvisual-plugins-* packages if you"
243         echo "want to have a visualizations in amaroK."
244 fi
245
246 %files -f %{name}.lang
247 %defattr(644,root,root,755)
248 %doc AUTHORS ChangeLog README
249 %attr(755,root,root) %{_bindir}/amarok
250 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
251 %attr(755,root,root) %{_bindir}/amarokapp
252 %attr(755,root,root) %{_bindir}/amarok_libvisual
253 #%attr(755,root,root) %{_bindir}/release_amarok
254 %{_libdir}/kde3/konqsidebar_universalamarok.la
255 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
256 %{_libdir}/kde3/libamarok_void-engine_plugin.la
257 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
258 %dir %{_datadir}/apps/amarok
259 %dir %{_datadir}/apps/amarok/scripts
260 %{_datadir}/apps/amarok/*.rc
261 %{_datadir}/apps/amarok/data
262 %{_datadir}/apps/amarok/icons
263 %{_datadir}/apps/amarok/images
264 %{_datadir}/apps/amarok/themes
265 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
266 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
267 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
268 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
269 %{_datadir}/apps/profiles/amarok.profile.xml
270 %{_datadir}/config/amarokrc
271 %{_datadir}/config.kcfg/amarok.kcfg
272 %{_datadir}/services/amarok_void-engine_plugin.desktop
273 %{_datadir}/servicetypes/amarok_plugin.desktop
274 %{_desktopdir}/kde/amarok.desktop
275 %{_iconsdir}/*/*/apps/amarok.*
276
277 %if %{with arts}
278 %files arts
279 %defattr(644,root,root,755)
280 %{_libdir}/kde3/libamarok_artsengine_plugin.la
281 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
282 %{_libdir}/libamarokarts.la
283 %attr(755,root,root) %{_libdir}/libamarokarts.so
284 %{_libdir}/mcop/Amarok
285 %{_libdir}/mcop/amarokarts.mcopclass
286 %{_libdir}/mcop/amarokarts.mcoptype
287 %{_datadir}/services/amarok_artsengine_plugin.desktop
288 %endif
289
290 %if %{with akode}
291 %files akode
292 %defattr(644,root,root,755)
293 %{_libdir}/kde3/libamarok_aKode-engine.la
294 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
295 %{_datadir}/services/amarok_aKode-engine.desktop
296 %endif
297
298 %if %{with gstreamer}
299 %files gstreamer
300 %defattr(644,root,root,755)
301 %{_libdir}/kde3/libamarok_gstengine_plugin.la
302 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
303 %{_datadir}/config.kcfg/gstconfig.kcfg
304 %{_datadir}/services/amarok_gstengine_plugin.desktop
305 %endif
306
307 %if %{with helix}
308 %files helix
309 %defattr(644,root,root,755)
310 %{_libdir}/kde3/libamarok_helixengine_plugin.la
311 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
312 %{_datadir}/config.kcfg/helixconfig.kcfg
313 %{_datadir}/services/amarok_helixengine_plugin.desktop
314 %endif
315
316 %if %{with xine}
317 %files xine
318 %defattr(644,root,root,755)
319 %{_libdir}/kde3/libamarok_xine-engine.la
320 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
321 %{_datadir}/config.kcfg/xinecfg.kcfg
322 %{_datadir}/services/amarok_xine-engine.desktop
323 #%{_datadir}/services/amarok_xineengine_plugin.desktop
324 %endif
325
326 %if %{with zeroconf}
327 %files zeroconf
328 %defattr(644,root,root,755)
329 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
330 %endif
331
332 %files scripts
333 %defattr(644,root,root,755)
334
335 %dir %{_datadir}/apps/amarok/scripts/alarm
336 %{_datadir}/apps/amarok/scripts/alarm/README
337 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
338
339 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
340 %{_datadir}/apps/amarok/scripts/graphequalizer/README
341 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
342
343 %dir %{_datadir}/apps/amarok/scripts/playlist2html
344 %{_datadir}/apps/amarok/scripts/playlist2html/README
345 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
346 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
347 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
348
349 %dir %{_datadir}/apps/amarok/scripts/templates
350 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
351 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
352 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
353
354 %dir %{_datadir}/apps/amarok/scripts/webcontrol
355 %{_datadir}/apps/amarok/scripts/webcontrol/README
356 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
357 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
358 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
359 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
360 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
361 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
362 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
363 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
364 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
365 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
366 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
367 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
368 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
369 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
370 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
371 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
372
373 %dir %{_datadir}/apps/amarok/scripts/common
374 %{_datadir}/apps/amarok/scripts/common/Publisher.py
375 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
376
377 #%dir %{_datadir}/apps/amarok/scripts/shouter
378 #%{_datadir}/apps/amarok/scripts/shouter/README
379 #%{_datadir}/apps/amarok/scripts/shouter/ChangeLog
380 #%{_datadir}/apps/amarok/scripts/shouter/Amarok.py
381 #%{_datadir}/apps/amarok/scripts/shouter/Globals.py
382 #%{_datadir}/apps/amarok/scripts/shouter/Playlist.py
383 #%{_datadir}/apps/amarok/scripts/shouter/Services.py
384 #%{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
385 #%{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
386 #%{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
387 #%{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
388 #%{_datadir}/apps/amarok/scripts/shouter/StreamController.py
389 #%{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
390 #%{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
391 #%{_datadir}/apps/amarok/scripts/shouter/debug.py
392 #%{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
393 #%dir %{_datadir}/apps/amarok/scripts/shouter/silence
394 #%{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
395 #%dir %{_datadir}/apps/amarok/scripts/shouter/test
396 #%{_datadir}/apps/amarok/scripts/shouter/test/client.py
397 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
398
399 %if 0
400 %dir %{_datadir}/apps/amarok/scripts/amarok_live
401 %{_datadir}/apps/amarok/scripts/amarok_live/README
402 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
403 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
404 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
405 %endif
This page took 0.385352 seconds and 4 git commands to generate.