]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- fix ac260-lt issue, req. proper libtunepim-devel-0.5.x.
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 #
9 # Conditional builds:
10 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable support for zeroconf
15 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
16 %bcond_without  helix           # disable HelixPlayer engine
17 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable MySQL support
20 %bcond_with     pgsql           # enable PostgreSQL support
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25
26 Summary:        A KDE audio player
27 Summary(pl):    Odtwarzacz audio dla KDE
28 Name:           amarok
29 Version:        1.4.3
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
34 Source0:        http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
35 # Source0-md5:  b0b4f8952ad23705c70815d50fd0af52
36 Patch0:         %{name}-helixplayer-morearchs.patch
37 Patch1:         %{name}-libnjb.patch
38 Patch2:         kde-ac260-lt.patch
39 URL:            http://amarok.kde.org/
40 BuildRequires:  SDL-devel
41 BuildRequires:  alsa-lib-devel
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  dbus-glib-devel
45 BuildRequires:  gettext-devel
46 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
47 BuildRequires:  kdebase-devel
48 %{?with_akode:BuildRequires:    kdemultimedia-akode}
49 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
50 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
51 %{?with_mp3players:BuildRequires:       libgpod-devel < 0.3.1}
52 %{?with_mp3players:BuildRequires:       libifp-devel}
53 %{?with_mp3players:BuildRequires:       libmtp-devel}
54 %{?with_mp3players:BuildRequires:       libnjb-devel}
55 BuildRequires:  libltdl-devel
56 %{?with_pgsql:BuildRequires:            libpqxx-devel}
57 BuildRequires:  libtunepimp-devel >= 0.5.1-6
58 BuildRequires:  libvisual-devel >= 0.4.0
59 BuildRequires:  mpeg4ip-devel
60 %{?with_mysql:BuildRequires:            mysql-devel}
61 BuildRequires:  pcre-devel
62 BuildRequires:  pkgconfig
63 BuildRequires:  rpm-pythonprov
64 BuildRequires:  rpmbuild(macros) >= 1.129
65 BuildRequires:  ruby-devel >= 1.8
66 BuildRequires:  sed >= 4.0
67 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
68 BuildRequires:  taglib-devel >= 1.4
69 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
70 %{?with_xmms:BuildRequires:     xmms-devel}
71 Requires(post): /sbin/ldconfig
72 Requires:       %{name}-plugin = %{version}-%{release}
73 Requires:       kdebase-core >= 9:3.1.93
74 Requires:       kdemultimedia-audiocd >= 9:3.1.93
75 Obsoletes:      amarok-arts
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %description
79 A KDE audio player.
80
81 %description -l pl
82 Odtwarzacz audio dla KDE.
83
84 %package akode
85 Summary:        Plugin akode
86 Summary(pl):    Wtyczka akode
87 Group:          X11/Applications/Multimedia
88 Requires:       %{name} = %{version}-%{release}
89 Provides:       %{name}-plugin = %{version}-%{release}
90
91 %description akode
92 Plugin akode.
93
94 %description akode -l pl
95 Wtyczka akode.
96
97 %package helix
98 Summary:        Helix/Realplayer playback support for amarok
99 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       helix-core
103 Provides:       %{name}-plugin = %{version}-%{release}
104
105 %description helix
106 Helix/Realplayer playback support for amarok.
107
108 %description helix -l pl
109 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
110
111 %package gstreamer
112 Summary:        Plugin gstreamer
113 Summary(pl):    Wtyczka gstreamer
114 Group:          X11/Applications/Multimedia
115 # deps, to get it working:
116 # mp3 decoder:  gstreamer-mad
117 # ogg decoder:  gstreamer-vorbis
118 # audio output driver:  gstreamer-audiosink-alsa
119 # from gstreamer-audio-effects to control volume, etc
120 # needed libs:
121 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
122 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
123 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
124 # gstreamer-musicbrainz for being able to edit id3 tags on files.
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       gstreamer-audio-effects
127 Requires:       gstreamer-audiosink
128 Requires:       gstreamer-mad
129 Requires:       gstreamer-musicbrainz
130 Requires:       gstreamer-vorbis
131 Provides:       %{name}-plugin = %{version}-%{release}
132
133 %description gstreamer
134 Plugin gstreamer.
135
136 %description gstreamer -l pl
137 Wtyczka gstreamer.
138
139 %package xine
140 Summary:        Plugin xine
141 Summary(pl):    Wtyczka xine
142 Group:          X11/Applications/Multimedia
143 Requires:       %{name} = %{version}-%{release}
144 Requires:       xine-plugin-audio
145 Provides:       %{name}-plugin = %{version}-%{release}
146
147 %description xine
148 Plugin xine.
149
150 %description xine -l pl
151 Wtyczka xine.
152
153 %package xmms
154 Summary:        Xmms wrapper
155 Summary(pl):    Wrapper xmms
156 Group:          X11/Applications/Multimedia
157 Requires:       %{name} = %{version}-%{release}
158
159 %description xmms
160 Xmms wrapper.
161
162 %description xmms -l pl
163 Wrapper xmms.
164
165 %package zeroconf
166 Summary:        Zeroconf data
167 Summary(pl):    Dane dla zeroconf
168 Group:          X11/Applications/Multimedia
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       kdenetwork-kdnssd
171 Provides:       %{name}-plugin = %{version}-%{release}
172
173 %description zeroconf
174 Zeroconf data.
175
176 %description zeroconf -l pl
177 Dane dla zeroconf.
178
179 %package scripts
180 Summary:        amaroK scripts
181 Summary(pl):    Skrypty amaroKa
182 Group:          X11/Applications/Multimedia
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       kdebase-kdialog
185 Requires:       python-PyQt
186 Requires:       ruby-modules
187
188 %description scripts
189 amaroK scripts allow you extend amaroK functionality.
190
191 You can learn more about scripts in amaroK from here:
192 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
193
194 %description scripts -l pl
195 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
196
197 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
198 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
199
200 %prep
201 %setup -q
202 %patch0 -p1
203 %patch1 -p1
204 %patch2 -p1
205
206 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
207         amarok/src/amarok.desktop \
208
209 # see kde bug #110909
210 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
211
212 # kill env, call interpreter directly, so rpm automatics could rule
213 %{__sed} -i -e '
214         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
215         1s,#!.*bin/env.*python,#!%{_bindir}/python,
216         1s,#!.*bin/env.*bash,#!/bin/bash,
217 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
218
219 %build
220 cp -f /usr/share/automake/config.sub admin
221 %{__make} -f admin/Makefile.common cvs
222
223 # hack: passing something other than "no" or "yes" to --with-helix allows
224 # us to pass HELIX_LIBS
225 %configure \
226         HELIX_LIBS=%{_libdir}/helixplayer \
227         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
228         --disable-rpath \
229         --with%{!?with_mas:out}-mas \
230         --with%{!?with_xine:out}-xine \
231         --with%{!?with_gstreamer:out}-gstreamer10 \
232         --with%{!?with_akode:out}-akode \
233         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
234         --with%{!?with_nmm:out}-nmm \
235         --with%{!?with_xmms:out}-xmms \
236         --with%{!?with_mp3players:out}-libgpod \
237         --with%{!?with_mp3players:out}-libnjb \
238         --with%{!?with_mp3players:out}-libmtp \
239         --with%{!?with_mp3players:out}-ifp \
240         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
241         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
242         --disable-final \
243         --with-mp4v2 \
244         --with-qt-libraries=%{_libdir} \
245         --with%{!?with_included_sqlite:out}-included-sqlite
246
247 %{__make}
248
249 %install
250 rm -rf $RPM_BUILD_ROOT
251
252 %{__make} install \
253         DESTDIR=$RPM_BUILD_ROOT \
254         kde_htmldir=%{_kdedocdir} \
255         kde_libs_htmldir=%{_kdedocdir}
256
257 # remove bogus dir
258 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
259
260 %find_lang amarok --all-name --with-kde
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post
266 /sbin/ldconfig
267 if [ "$1" = 1 ]; then
268         echo "Remember to install libvisual-plugins-* packages if you"
269         echo "want to have a visualizations in amaroK."
270 fi
271
272 %postun -p /sbin/ldconfig
273
274 %files -f %{name}.lang
275 %defattr(644,root,root,755)
276 %doc AUTHORS ChangeLog README
277 %attr(755,root,root) %{_bindir}/amarok
278 %attr(755,root,root) %{_bindir}/amarokapp
279 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
280 %attr(755,root,root) %{_bindir}/amarok_libvisual
281 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
282 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
283 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
284 %{_libdir}/kde3/konqsidebar_universalamarok.la
285 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
286 %{_libdir}/kde3/libamarok_generic-mediadevice.la
287 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
288 %{_libdir}/kde3/libamarok_void-engine_plugin.la
289 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
290 %{_libdir}/libamarok.la
291 %{_libdir}/kde3/libamarok_daap-mediadevice.la
292 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
293 %{_libdir}/kde3/libamarok_massstorage-device.la
294 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
295 %{_libdir}/kde3/libamarok_nfs-device.la
296 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
297 %{_libdir}/kde3/libamarok_smb-device.la
298 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
299 %dir %{_datadir}/apps/amarok
300 %dir %{_datadir}/apps/amarok/scripts
301 %{_datadir}/apps/amarok/ruby_lib
302 %{_datadir}/apps/amarok/*.rc
303 %{_datadir}/apps/amarok/data
304 %{_datadir}/apps/amarok/icons
305 %{_datadir}/apps/amarok/images
306 %{_datadir}/apps/amarok/themes
307 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
308 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
309 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
310 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
311 %{_datadir}/apps/profiles/amarok.profile.xml
312 %{_datadir}/config/amarokrc
313 %{_datadir}/config.kcfg/amarok.kcfg
314 %{_datadir}/services/amarok_generic-mediadevice.desktop
315 %{_datadir}/services/amarok_void-engine_plugin.desktop
316 %{_datadir}/services/amarok_daap-mediadevice.desktop
317 %{_datadir}/services/amarok_massstorage-device.desktop
318 %{_datadir}/services/amarok_nfs-device.desktop
319 %{_datadir}/services/amarok_smb-device.desktop
320 %{_datadir}/services/amaroklastfm.protocol
321 %{_datadir}/services/amarokitpc.protocol
322 %{_datadir}/services/amarokpcast.protocol
323 %{_datadir}/servicetypes/amarok_codecinstall.desktop
324 %{_datadir}/servicetypes/amarok_plugin.desktop
325 %{_desktopdir}/kde/amarok.desktop
326 %{_iconsdir}/*/*/apps/amarok.*
327 # TODO: move to subpackage
328 %if %{with mp3players}
329 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
330 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
331 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
332 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
333 %{_libdir}/kde3/libamarok_mtp-mediadevice.la
334 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
335 %{_libdir}/kde3/libamarok_njb-mediadevice.la
336 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
337 %{_datadir}/services/amarok_ifp-mediadevice.desktop
338 %{_datadir}/services/amarok_ipod-mediadevice.desktop
339 %{_datadir}/services/amarok_mtp-mediadevice.desktop
340 %{_datadir}/services/amarok_njb-mediadevice.desktop
341 %endif
342
343 %if %{with akode}
344 %files akode
345 %defattr(644,root,root,755)
346 %{_libdir}/kde3/libamarok_aKode-engine.la
347 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
348 %{_datadir}/services/amarok_aKode-engine.desktop
349 %endif
350
351 %if %{with gstreamer}
352 %files gstreamer
353 %defattr(644,root,root,755)
354 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
355 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
356 %{_datadir}/config.kcfg/gstconfig.kcfg
357 %{_datadir}/services/amarok_gst10engine_plugin.desktop
358 %endif
359
360 %if %{with helix}
361 %files helix
362 %defattr(644,root,root,755)
363 %{_libdir}/kde3/libamarok_helixengine_plugin.la
364 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
365 %{_datadir}/config.kcfg/helixconfig.kcfg
366 %{_datadir}/services/amarok_helixengine_plugin.desktop
367 %endif
368
369 %if %{with xine}
370 %files xine
371 %defattr(644,root,root,755)
372 %{_libdir}/kde3/libamarok_xine-engine.la
373 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
374 %{_datadir}/config.kcfg/xinecfg.kcfg
375 %{_datadir}/services/amarok_xine-engine.desktop
376 %endif
377
378 %if %{with xmms}
379 %files xmms
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
382 %endif
383
384 %if 0
385 %if %{with zeroconf}
386 %files zeroconf
387 %defattr(644,root,root,755)
388 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
389 %endif
390 %endif
391
392 %files scripts
393 %defattr(644,root,root,755)
394 %dir %{_datadir}/apps/amarok/scripts/common
395 %{_datadir}/apps/amarok/scripts/common/Publisher.py
396 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
397
398 %dir %{_datadir}/apps/amarok/scripts/templates
399 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
400 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
401 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
402
403 # amarok searches for executable programs for scripts
404 # to figure out which files need to have execute permission, use this
405 # find command:
406 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
407
408 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
409 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
410 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
411
412 %dir %{_datadir}/apps/amarok/scripts/playlist2html
413 %{_datadir}/apps/amarok/scripts/playlist2html/README
414 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
415 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
416 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
417
418 %dir %{_datadir}/apps/amarok/scripts/webcontrol
419 %{_datadir}/apps/amarok/scripts/webcontrol/README
420 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
421 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
422 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
423 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
424 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
425 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
426 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
427 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
428 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
429 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
430 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
431 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
432 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
433 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
434 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
435 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
436 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
437 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
438 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
439
440 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
441 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
442 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
443 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
444 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
445
446 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
447 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
448 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
449 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
450 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
451
452 %dir %{_datadir}/apps/amarok/scripts/score_default
453 %{_datadir}/apps/amarok/scripts/score_default/COPYING
454 %{_datadir}/apps/amarok/scripts/score_default/README
455 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
456 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
457 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
458 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
459 %{_datadir}/apps/amarok/scripts/score_impulsive/README
460 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
461 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
462
463 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
464 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
465
466 %if 0
467 %dir %{_datadir}/apps/amarok/scripts/amarok_live
468 %{_datadir}/apps/amarok/scripts/amarok_live/README
469 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
470 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
471 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
472 %endif
This page took 0.094034 seconds and 4 git commands to generate.