]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- BR: pkgconfig
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_without  helix           # disable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25 Summary:        A KDE audio player
26 Summary(pl):    Odtwarzacz audio dla KDE
27 Name:           amarok
28 Version:        1.3.9
29 Release:        1
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33 # Source0-md5:  fb4cb3dafd3d15657b78e24c33abcf76
34 Patch0:         kde-common-gcc4.patch
35 Patch1:         %{name}-lyricsurl.patch
36 Patch2:         %{name}-libtunepimp-0.4.0.patch
37 Patch3:         %{name}-helixplayer-morearchs.patch
38 URL:            http://amarok.kde.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  arts-qt-devel
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  gettext-devel
45 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
46 BuildRequires:  kdebase-devel
47 %{?with_akode:BuildRequires:    kdemultimedia-akode}
48 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
49 BuildRequires:  libltdl-devel
50 BuildRequires:  libtunepimp-devel >= 0.4.0
51 BuildRequires:  libvisual-devel >= 0.2.0
52 %{?with_pgsql:BuildRequires:            libpqxx-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 BuildRequires:  pcre-devel
55 BuildRequires:  pkgconfig
56 BuildRequires:  rpm-pythonprov
57 BuildRequires:  rpmbuild(macros) >= 1.129
58 BuildRequires:  sed >= 4.0
59 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
60 BuildRequires:  taglib-devel >= 1.4
61 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
62 %{?with_xmms:BuildRequires:             xmms-devel}
63 Requires:       %{name}-plugin = %{version}-%{release}
64 Requires:       kdebase-core >= 9:3.1.93
65 Requires:       kdemultimedia-audiocd >= 9:3.1.93
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 A KDE audio player.
70
71 %description -l pl
72 Odtwarzacz audio dla KDE.
73
74 %package arts
75 Summary:        Plugin arts
76 Summary(pl):    Wtyczka arts
77 Group:          X11/Applications/Multimedia
78 Requires:       %{name} = %{version}-%{release}
79 Provides:       %{name}-plugin = %{version}-%{release}
80
81 %description arts
82 Plugin arts.
83
84 %description arts -l pl
85 Wtyczka arts.
86
87 %package akode
88 Summary:        Plugin akode
89 Summary(pl):    Wtyczka akode
90 Group:          X11/Applications/Multimedia
91 Requires:       %{name} = %{version}-%{release}
92 Provides:       %{name}-plugin = %{version}-%{release}
93
94 %description akode
95 Plugin akode.
96
97 %description akode -l pl
98 Wtyczka akode.
99
100 %package helix
101 Summary:        Helix/Realplayer playback support for amarok
102 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
103 Group:          X11/Applications/Multimedia
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       helix-core
106 Provides:       %{name}-plugin = %{version}-%{release}
107
108 %description helix
109 Helix/Realplayer playback support for amarok.
110
111 %description helix -l pl
112 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
113
114 %package gstreamer
115 Summary:        Plugin gstreamer
116 Summary(pl):    Wtyczka gstreamer
117 Group:          X11/Applications/Multimedia
118 # deps, to get it working:
119 # mp3 decoder: gstreamer-mad
120 # ogg decoder: gstreamer-vorbis
121 # audio output driver: gstreamer-audiosink-alsa
122 # from gstreamer-audio-effects to control volume, etc
123 # needed libs:
124 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
125 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
126 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
127 # gstreamer-musicbrainz for being able to edit id3 tags on files.
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       gstreamer-audio-effects
130 Requires:       gstreamer-audiosink
131 Requires:       gstreamer-mad
132 Requires:       gstreamer-musicbrainz
133 Requires:       gstreamer-vorbis
134 Provides:       %{name}-plugin = %{version}-%{release}
135
136 %description gstreamer
137 Plugin gstreamer.
138
139 %description gstreamer -l pl
140 Wtyczka gstreamer.
141
142 %package xine
143 Summary:        Plugin xine
144 Summary(pl):    Wtyczka xine
145 Group:          X11/Applications/Multimedia
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       xine-plugin-audio
148 Provides:       %{name}-plugin = %{version}-%{release}
149
150 %description xine
151 Plugin xine.
152
153 %description xine -l pl
154 Wtyczka xine.
155
156 %package xmms
157 Summary:        Xmms wrapper
158 Summary(pl):    Wrapper xmms
159 Group:          X11/Applications/Multimedia
160 Requires:       %{name} = %{version}-%{release}
161
162 %description xmms
163 Xmms wrapper.
164
165 %description xmms -l pl
166 Wrapper xmms.
167
168 %package zeroconf
169 Summary:        Zeroconf data
170 Summary(pl):    Dane dla zeroconf
171 Group:          X11/Applications/Multimedia
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       kdenetwork-kdnssd
174 Provides:       %{name}-plugin = %{version}-%{release}
175
176 %description zeroconf
177 Zeroconf data.
178
179 %description zeroconf -l pl
180 Dane dla zeroconf.
181
182 %package scripts
183 Summary:        amaroK scripts
184 Summary(pl):    Skrypty amaroKa
185 Group:          X11/Applications/Multimedia
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       kdebase-kdialog
188 Requires:       python-PyQt
189
190 %description scripts
191 amaroK scripts allow you extend amaroK functionality.
192
193 You can learn more about scripts in amaroK from here:
194 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
195
196 %description scripts -l pl
197 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
198
199 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
200 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
201
202 %prep
203 %setup -q
204 %patch0 -p1
205 %{?with_altlyrics:%patch1 -p1}
206 #%patch2 -p1 ## probably unnided
207 %patch3 -p1
208 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
209         amarok/src/amarok.desktop \
210
211 # see kde bug #110909
212 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
213
214 %build
215 cp -f /usr/share/automake/config.sub admin
216
217 %{__make} -f admin/Makefile.common cvs
218
219 # hack: passing something other than "no" or "yes" to --with-helix allows
220 # us to pass HELIX_LIBS
221 %configure \
222         HELIX_LIBS=%{_libdir}/helixplayer \
223         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
224         --disable-rpath \
225         --with%{!?with_arts:out}-arts \
226         --with%{!?with_mas:out}-mas \
227         --with%{!?with_xine:out}-xine \
228         --with%{!?with_gstreamer:out}-gstreamer \
229         --with%{!?with_akode:out}-akode \
230         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
231         --with%{!?with_nmm:out}-nmm \
232         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
233         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
234         --disable-final \
235         --with-qt-libraries=%{_libdir} \
236         --with%{!?with_included_sqlite:out}-included-sqlite
237
238 %{__make}
239
240 %install
241 rm -rf $RPM_BUILD_ROOT
242
243 %{__make} install \
244         DESTDIR=$RPM_BUILD_ROOT \
245         kde_htmldir=%{_kdedocdir} \
246         kde_libs_htmldir=%{_kdedocdir}
247
248 # remove bogus dir
249 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
250
251 %find_lang amarok --all-name --with-kde
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %post
257 if [ "$1" = 1 ]; then
258         echo "Remember to install libvisual-plugins-* packages if you"
259         echo "want to have a visualizations in amaroK."
260 fi
261
262 %files -f %{name}.lang
263 %defattr(644,root,root,755)
264 %doc AUTHORS ChangeLog README
265 %attr(755,root,root) %{_bindir}/amarok
266 %attr(755,root,root) %{_bindir}/amarokapp
267 %attr(755,root,root) %{_bindir}/amarok_libvisual
268 #%attr(755,root,root) %{_bindir}/release_amarok
269 %{_libdir}/kde3/konqsidebar_universalamarok.la
270 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
271 %{_libdir}/kde3/libamarok_void-engine_plugin.la
272 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
273 %dir %{_datadir}/apps/amarok
274 %dir %{_datadir}/apps/amarok/scripts
275 %{_datadir}/apps/amarok/*.rc
276 %{_datadir}/apps/amarok/data
277 %{_datadir}/apps/amarok/icons
278 %{_datadir}/apps/amarok/images
279 %{_datadir}/apps/amarok/themes
280 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
281 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
282 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
283 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
284 %{_datadir}/apps/profiles/amarok.profile.xml
285 %{_datadir}/config/amarokrc
286 %{_datadir}/config.kcfg/amarok.kcfg
287 %{_datadir}/services/amarok_void-engine_plugin.desktop
288 %{_datadir}/servicetypes/amarok_plugin.desktop
289 %{_desktopdir}/kde/amarok.desktop
290 %{_iconsdir}/*/*/apps/amarok.*
291
292 %if %{with arts}
293 %files arts
294 %defattr(644,root,root,755)
295 %{_libdir}/kde3/libamarok_artsengine_plugin.la
296 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
297 %{_libdir}/libamarokarts.la
298 %attr(755,root,root) %{_libdir}/libamarokarts.so
299 %{_libdir}/mcop/Amarok
300 %{_libdir}/mcop/amarokarts.mcopclass
301 %{_libdir}/mcop/amarokarts.mcoptype
302 %{_datadir}/services/amarok_artsengine_plugin.desktop
303 %endif
304
305 %if %{with akode}
306 %files akode
307 %defattr(644,root,root,755)
308 %{_libdir}/kde3/libamarok_aKode-engine.la
309 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
310 %{_datadir}/services/amarok_aKode-engine.desktop
311 %endif
312
313 %if %{with gstreamer}
314 %files gstreamer
315 %defattr(644,root,root,755)
316 %{_libdir}/kde3/libamarok_gstengine_plugin.la
317 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
318 %{_datadir}/config.kcfg/gstconfig.kcfg
319 %{_datadir}/services/amarok_gstengine_plugin.desktop
320 %endif
321
322 %if %{with helix}
323 %files helix
324 %defattr(644,root,root,755)
325 %{_libdir}/kde3/libamarok_helixengine_plugin.la
326 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
327 %{_datadir}/config.kcfg/helixconfig.kcfg
328 %{_datadir}/services/amarok_helixengine_plugin.desktop
329 %endif
330
331 %if %{with xine}
332 %files xine
333 %defattr(644,root,root,755)
334 %{_libdir}/kde3/libamarok_xine-engine.la
335 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
336 %{_datadir}/config.kcfg/xinecfg.kcfg
337 %{_datadir}/services/amarok_xine-engine.desktop
338 #%{_datadir}/services/amarok_xineengine_plugin.desktop
339 %endif
340
341 %if %{with xmms}
342 %files xmms
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
345 %endif
346
347 %if 0
348 %if %{with zeroconf}
349 %files zeroconf
350 %defattr(644,root,root,755)
351 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
352 %endif
353 %endif
354
355 %files scripts
356 %defattr(644,root,root,755)
357
358 %dir %{_datadir}/apps/amarok/scripts/alarm
359 %{_datadir}/apps/amarok/scripts/alarm/README
360 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
361
362 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
363 %{_datadir}/apps/amarok/scripts/graphequalizer/README
364 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
365
366 %dir %{_datadir}/apps/amarok/scripts/playlist2html
367 %{_datadir}/apps/amarok/scripts/playlist2html/README
368 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
369 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
370 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
371
372 %dir %{_datadir}/apps/amarok/scripts/templates
373 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
374 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
375 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
376
377 %dir %{_datadir}/apps/amarok/scripts/webcontrol
378 %{_datadir}/apps/amarok/scripts/webcontrol/README
379 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
380 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
381 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
382 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
383 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
384 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
385 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
386 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
387 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
388 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
389 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
390 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
391 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
392 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
393 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
394 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
395
396 %dir %{_datadir}/apps/amarok/scripts/common
397 %{_datadir}/apps/amarok/scripts/common/Publisher.py
398 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
399
400 #%dir %{_datadir}/apps/amarok/scripts/shouter
401 #%{_datadir}/apps/amarok/scripts/shouter/README
402 #%{_datadir}/apps/amarok/scripts/shouter/ChangeLog
403 #%{_datadir}/apps/amarok/scripts/shouter/Amarok.py
404 #%{_datadir}/apps/amarok/scripts/shouter/Globals.py
405 #%{_datadir}/apps/amarok/scripts/shouter/Playlist.py
406 #%{_datadir}/apps/amarok/scripts/shouter/Services.py
407 #%{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
408 #%{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
409 #%{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
410 #%{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
411 #%{_datadir}/apps/amarok/scripts/shouter/StreamController.py
412 #%{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
413 #%{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
414 #%{_datadir}/apps/amarok/scripts/shouter/debug.py
415 #%{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
416 #%dir %{_datadir}/apps/amarok/scripts/shouter/silence
417 #%{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
418 #%dir %{_datadir}/apps/amarok/scripts/shouter/test
419 #%{_datadir}/apps/amarok/scripts/shouter/test/client.py
420 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
421
422 %if 0
423 %dir %{_datadir}/apps/amarok/scripts/amarok_live
424 %{_datadir}/apps/amarok/scripts/amarok_live/README
425 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
426 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
427 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
428 %endif
This page took 0.107323 seconds and 4 git commands to generate.