]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- rel 5
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 #
10 # Conditional builds:
11 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
12 %bcond_without  mas             # disable MAS audio backend
13 %bcond_without  xine            # disable xine engine
14 %bcond_without  xmms            # disable xmms wrapping
15 %bcond_without  zeroconf        # disable support for zeroconf
16 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
17 %bcond_without  helix           # disable HelixPlayer engine
18 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
19 %bcond_with     nmm             # enable NMM audio backend
20 %bcond_with     mysql           # enable MySQL support
21 %bcond_with     pgsql           # enable PostgreSQL support
22 #
23 %ifarch i386
24 %undefine       with_helix
25 %endif
26
27 Summary:        A KDE audio player
28 Summary(pl):    Odtwarzacz audio dla KDE
29 Name:           amarok
30 Version:        1.4.4
31 Release:        5
32 License:        GPL
33 Group:          X11/Applications/Multimedia
34 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
35 Source0:        http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  56a9aec42088c338b81252f8e0651781
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         %{name}-sparc.patch
41 Patch4:         kde-ac260-lt.patch
42 Patch5:         kde-common-PLD.patch
43 URL:            http://amarok.kde.org/
44 BuildRequires:  SDL-devel
45 BuildRequires:  alsa-lib-devel
46 BuildRequires:  autoconf
47 BuildRequires:  automake
48 BuildRequires:  dbus-glib-devel
49 BuildRequires:  gettext-devel
50 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
51 BuildRequires:  kdebase-devel
52 %{?with_akode:BuildRequires:    kdemultimedia-akode}
53 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
54 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
55 %{?with_mp3players:BuildRequires:       libifp-devel}
56 %{?with_mp3players:BuildRequires:       libmtp-devel}
57 %{?with_mp3players:BuildRequires:       libnjb-devel}
58 BuildRequires:  libltdl-devel
59 %{?with_pgsql:BuildRequires:            libpqxx-devel}
60 BuildRequires:  libtunepimp-devel >= 0.5.1-6
61 BuildRequires:  libvisual-devel >= 0.4.0
62 BuildRequires:  mpeg4ip-devel
63 %{?with_mysql:BuildRequires:            mysql-devel}
64 BuildRequires:  pcre-devel
65 BuildRequires:  pkgconfig
66 BuildRequires:  rpm-pythonprov
67 BuildRequires:  rpmbuild(macros) >= 1.129
68 BuildRequires:  ruby-devel >= 1.8
69 BuildRequires:  sed >= 4.0
70 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
71 BuildRequires:  taglib-devel >= 1.4
72 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
73 %{?with_xmms:BuildRequires:     xmms-devel}
74 Requires(post): /sbin/ldconfig
75 Requires:       %{name}-plugin = %{version}-%{release}
76 Requires:       kdebase-core >= 9:3.1.93
77 Requires:       kdemultimedia-audiocd >= 9:3.1.93
78 Obsoletes:      amarok-arts
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
82 %define         filterout_ld    -Wl,--as-needed
83
84 %description
85 A KDE audio player.
86
87 %description -l pl
88 Odtwarzacz audio dla KDE.
89
90 %package akode
91 Summary:        Plugin akode
92 Summary(pl):    Wtyczka akode
93 Group:          X11/Applications/Multimedia
94 Requires:       %{name} = %{version}-%{release}
95 Provides:       %{name}-plugin = %{version}-%{release}
96
97 %description akode
98 Plugin akode.
99
100 %description akode -l pl
101 Wtyczka akode.
102
103 %package helix
104 Summary:        Helix/Realplayer playback support for amarok
105 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
106 Group:          X11/Applications/Multimedia
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       helix-core
109 Provides:       %{name}-plugin = %{version}-%{release}
110
111 %description helix
112 Helix/Realplayer playback support for amarok.
113
114 %description helix -l pl
115 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
116
117 %package gstreamer
118 Summary:        Plugin gstreamer
119 Summary(pl):    Wtyczka gstreamer
120 Group:          X11/Applications/Multimedia
121 # deps, to get it working:
122 # mp3 decoder:  gstreamer-mad
123 # ogg decoder:  gstreamer-vorbis
124 # audio output driver:  gstreamer-audiosink-alsa
125 # from gstreamer-audio-effects to control volume, etc
126 # needed libs:
127 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
128 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
129 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
130 # gstreamer-musicbrainz for being able to edit id3 tags on files.
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       gstreamer-audio-effects
133 Requires:       gstreamer-audiosink
134 Requires:       gstreamer-mad
135 Requires:       gstreamer-musicbrainz
136 Requires:       gstreamer-vorbis
137 Provides:       %{name}-plugin = %{version}-%{release}
138
139 %description gstreamer
140 Plugin gstreamer.
141
142 %description gstreamer -l pl
143 Wtyczka gstreamer.
144
145 %package xine
146 Summary:        Plugin xine
147 Summary(pl):    Wtyczka xine
148 Group:          X11/Applications/Multimedia
149 Requires:       %{name} = %{version}-%{release}
150 Requires:       xine-plugin-audio
151 Provides:       %{name}-plugin = %{version}-%{release}
152
153 %description xine
154 Plugin xine.
155
156 %description xine -l pl
157 Wtyczka xine.
158
159 %package xmms
160 Summary:        Xmms wrapper
161 Summary(pl):    Wrapper xmms
162 Group:          X11/Applications/Multimedia
163 Requires:       %{name} = %{version}-%{release}
164
165 %description xmms
166 Xmms wrapper.
167
168 %description xmms -l pl
169 Wrapper xmms.
170
171 %package zeroconf
172 Summary:        Zeroconf data
173 Summary(pl):    Dane dla zeroconf
174 Group:          X11/Applications/Multimedia
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       kdenetwork-kdnssd
177 Provides:       %{name}-plugin = %{version}-%{release}
178
179 %description zeroconf
180 Zeroconf data.
181
182 %description zeroconf -l pl
183 Dane dla zeroconf.
184
185 %package scripts
186 Summary:        amaroK scripts
187 Summary(pl):    Skrypty amaroKa
188 Group:          X11/Applications/Multimedia
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       kdebase-kdialog
191 Requires:       python-PyQt
192 Requires:       ruby-modules
193
194 %description scripts
195 amaroK scripts allow you extend amaroK functionality.
196
197 You can learn more about scripts in amaroK from here:
198 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
199
200 %description scripts -l pl
201 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
202
203 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
204 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
205
206 %prep
207 %setup -q
208 %patch0 -p1
209 %patch1 -p1
210 %patch2 -p0
211 %patch3 -p0
212 %patch4 -p1
213 %patch5 -p1
214
215 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
216         amarok/src/amarok.desktop \
217
218 # see kde bug #110909
219 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
220
221 # kill env, call interpreter directly, so rpm automatics could rule
222 %{__sed} -i -e '
223         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
224         1s,#!.*bin/env.*python,#!%{_bindir}/python,
225         1s,#!.*bin/env.*bash,#!/bin/bash,
226 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
227
228 %build
229 cp -f /usr/share/automake/config.sub admin
230 %{__make} -f admin/Makefile.common cvs
231
232 # hack: passing something other than "no" or "yes" to --with-helix allows
233 # us to pass HELIX_LIBS
234 %configure \
235         HELIX_LIBS=%{_libdir}/helixplayer \
236         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
237         --disable-rpath \
238         --with%{!?with_mas:out}-mas \
239         --with%{!?with_xine:out}-xine \
240         --with%{!?with_gstreamer:out}-gstreamer10 \
241         --with%{!?with_akode:out}-akode \
242         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
243         --with%{!?with_nmm:out}-nmm \
244         --with%{!?with_xmms:out}-xmms \
245         --with%{!?with_mp3players:out}-libgpod \
246         --with%{!?with_mp3players:out}-libnjb \
247         --with%{!?with_mp3players:out}-libmtp \
248         --with%{!?with_mp3players:out}-ifp \
249         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
250         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
251         --disable-final \
252         --with-mp4v2 \
253         --with-qt-libraries=%{_libdir} \
254         --with%{!?with_included_sqlite:out}-included-sqlite
255
256 %{__make}
257
258 %install
259 rm -rf $RPM_BUILD_ROOT
260
261 %{__make} install \
262         DESTDIR=$RPM_BUILD_ROOT \
263         kde_htmldir=%{_kdedocdir} \
264         kde_libs_htmldir=%{_kdedocdir}
265
266 # remove bogus dir
267 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
268
269 %find_lang amarok --all-name --with-kde
270
271 %clean
272 rm -rf $RPM_BUILD_ROOT
273
274 %post
275 /sbin/ldconfig
276 if [ "$1" = 1 ]; then
277         echo "Remember to install libvisual-plugins-* packages if you"
278         echo "want to have a visualizations in amaroK."
279 fi
280
281 %postun -p /sbin/ldconfig
282
283 %files -f %{name}.lang
284 %defattr(644,root,root,755)
285 %doc AUTHORS ChangeLog README
286 %attr(755,root,root) %{_bindir}/amarok
287 %attr(755,root,root) %{_bindir}/amarokapp
288 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
289 %attr(755,root,root) %{_bindir}/amarok_libvisual
290 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
291 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
292 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
293 %{_libdir}/kde3/konqsidebar_universalamarok.la
294 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
295 %{_libdir}/kde3/libamarok_generic-mediadevice.la
296 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
297 %{_libdir}/kde3/libamarok_void-engine_plugin.la
298 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
299 %{_libdir}/libamarok.la
300 %{_libdir}/kde3/libamarok_daap-mediadevice.la
301 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
302 %{_libdir}/kde3/libamarok_massstorage-device.la
303 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
304 %{_libdir}/kde3/libamarok_nfs-device.la
305 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
306 %{_libdir}/kde3/libamarok_smb-device.la
307 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
308 %{_libdir}/ruby_lib/http11.rb
309 %{_libdir}/ruby_lib/libhttp11.la
310 %attr(755,root,root) %{_libdir}/ruby_lib/libhttp11.so.0.0.0
311 %dir %{_datadir}/apps/amarok
312 %dir %{_datadir}/apps/amarok/scripts
313 %{_datadir}/apps/amarok/ruby_lib
314 %{_datadir}/apps/amarok/*.rc
315 %{_datadir}/apps/amarok/data
316 %{_datadir}/apps/amarok/icons
317 %{_datadir}/apps/amarok/images
318 %{_datadir}/apps/amarok/themes
319 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
320 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
321 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
322 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
323 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
324 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
325 %{_datadir}/apps/profiles/amarok.profile.xml
326 %{_datadir}/config/amarokrc
327 %{_datadir}/config.kcfg/amarok.kcfg
328 %{_datadir}/services/amarok_generic-mediadevice.desktop
329 %{_datadir}/services/amarok_void-engine_plugin.desktop
330 %{_datadir}/services/amarok_daap-mediadevice.desktop
331 %{_datadir}/services/amarok_massstorage-device.desktop
332 %{_datadir}/services/amarok_nfs-device.desktop
333 %{_datadir}/services/amarok_smb-device.desktop
334 %{_datadir}/services/amaroklastfm.protocol
335 %{_datadir}/services/amarokitpc.protocol
336 %{_datadir}/services/amarokpcast.protocol
337 %{_datadir}/servicetypes/amarok_codecinstall.desktop
338 %{_datadir}/servicetypes/amarok_plugin.desktop
339 %{_desktopdir}/kde/amarok.desktop
340 %{_iconsdir}/*/*/apps/amarok.*
341 # TODO: move to subpackage
342 %if %{with mp3players}
343 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
344 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
345 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
346 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
347 %{_libdir}/kde3/libamarok_mtp-mediadevice.la
348 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
349 %{_libdir}/kde3/libamarok_njb-mediadevice.la
350 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
351 %{_datadir}/services/amarok_ifp-mediadevice.desktop
352 %{_datadir}/services/amarok_ipod-mediadevice.desktop
353 %{_datadir}/services/amarok_mtp-mediadevice.desktop
354 %{_datadir}/services/amarok_njb-mediadevice.desktop
355 %endif
356
357 %if %{with akode}
358 %files akode
359 %defattr(644,root,root,755)
360 %{_libdir}/kde3/libamarok_aKode-engine.la
361 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
362 %{_datadir}/services/amarok_aKode-engine.desktop
363 %endif
364
365 %if %{with gstreamer}
366 %files gstreamer
367 %defattr(644,root,root,755)
368 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
369 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
370 %{_datadir}/config.kcfg/gstconfig.kcfg
371 %{_datadir}/services/amarok_gst10engine_plugin.desktop
372 %endif
373
374 %if %{with helix}
375 %files helix
376 %defattr(644,root,root,755)
377 %{_libdir}/kde3/libamarok_helixengine_plugin.la
378 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
379 %{_datadir}/config.kcfg/helixconfig.kcfg
380 %{_datadir}/services/amarok_helixengine_plugin.desktop
381 %endif
382
383 %if %{with xine}
384 %files xine
385 %defattr(644,root,root,755)
386 %{_libdir}/kde3/libamarok_xine-engine.la
387 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
388 %{_datadir}/config.kcfg/xinecfg.kcfg
389 %{_datadir}/services/amarok_xine-engine.desktop
390 %endif
391
392 %if %{with xmms}
393 %files xmms
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
396 %endif
397
398 %if 0
399 %if %{with zeroconf}
400 %files zeroconf
401 %defattr(644,root,root,755)
402 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
403 %endif
404 %endif
405
406 %files scripts
407 %defattr(644,root,root,755)
408 %dir %{_datadir}/apps/amarok/scripts/common
409 %{_datadir}/apps/amarok/scripts/common/Publisher.py
410 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
411
412 %dir %{_datadir}/apps/amarok/scripts/templates
413 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
414 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
415 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
416
417 # amarok searches for executable programs for scripts
418 # to figure out which files need to have execute permission, use this
419 # find command:
420 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
421
422 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
423 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
424 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
425
426 %dir %{_datadir}/apps/amarok/scripts/playlist2html
427 %{_datadir}/apps/amarok/scripts/playlist2html/README
428 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
429 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
430 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
431
432 %dir %{_datadir}/apps/amarok/scripts/webcontrol
433 %{_datadir}/apps/amarok/scripts/webcontrol/README
434 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
435 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
436 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
437 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
438 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
439 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
440 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
441 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
442 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
443 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
444 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
445 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
446 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
447 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
448 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
449 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
450 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
451 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
452 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
453
454 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
455 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
456 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
457 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
458 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
459
460 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
461 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
462 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
463 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
464 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
465
466 %dir %{_datadir}/apps/amarok/scripts/score_default
467 %{_datadir}/apps/amarok/scripts/score_default/COPYING
468 %{_datadir}/apps/amarok/scripts/score_default/README
469 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
470 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
471 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
472 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
473 %{_datadir}/apps/amarok/scripts/score_impulsive/README
474 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
475 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
476
477 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
478 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
479
480 %if 0
481 %dir %{_datadir}/apps/amarok/scripts/amarok_live
482 %{_datadir}/apps/amarok/scripts/amarok_live/README
483 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
484 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
485 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
486 %endif
This page took 0.423187 seconds and 4 git commands to generate.