]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- updated to 1.3.3
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * HelixPlayer engine (fix build - propably some BRs)
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_with     helix           # enable HelixPlayer engine
15 %bcond_with     nmm             # enable NMM audio backend
16 %bcond_with     mysql           # enable mysql support
17 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
18 %bcond_with     altlyrics       # use alternative lyrics provider
19 Summary:        A KDE audio player
20 Summary(pl):    Odtwarzacz audio dla KDE
21 Name:           amarok
22 Version:        1.3.3
23 Release:        1
24 License:        GPL
25 Group:          X11/Applications/Multimedia
26 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
27 # Source0-md5:  13f02c3cce06d9c1d0511171d736efa3
28 Patch0:         kde-common-gcc4.patch
29 Patch1:         %{name}-lyricsurl.patch
30 URL:            http://amarok.kde.org/
31 #BuildRequires: kdebindings-kjsembed-devel
32 #BuildRequires: unsermake >= 040511
33 BuildRequires:  SDL-devel
34 BuildRequires:  alsa-lib-devel
35 BuildRequires:  arts-qt-devel
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
39 BuildRequires:  kdebase-devel
40 %{?with_akode:BuildRequires:    kdemultimedia-akode}
41 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libmusicbrainz-devel
44 BuildRequires:  libvisual-devel >= 0.2.0
45 %{?with_mysql:BuildRequires:            mysql-devel}
46 BuildRequires:  pcre-devel
47 BuildRequires:  rpm-pythonprov
48 BuildRequires:  rpmbuild(macros) >= 1.129
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  sqlite3-devel
51 BuildRequires:  taglib-devel >= 1.4
52 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
53 %{?with_xmms:BuildRequires:             xmms-devel}
54 Requires:       %{name}-plugin = %{version}-%{release}
55 Requires:       kdebase-core >= 9:3.1.93
56 Requires:       kdemultimedia-audiocd >= 9:3.1.93
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 A KDE audio player.
61
62 %description -l pl
63 Odtwarzacz audio dla KDE.
64
65 %package arts
66 Summary:        Plugin arts
67 Summary(pl):    Wtyczka arts
68 Group:          X11/Applications/Multimedia
69 Requires:       %{name} = %{version}-%{release}
70 Provides:       %{name}-plugin = %{version}-%{release}
71
72 %description arts
73 Plugin arts.
74
75 %description arts -l pl
76 Wtyczka arts.
77
78 %package akode
79 Summary:        Plugin akode
80 Summary(pl):    Wtyczka akode
81 Group:          X11/Applications/Multimedia
82 Requires:       %{name} = %{version}-%{release}
83 Provides:       %{name}-plugin = %{version}-%{release}
84
85 %description akode
86 Plugin akode.
87
88 %description akode -l pl
89 Wtyczka akode.
90
91 %package gstreamer
92 Summary:        Plugin gstreamer
93 Summary(pl):    Wtyczka gstreamer
94 Group:          X11/Applications/Multimedia
95 # deps, to get it working:
96 # mp3 decoder: gstreamer-mad
97 # ogg decoder: gstreamer-vorbis
98 # audio output driver: gstreamer-audiosink-alsa
99 # from gstreamer-audio-effects to control volume, etc
100 # needed libs:
101 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
102 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
103 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
104 # gstreamer-musicbrainz for being able to edit id3 tags on files.
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       gstreamer-audio-effects
107 Requires:       gstreamer-audiosink
108 Requires:       gstreamer-mad
109 Requires:       gstreamer-musicbrainz
110 Requires:       gstreamer-vorbis
111 Provides:       %{name}-plugin = %{version}-%{release}
112
113 %description gstreamer
114 Plugin gstreamer.
115
116 %description gstreamer -l pl
117 Wtyczka gstreamer.
118
119 %package xine
120 Summary:        Plugin xine
121 Summary(pl):    Wtyczka xine
122 Group:          X11/Applications/Multimedia
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       xine-plugin-audio
125 Provides:       %{name}-plugin = %{version}-%{release}
126
127 %description xine
128 Plugin xine.
129
130 %description xine -l pl
131 Wtyczka xine.
132
133 %package zeroconf
134 Summary:        Zeroconf data
135 Summary(pl):    Dane dla zeroconf
136 Group:          X11/Applications/Multimedia
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       kdenetwork-kdnssd
139 Provides:       %{name}-plugin = %{version}-%{release}
140
141 %description zeroconf
142 Zeroconf data.
143
144 %description zeroconf -l pl
145 Dane dla zeroconf.
146
147 %package scripts
148 Summary:        amaroK scripts
149 Summary(pl):    Skrypty amaroKa
150 Group:          X11/Applications/Multimedia
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       kdebase-kdialog
153 Requires:       python-PyQt
154
155 %description scripts
156 amaroK scripts allow you extend amaroK functionality.
157
158 You can learn more about scripts in amaroK from here:
159 <http://amarok.kde.org/wiki/index.php/Scripts>.
160
161 %description scripts -l pl
162 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
163
164 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
165 <http://amarok.kde.org/wiki/index.php/Scripts>.
166
167 %prep
168 %setup -q
169 %patch0 -p1
170 %{?with_altlyrics:%patch1 -p1}
171 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
172         amarok/src/amarok.desktop \
173
174 # see kde bug #110909
175 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
176
177 %build
178 %{__aclocal}
179 %{__autoconf}
180 %{__autoheader}
181 %{__automake}
182
183 cp -f /usr/share/automake/config.sub admin
184
185 #export UNSERMAKE=/usr/share/unsermake/unsermake
186
187 %{__make} -f admin/Makefile.common cvs
188
189 %configure \
190         --disable-rpath \
191         %{!?with_arts:--without-arts} \
192         %{?with_mas:--with-mas} \
193         %{!?with_xine:--without-xine} \
194         %{!?with_gstreamer:--without-gstreamer} \
195         %{!?with_akode:--without-akode} \
196         %{?with_helix:--with-helix} \
197         %{?with_nmm:--with-nmm} \
198         %{?with_mysql:--with-mysql} \
199         --disable-final \
200         --with-qt-libraries=%{_libdir} \
201         --without-included-sqlite
202
203 %{__make}
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207
208 %{__make} install \
209         DESTDIR=$RPM_BUILD_ROOT \
210         kde_htmldir=%{_kdedocdir} \
211         kde_libs_htmldir=%{_kdedocdir}
212
213 # remove bogus dir
214 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
215
216 %find_lang amarok --all-name --with-kde
217
218 %clean
219 rm -rf $RPM_BUILD_ROOT
220
221 %post
222 if [ "$1" = 1 ]; then
223         echo "Remember to install libvisual-plugins-* packages if you"
224         echo "want to have a visualizations in amaroK."
225 fi
226
227 %files -f %{name}.lang
228 %defattr(644,root,root,755)
229 %doc AUTHORS ChangeLog README TODO
230 %attr(755,root,root) %{_bindir}/amarok
231 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
232 %attr(755,root,root) %{_bindir}/amarokapp
233 %attr(755,root,root) %{_bindir}/amarok_libvisual
234 #%attr(755,root,root) %{_bindir}/release_amarok
235 %{_libdir}/kde3/konqsidebar_universalamarok.la
236 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
237 %{_libdir}/kde3/libamarok_void-engine_plugin.la
238 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
239 %dir %{_datadir}/apps/amarok
240 %dir %{_datadir}/apps/amarok/scripts
241 %{_datadir}/apps/amarok/*.rc
242 %{_datadir}/apps/amarok/data
243 %{_datadir}/apps/amarok/icons
244 %{_datadir}/apps/amarok/images
245 %{_datadir}/apps/amarok/themes
246 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
247 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
248 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
249 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
250 %{_datadir}/apps/profiles/amarok.profile.xml
251 %{_datadir}/config/amarokrc
252 %{_datadir}/config.kcfg/amarok.kcfg
253 %{_datadir}/services/amarok_void-engine_plugin.desktop
254 %{_datadir}/servicetypes/amarok_plugin.desktop
255 %{_desktopdir}/kde/amarok.desktop
256 %{_iconsdir}/*/*/apps/amarok.*
257
258 %if %{with arts}
259 %files arts
260 %defattr(644,root,root,755)
261 %{_libdir}/kde3/libamarok_artsengine_plugin.la
262 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
263 %{_libdir}/libamarokarts.la
264 %attr(755,root,root) %{_libdir}/libamarokarts.so
265 %{_libdir}/mcop/Amarok
266 %{_libdir}/mcop/amarokarts.mcopclass
267 %{_libdir}/mcop/amarokarts.mcoptype
268 %{_datadir}/services/amarok_artsengine_plugin.desktop
269 %endif
270
271 %if %{with akode}
272 %files akode
273 %defattr(644,root,root,755)
274 %{_libdir}/kde3/libamarok_aKode-engine.la
275 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
276 %{_datadir}/services/amarok_aKode-engine.desktop
277 %endif
278
279 %if %{with gstreamer}
280 %files gstreamer
281 %defattr(644,root,root,755)
282 %{_libdir}/kde3/libamarok_gstengine_plugin.la
283 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
284 %{_datadir}/config.kcfg/gstconfig.kcfg
285 %{_datadir}/services/amarok_gstengine_plugin.desktop
286 %endif
287
288 %if %{with xine}
289 %files xine
290 %defattr(644,root,root,755)
291 %{_libdir}/kde3/libamarok_xine-engine.la
292 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
293 %{_datadir}/config.kcfg/xinecfg.kcfg
294 %{_datadir}/services/amarok_xine-engine.desktop
295 #%{_datadir}/services/amarok_xineengine_plugin.desktop
296 %endif
297
298 %if %{with zeroconf}
299 %files zeroconf
300 %defattr(644,root,root,755)
301 %{_datadir}/apps/zeroconf/_shoutcast._tcp
302 %endif
303
304 %files scripts
305 %defattr(644,root,root,755)
306
307 %dir %{_datadir}/apps/amarok/scripts/alarm
308 %{_datadir}/apps/amarok/scripts/alarm/README
309 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
310
311 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
312 %{_datadir}/apps/amarok/scripts/graphequalizer/README
313 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
314
315 %dir %{_datadir}/apps/amarok/scripts/playlist2html
316 %{_datadir}/apps/amarok/scripts/playlist2html/README
317 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
318 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
319 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
320
321 %dir %{_datadir}/apps/amarok/scripts/templates
322 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
323 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
324 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
325
326 %dir %{_datadir}/apps/amarok/scripts/webcontrol
327 %{_datadir}/apps/amarok/scripts/webcontrol/README
328 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
329 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
330 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
331 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
332 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
333 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
334 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
335 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
336 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
337 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
338 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
339 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
340 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
341 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
342 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
343 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
344
345 %dir %{_datadir}/apps/amarok/scripts/common
346 %{_datadir}/apps/amarok/scripts/common/Publisher.py
347 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
348
349 %dir %{_datadir}/apps/amarok/scripts/shouter
350 %{_datadir}/apps/amarok/scripts/shouter/README
351 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
352 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
353 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
354 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
355 %{_datadir}/apps/amarok/scripts/shouter/Services.py
356 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
357 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
358 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
359 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
360 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
361 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
362 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
363 %{_datadir}/apps/amarok/scripts/shouter/debug.py
364 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
365 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
366 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
367 %dir %{_datadir}/apps/amarok/scripts/shouter/test
368 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
369 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
370
371 %if 0
372 %dir %{_datadir}/apps/amarok/scripts/amarok_live
373 %{_datadir}/apps/amarok/scripts/amarok_live/README
374 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
375 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
376 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
377 %endif
This page took 0.062225 seconds and 4 git commands to generate.