]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- added amarok-desktop.patch, which fixes a wrong mimetype definition
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3.5
25 Release:        3
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  faac790ea432a784fa7d1ac6a34ee410
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         %{name}-lyricsurl.patch
32 Patch2:         %{name}-desktop.patch
33 URL:            http://amarok.kde.org/
34 #BuildRequires: kdebindings-kjsembed-devel
35 #BuildRequires: unsermake >= 040511
36 BuildRequires:  SDL-devel
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  arts-qt-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
42 BuildRequires:  kdebase-devel
43 %{?with_akode:BuildRequires:    kdemultimedia-akode}
44 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
45 BuildRequires:  libltdl-devel
46 BuildRequires:  libmusicbrainz-devel
47 BuildRequires:  libvisual-devel >= 0.2.0
48 %{?with_mysql:BuildRequires:            mysql-devel}
49 %{?with_pgsql:BuildRequires:            libpqxx-devel}
50 BuildRequires:  pcre-devel
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.129
53 BuildRequires:  sed >= 4.0
54 %{?with_helix:BuildRequires:helix-core}
55 %{?!with_included_sqlite:BuildRequires: sqlite3-devel}
56 BuildRequires:  taglib-devel >= 1.4
57 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
58 %{?with_xmms:BuildRequires:             xmms-devel}
59 Requires:       %{name}-plugin = %{version}-%{release}
60 Requires:       kdebase-core >= 9:3.1.93
61 Requires:       kdemultimedia-audiocd >= 9:3.1.93
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 A KDE audio player.
66
67 %description -l pl
68 Odtwarzacz audio dla KDE.
69
70 %package arts
71 Summary:        Plugin arts
72 Summary(pl):    Wtyczka arts
73 Group:          X11/Applications/Multimedia
74 Requires:       %{name} = %{version}-%{release}
75 Provides:       %{name}-plugin = %{version}-%{release}
76
77 %description arts
78 Plugin arts.
79
80 %description arts -l pl
81 Wtyczka arts.
82
83 %package akode
84 Summary:        Plugin akode
85 Summary(pl):    Wtyczka akode
86 Group:          X11/Applications/Multimedia
87 Requires:       %{name} = %{version}-%{release}
88 Provides:       %{name}-plugin = %{version}-%{release}
89
90 %description akode
91 Plugin akode.
92
93 %description akode -l pl
94 Wtyczka akode.
95
96 %package gstreamer
97 Summary:        Plugin gstreamer
98 Summary(pl):    Wtyczka gstreamer
99 Group:          X11/Applications/Multimedia
100 # deps, to get it working:
101 # mp3 decoder: gstreamer-mad
102 # ogg decoder: gstreamer-vorbis
103 # audio output driver: gstreamer-audiosink-alsa
104 # from gstreamer-audio-effects to control volume, etc
105 # needed libs:
106 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
107 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
108 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
109 # gstreamer-musicbrainz for being able to edit id3 tags on files.
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       gstreamer-audio-effects
112 Requires:       gstreamer-audiosink
113 Requires:       gstreamer-mad
114 Requires:       gstreamer-musicbrainz
115 Requires:       gstreamer-vorbis
116 Provides:       %{name}-plugin = %{version}-%{release}
117
118 %description gstreamer
119 Plugin gstreamer.
120
121 %description gstreamer -l pl
122 Wtyczka gstreamer.
123
124 %package xine
125 Summary:        Plugin xine
126 Summary(pl):    Wtyczka xine
127 Group:          X11/Applications/Multimedia
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       xine-plugin-audio
130 Provides:       %{name}-plugin = %{version}-%{release}
131
132 %description xine
133 Plugin xine.
134
135 %description xine -l pl
136 Wtyczka xine.
137
138 %package zeroconf
139 Summary:        Zeroconf data
140 Summary(pl):    Dane dla zeroconf
141 Group:          X11/Applications/Multimedia
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       kdenetwork-kdnssd
144 Provides:       %{name}-plugin = %{version}-%{release}
145
146 %description zeroconf
147 Zeroconf data.
148
149 %description zeroconf -l pl
150 Dane dla zeroconf.
151
152 %package scripts
153 Summary:        amaroK scripts
154 Summary(pl):    Skrypty amaroKa
155 Group:          X11/Applications/Multimedia
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       kdebase-kdialog
158 Requires:       python-PyQt
159
160 %description scripts
161 amaroK scripts allow you extend amaroK functionality.
162
163 You can learn more about scripts in amaroK from here:
164 <http://amarok.kde.org/wiki/index.php/Scripts>.
165
166 %description scripts -l pl
167 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
168
169 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
170 <http://amarok.kde.org/wiki/index.php/Scripts>.
171
172 %prep
173 %setup -q
174 %patch0 -p1
175 %{?with_altlyrics:%patch1 -p1}
176 %patch2 -p1
177 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
178         amarok/src/amarok.desktop \
179
180 # see kde bug #110909
181 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
182
183 %build
184 %{__aclocal}
185 %{__autoconf}
186 %{__autoheader}
187 %{__automake}
188
189 cp -f /usr/share/automake/config.sub admin
190
191 #export UNSERMAKE=/usr/share/unsermake/unsermake
192
193 %{__make} -f admin/Makefile.common cvs
194
195 %configure \
196         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
197         --disable-rpath \
198         --with%{!?with_arts:out}-arts \
199         --with%{!?with_mas:out}-mas \
200         --with%{!?with_xine:out}-xine \
201         --with%{!?with_gstreamer:out}-gstreamer \
202         --with%{!?with_akode:out}-akode \
203         --with%{!?with_helix:out}-helix \
204         --with%{!?with_nmm:out}-nmm \
205         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
206         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
207         --disable-final \
208         --with-qt-libraries=%{_libdir} \
209         --with%{!?with_included_sqlite:out}-included-sqlite
210
211 %{__make}
212
213 %install
214 rm -rf $RPM_BUILD_ROOT
215
216 %{__make} install \
217         DESTDIR=$RPM_BUILD_ROOT \
218         kde_htmldir=%{_kdedocdir} \
219         kde_libs_htmldir=%{_kdedocdir}
220
221 # remove bogus dir
222 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
223
224 %find_lang amarok --all-name --with-kde
225
226 %clean
227 rm -rf $RPM_BUILD_ROOT
228
229 %post
230 if [ "$1" = 1 ]; then
231         echo "Remember to install libvisual-plugins-* packages if you"
232         echo "want to have a visualizations in amaroK."
233 fi
234
235 %files -f %{name}.lang
236 %defattr(644,root,root,755)
237 %doc AUTHORS ChangeLog README
238 %attr(755,root,root) %{_bindir}/amarok
239 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
240 %attr(755,root,root) %{_bindir}/amarokapp
241 %attr(755,root,root) %{_bindir}/amarok_libvisual
242 #%attr(755,root,root) %{_bindir}/release_amarok
243 %{_libdir}/kde3/konqsidebar_universalamarok.la
244 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
245 %{_libdir}/kde3/libamarok_void-engine_plugin.la
246 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
247 %dir %{_datadir}/apps/amarok
248 %dir %{_datadir}/apps/amarok/scripts
249 %{_datadir}/apps/amarok/*.rc
250 %{_datadir}/apps/amarok/data
251 %{_datadir}/apps/amarok/icons
252 %{_datadir}/apps/amarok/images
253 %{_datadir}/apps/amarok/themes
254 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
255 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
256 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
257 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
258 %{_datadir}/apps/profiles/amarok.profile.xml
259 %{_datadir}/config/amarokrc
260 %{_datadir}/config.kcfg/amarok.kcfg
261 %{_datadir}/services/amarok_void-engine_plugin.desktop
262 %{_datadir}/servicetypes/amarok_plugin.desktop
263 %{_desktopdir}/kde/amarok.desktop
264 %{_iconsdir}/*/*/apps/amarok.*
265
266 %if %{with arts}
267 %files arts
268 %defattr(644,root,root,755)
269 %{_libdir}/kde3/libamarok_artsengine_plugin.la
270 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
271 %{_libdir}/libamarokarts.la
272 %attr(755,root,root) %{_libdir}/libamarokarts.so
273 %{_libdir}/mcop/Amarok
274 %{_libdir}/mcop/amarokarts.mcopclass
275 %{_libdir}/mcop/amarokarts.mcoptype
276 %{_datadir}/services/amarok_artsengine_plugin.desktop
277 %endif
278
279 %if %{with akode}
280 %files akode
281 %defattr(644,root,root,755)
282 %{_libdir}/kde3/libamarok_aKode-engine.la
283 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
284 %{_datadir}/services/amarok_aKode-engine.desktop
285 %endif
286
287 %if %{with gstreamer}
288 %files gstreamer
289 %defattr(644,root,root,755)
290 %{_libdir}/kde3/libamarok_gstengine_plugin.la
291 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
292 %{_datadir}/config.kcfg/gstconfig.kcfg
293 %{_datadir}/services/amarok_gstengine_plugin.desktop
294 %endif
295
296 %if %{with xine}
297 %files xine
298 %defattr(644,root,root,755)
299 %{_libdir}/kde3/libamarok_xine-engine.la
300 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
301 %{_datadir}/config.kcfg/xinecfg.kcfg
302 %{_datadir}/services/amarok_xine-engine.desktop
303 #%{_datadir}/services/amarok_xineengine_plugin.desktop
304 %endif
305
306 %if %{with zeroconf}
307 %files zeroconf
308 %defattr(644,root,root,755)
309 %{_datadir}/apps/zeroconf/_shoutcast._tcp
310 %endif
311
312 %files scripts
313 %defattr(644,root,root,755)
314
315 %dir %{_datadir}/apps/amarok/scripts/alarm
316 %{_datadir}/apps/amarok/scripts/alarm/README
317 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
318
319 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
320 %{_datadir}/apps/amarok/scripts/graphequalizer/README
321 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
322
323 %dir %{_datadir}/apps/amarok/scripts/playlist2html
324 %{_datadir}/apps/amarok/scripts/playlist2html/README
325 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
326 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
327 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
328
329 %dir %{_datadir}/apps/amarok/scripts/templates
330 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
331 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
332 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
333
334 %dir %{_datadir}/apps/amarok/scripts/webcontrol
335 %{_datadir}/apps/amarok/scripts/webcontrol/README
336 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
337 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
338 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
339 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
340 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
341 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
342 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
343 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
344 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
345 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
346 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
347 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
348 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
349 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
350 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
351 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
352
353 %dir %{_datadir}/apps/amarok/scripts/common
354 %{_datadir}/apps/amarok/scripts/common/Publisher.py
355 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
356
357 %dir %{_datadir}/apps/amarok/scripts/shouter
358 %{_datadir}/apps/amarok/scripts/shouter/README
359 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
360 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
361 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
362 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
363 %{_datadir}/apps/amarok/scripts/shouter/Services.py
364 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
365 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
366 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
367 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
368 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
369 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
370 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
371 %{_datadir}/apps/amarok/scripts/shouter/debug.py
372 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
373 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
374 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
375 %dir %{_datadir}/apps/amarok/scripts/shouter/test
376 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
377 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
378
379 %if 0
380 %dir %{_datadir}/apps/amarok/scripts/amarok_live
381 %{_datadir}/apps/amarok/scripts/amarok_live/README
382 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
383 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
384 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
385 %endif
This page took 0.194525 seconds and 4 git commands to generate.