]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- kdialog mostly needed for -scripts
[packages/amarok.git] / amarok.spec
1 # This file does not like to be adapterized!
2 # - or at least rpm is broken, as it doesn't build without rpm-pythonprov
3 #
4 # TODO:
5 #       * postgresql support alongside mysql
6 #       * NMM audio backend support (fix build - propably some BRs)
7 #       * make descriptions less useless
8 #       * HelixPlayer engine (fix build - propably some BRs)
9 #
10 # Conditional builds:
11 %bcond_without  arts            # disable arts engine
12 %bcond_without  gstreamer       # disable gstreamer
13 %bcond_without  mas             # disable MAS audio backend
14 %bcond_without  xine            # disable xine engine
15 %bcond_without  xmms            # disable xmms wrapping
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_with     helix           # enable HelixPlayer engine
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable mysql support
20 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3
25 Release:        1.2
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         http://websvn.kde.org/trunk/extragear/multimedia/amarok/src/playlistbrowseritem.h?rev=449581&r1=449054&r2=449581&makepatch=1&diff_format=u
32 URL:            http://amarok.kde.org/
33 BuildRequires:  SDL-devel
34 BuildRequires:  alsa-lib-devel
35 BuildRequires:  arts-qt-devel
36 BuildRequires:  automake
37 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
38 BuildRequires:  kdebase-devel
39 %{?with_akode:BuildRequires:    kdemultimedia-akode}
40 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
41 BuildRequires:  libltdl-devel
42 BuildRequires:  libmusicbrainz-devel
43 BuildRequires:  libvisual-devel >= 0.2.0
44 BuildRequires:  pcre-devel
45 BuildRequires:  rpmbuild(macros) >= 1.129
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  sqlite3-devel
49 BuildRequires:  taglib-devel >= 1.4
50 #BuildRequires: unsermake >= 040511
51 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
52 %{?with_xmms:BuildRequires:             xmms-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 #BuildRequires: kdebindings-kjsembed-devel
55 Requires:       %{name}-plugin = %{version}-%{release}
56 Requires:       kdebase-core >= 9:3.1.93
57 Requires:       kdemultimedia-audiocd >= 9:3.1.93
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 A KDE audio player.
62
63 %description -l pl
64 Odtwarzacz audio dla KDE.
65
66 %package arts
67 Summary:        Plugin arts
68 Summary(pl):    Wtyczka arts
69 Group:          X11/Applications/Multimedia
70 Requires:       %{name} = %{version}-%{release}
71 Provides:       %{name}-plugin = %{version}-%{release}
72
73 %description arts
74 Plugin arts.
75
76 %description arts -l pl
77 Wtyczka arts.
78
79 %package akode
80 Summary:        Plugin akode
81 Summary(pl):    Wtyczka akode
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       %{name}-plugin = %{version}-%{release}
85
86 %description akode
87 Plugin akode.
88
89 %description akode -l pl
90 Wtyczka akode.
91
92 %package gstreamer
93 Summary:        Plugin gstreamer
94 Summary(pl):    Wtyczka gstreamer
95 Group:          X11/Applications/Multimedia
96 # deps, to get it working:
97 # mp3 decoder: gstreamer-mad
98 # ogg decoder: gstreamer-vorbis
99 # audio output driver: gstreamer-audiosink-alsa
100 # from gstreamer-audio-effects to control volume, etc
101 # needed libs:
102 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
103 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
104 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
105 # gstreamer-musicbrainz for being able to edit id3 tags on files.
106 Requires:       gstreamer-audio-effects
107 Requires:       gstreamer-audiosink
108 Requires:       gstreamer-mad
109 Requires:       gstreamer-vorbis
110 Requires:       gstreamer-musicbrainz
111 Requires:       %{name} = %{version}-%{release}
112 Provides:       %{name}-plugin = %{version}-%{release}
113
114 %description gstreamer
115 Plugin gstreamer.
116
117 %description gstreamer -l pl
118 Wtyczka gstreamer.
119
120 %package xine
121 Summary:        Plugin xine
122 Summary(pl):    Wtyczka xine
123 Group:          X11/Applications/Multimedia
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       xine-plugin-audio
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description xine
129 Plugin xine.
130
131 %description xine -l pl
132 Wtyczka xine.
133
134 %package zeroconf
135 Summary:        Zeroconf data
136 Summary(pl):    Dane dla zeroconf
137 Group:          X11/Applications/Multimedia
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       kdenetwork-kdnssd
140 Provides:       %{name}-plugin = %{version}-%{release}
141
142 %description zeroconf
143 Zeroconf data.
144
145 %description zeroconf -l pl
146 Dane dla zeroconf.
147
148 %package scripts
149 Summary:        amaroK scripts
150 Group:          X11/Applications/Multimedia
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       kdebase-kdialog
153
154 %description scripts
155 amaroK scripts allow you extend amaroK functionality.
156
157 You can learn more about scripts in amaroK from here:
158 <http://amarok.kde.org/wiki/index.php/Scripts>.
159
160 %prep
161 %setup -q
162 %patch0 -p1
163 %patch1 -p3
164 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
165         amarok/src/amarok.desktop \
166
167 %build
168 cp -f /usr/share/automake/config.sub admin
169
170 #export UNSERMAKE=/usr/share/unsermake/unsermake
171
172 %{__make} -f admin/Makefile.common cvs
173
174 %configure \
175         --disable-rpath \
176         %{!?with_arts:--without-arts} \
177         %{?with_mas:--with-mas} \
178         %{!?with_xine:--without-xine} \
179         %{!?with_gstreamer:--without-gstreamer} \
180         %{!?with_akode:--without-akode} \
181         %{?with_helix:--with-helix} \
182         %{?with_nmm:--with-nmm} \
183         %{?with_mysql:--with-mysql} \
184         --disable-final \
185         --with-qt-libraries=%{_libdir} \
186         --without-included-sqlite
187
188 %{__make}
189
190 %install
191 rm -rf $RPM_BUILD_ROOT
192
193 %{__make} install \
194         DESTDIR=$RPM_BUILD_ROOT \
195         kde_htmldir=%{_kdedocdir} \
196         kde_libs_htmldir=%{_kdedocdir}
197
198 # remove bogus dir
199 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
200
201 %find_lang amarok --all-name --with-kde
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %post
207 if [ "$1" = 1 ]; then
208         echo "Remember to install libvisual-plugins-* packages if you"
209         echo "want to have a visualizations in amaroK."
210 fi
211
212 %files -f %{name}.lang
213 %defattr(644,root,root,755)
214 %doc AUTHORS ChangeLog README TODO
215 %attr(755,root,root) %{_bindir}/amarok
216 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
217 %attr(755,root,root) %{_bindir}/amarokapp
218 %attr(755,root,root) %{_bindir}/amarok_libvisual
219 #%attr(755,root,root) %{_bindir}/release_amarok
220 %{_libdir}/kde3/konqsidebar_universalamarok.la
221 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
222 %{_libdir}/kde3/libamarok_void-engine_plugin.la
223 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
224 %dir %{_datadir}/apps/amarok
225 %dir %{_datadir}/apps/amarok/scripts
226 %{_datadir}/apps/amarok/*.rc
227 %{_datadir}/apps/amarok/data
228 %{_datadir}/apps/amarok/icons
229 %{_datadir}/apps/amarok/images
230 %{_datadir}/apps/amarok/themes
231 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
232 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
233 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
234 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
235 %{_datadir}/apps/profiles/amarok.profile.xml
236 %{_datadir}/config/amarokrc
237 %{_datadir}/config.kcfg/amarok.kcfg
238 %{_datadir}/services/amarok_void-engine_plugin.desktop
239 %{_datadir}/servicetypes/amarok_plugin.desktop
240 %{_desktopdir}/kde/amarok.desktop
241 %{_iconsdir}/*/*/apps/amarok.*
242
243 %if %{with arts}
244 %files arts
245 %defattr(644,root,root,755)
246 %{_libdir}/kde3/libamarok_artsengine_plugin.la
247 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
248 %{_libdir}/libamarokarts.la
249 %attr(755,root,root) %{_libdir}/libamarokarts.so
250 %{_libdir}/mcop/Amarok
251 %{_libdir}/mcop/amarokarts.mcopclass
252 %{_libdir}/mcop/amarokarts.mcoptype
253 %{_datadir}/services/amarok_artsengine_plugin.desktop
254 %endif
255
256 %if %{with akode}
257 %files akode
258 %defattr(644,root,root,755)
259 %{_libdir}/kde3/libamarok_aKode-engine.la
260 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
261 %{_datadir}/services/amarok_aKode-engine.desktop
262 %endif
263
264 %if %{with gstreamer}
265 %files gstreamer
266 %defattr(644,root,root,755)
267 %{_libdir}/kde3/libamarok_gstengine_plugin.la
268 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
269 %{_datadir}/config.kcfg/gstconfig.kcfg
270 %{_datadir}/services/amarok_gstengine_plugin.desktop
271 %endif
272
273 %if %{with xine}
274 %files xine
275 %defattr(644,root,root,755)
276 %{_libdir}/kde3/libamarok_xine-engine.la
277 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
278 %{_datadir}/config.kcfg/xinecfg.kcfg
279 %{_datadir}/services/amarok_xine-engine.desktop
280 #%{_datadir}/services/amarok_xineengine_plugin.desktop
281 %endif
282
283 %if %{with zeroconf}
284 %files zeroconf
285 %defattr(644,root,root,755)
286 %{_datadir}/apps/zeroconf/_shoutcast._tcp
287 %endif
288
289 %files scripts
290 %defattr(644,root,root,755)
291
292 %dir %{_datadir}/apps/amarok/scripts/alarm
293 %{_datadir}/apps/amarok/scripts/alarm/README
294 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
295
296 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
297 %{_datadir}/apps/amarok/scripts/graphequalizer/README
298 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
299
300 %dir %{_datadir}/apps/amarok/scripts/playlist2html
301 %{_datadir}/apps/amarok/scripts/playlist2html/README
302 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
303 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
304 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
305
306 %dir %{_datadir}/apps/amarok/scripts/templates
307 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
308 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
309 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
310
311 %dir %{_datadir}/apps/amarok/scripts/webcontrol
312 %{_datadir}/apps/amarok/scripts/webcontrol/README
313 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
314 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
315 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
316 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
317 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
318 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
319 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
320 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
321 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
322 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
323 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
324 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
325 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
326 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
327 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
328 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
329
330 %dir %{_datadir}/apps/amarok/scripts/common
331 %{_datadir}/apps/amarok/scripts/common/Publisher.py
332 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
333
334 %dir %{_datadir}/apps/amarok/scripts/shouter
335 %{_datadir}/apps/amarok/scripts/shouter/README
336 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
337 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
338 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
339 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
340 %{_datadir}/apps/amarok/scripts/shouter/Services.py
341 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
342 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
343 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
344 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
345 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
346 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
347 %{_datadir}/apps/amarok/scripts/shouter/debug.py
348 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
349 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
350 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-128.mp3
351 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-160.mp3
352 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-192.mp3
353 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-224.mp3
354 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-256.mp3
355 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-320.mp3
356 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
357 %dir %{_datadir}/apps/amarok/scripts/shouter/test
358 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
359 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
360
361 %dir %{_datadir}/apps/amarok/scripts/amarok_live
362 %{_datadir}/apps/amarok/scripts/amarok_live/README
363 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
364 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
365 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
This page took 0.078583 seconds and 4 git commands to generate.