]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- faster and better lyrics url (my own wrapper)
[packages/amarok.git] / amarok.spec
1 # This file does not like to be adapterized!
2 # - or at least rpm is broken, as it doesn't build without rpm-pythonprov
3 #
4 # TODO:
5 #       * postgresql support alongside mysql
6 #       * NMM audio backend support (fix build - propably some BRs)
7 #       * make descriptions less useless
8 #       * HelixPlayer engine (fix build - propably some BRs)
9 #
10 # Conditional builds:
11 %bcond_without  arts            # disable arts engine
12 %bcond_without  gstreamer       # disable gstreamer
13 %bcond_without  mas             # disable MAS audio backend
14 %bcond_without  xine            # disable xine engine
15 %bcond_without  xmms            # disable xmms wrapping
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_with     helix           # enable HelixPlayer engine
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable mysql support
20 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3
25 Release:        1.3
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         http://websvn.kde.org/trunk/extragear/multimedia/amarok/src/playlistbrowseritem.h?rev=449581&r1=449054&r2=449581&makepatch=1&diff_format=u
32 Patch2:         %{name}-lyricsurl.patch
33 URL:            http://amarok.kde.org/
34 BuildRequires:  SDL-devel
35 BuildRequires:  alsa-lib-devel
36 BuildRequires:  arts-qt-devel
37 BuildRequires:  automake
38 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
39 BuildRequires:  kdebase-devel
40 %{?with_akode:BuildRequires:    kdemultimedia-akode}
41 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libmusicbrainz-devel
44 BuildRequires:  libvisual-devel >= 0.2.0
45 BuildRequires:  pcre-devel
46 BuildRequires:  rpmbuild(macros) >= 1.129
47 BuildRequires:  rpm-pythonprov
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  sqlite3-devel
50 BuildRequires:  taglib-devel >= 1.4
51 #BuildRequires: unsermake >= 040511
52 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
53 %{?with_xmms:BuildRequires:             xmms-devel}
54 %{?with_mysql:BuildRequires:            mysql-devel}
55 #BuildRequires: kdebindings-kjsembed-devel
56 Requires:       %{name}-plugin = %{version}-%{release}
57 Requires:       kdebase-core >= 9:3.1.93
58 Requires:       kdemultimedia-audiocd >= 9:3.1.93
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 A KDE audio player.
63
64 %description -l pl
65 Odtwarzacz audio dla KDE.
66
67 %package arts
68 Summary:        Plugin arts
69 Summary(pl):    Wtyczka arts
70 Group:          X11/Applications/Multimedia
71 Requires:       %{name} = %{version}-%{release}
72 Provides:       %{name}-plugin = %{version}-%{release}
73
74 %description arts
75 Plugin arts.
76
77 %description arts -l pl
78 Wtyczka arts.
79
80 %package akode
81 Summary:        Plugin akode
82 Summary(pl):    Wtyczka akode
83 Group:          X11/Applications/Multimedia
84 Requires:       %{name} = %{version}-%{release}
85 Provides:       %{name}-plugin = %{version}-%{release}
86
87 %description akode
88 Plugin akode.
89
90 %description akode -l pl
91 Wtyczka akode.
92
93 %package gstreamer
94 Summary:        Plugin gstreamer
95 Summary(pl):    Wtyczka gstreamer
96 Group:          X11/Applications/Multimedia
97 # deps, to get it working:
98 # mp3 decoder: gstreamer-mad
99 # ogg decoder: gstreamer-vorbis
100 # audio output driver: gstreamer-audiosink-alsa
101 # from gstreamer-audio-effects to control volume, etc
102 # needed libs:
103 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
104 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
105 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
106 # gstreamer-musicbrainz for being able to edit id3 tags on files.
107 Requires:       gstreamer-audio-effects
108 Requires:       gstreamer-audiosink
109 Requires:       gstreamer-mad
110 Requires:       gstreamer-vorbis
111 Requires:       gstreamer-musicbrainz
112 Requires:       %{name} = %{version}-%{release}
113 Provides:       %{name}-plugin = %{version}-%{release}
114
115 %description gstreamer
116 Plugin gstreamer.
117
118 %description gstreamer -l pl
119 Wtyczka gstreamer.
120
121 %package xine
122 Summary:        Plugin xine
123 Summary(pl):    Wtyczka xine
124 Group:          X11/Applications/Multimedia
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       xine-plugin-audio
127 Provides:       %{name}-plugin = %{version}-%{release}
128
129 %description xine
130 Plugin xine.
131
132 %description xine -l pl
133 Wtyczka xine.
134
135 %package zeroconf
136 Summary:        Zeroconf data
137 Summary(pl):    Dane dla zeroconf
138 Group:          X11/Applications/Multimedia
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       kdenetwork-kdnssd
141 Provides:       %{name}-plugin = %{version}-%{release}
142
143 %description zeroconf
144 Zeroconf data.
145
146 %description zeroconf -l pl
147 Dane dla zeroconf.
148
149 %package scripts
150 Summary:        amaroK scripts
151 Group:          X11/Applications/Multimedia
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       kdebase-kdialog
154 Requires:       python-PyQt
155
156 %description scripts
157 amaroK scripts allow you extend amaroK functionality.
158
159 You can learn more about scripts in amaroK from here:
160 <http://amarok.kde.org/wiki/index.php/Scripts>.
161
162 %prep
163 %setup -q
164 %patch0 -p1
165 %patch1 -p3
166 %patch2 -p1
167 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
168         amarok/src/amarok.desktop \
169
170 %build
171 cp -f /usr/share/automake/config.sub admin
172
173 #export UNSERMAKE=/usr/share/unsermake/unsermake
174
175 %{__make} -f admin/Makefile.common cvs
176
177 %configure \
178         --disable-rpath \
179         %{!?with_arts:--without-arts} \
180         %{?with_mas:--with-mas} \
181         %{!?with_xine:--without-xine} \
182         %{!?with_gstreamer:--without-gstreamer} \
183         %{!?with_akode:--without-akode} \
184         %{?with_helix:--with-helix} \
185         %{?with_nmm:--with-nmm} \
186         %{?with_mysql:--with-mysql} \
187         --disable-final \
188         --with-qt-libraries=%{_libdir} \
189         --without-included-sqlite
190
191 %{__make}
192
193 %install
194 rm -rf $RPM_BUILD_ROOT
195
196 %{__make} install \
197         DESTDIR=$RPM_BUILD_ROOT \
198         kde_htmldir=%{_kdedocdir} \
199         kde_libs_htmldir=%{_kdedocdir}
200
201 # remove bogus dir
202 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
203
204 %find_lang amarok --all-name --with-kde
205
206 %clean
207 rm -rf $RPM_BUILD_ROOT
208
209 %post
210 if [ "$1" = 1 ]; then
211         echo "Remember to install libvisual-plugins-* packages if you"
212         echo "want to have a visualizations in amaroK."
213 fi
214
215 %files -f %{name}.lang
216 %defattr(644,root,root,755)
217 %doc AUTHORS ChangeLog README TODO
218 %attr(755,root,root) %{_bindir}/amarok
219 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
220 %attr(755,root,root) %{_bindir}/amarokapp
221 %attr(755,root,root) %{_bindir}/amarok_libvisual
222 #%attr(755,root,root) %{_bindir}/release_amarok
223 %{_libdir}/kde3/konqsidebar_universalamarok.la
224 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
225 %{_libdir}/kde3/libamarok_void-engine_plugin.la
226 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
227 %dir %{_datadir}/apps/amarok
228 %dir %{_datadir}/apps/amarok/scripts
229 %{_datadir}/apps/amarok/*.rc
230 %{_datadir}/apps/amarok/data
231 %{_datadir}/apps/amarok/icons
232 %{_datadir}/apps/amarok/images
233 %{_datadir}/apps/amarok/themes
234 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
235 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
236 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
237 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
238 %{_datadir}/apps/profiles/amarok.profile.xml
239 %{_datadir}/config/amarokrc
240 %{_datadir}/config.kcfg/amarok.kcfg
241 %{_datadir}/services/amarok_void-engine_plugin.desktop
242 %{_datadir}/servicetypes/amarok_plugin.desktop
243 %{_desktopdir}/kde/amarok.desktop
244 %{_iconsdir}/*/*/apps/amarok.*
245
246 %if %{with arts}
247 %files arts
248 %defattr(644,root,root,755)
249 %{_libdir}/kde3/libamarok_artsengine_plugin.la
250 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
251 %{_libdir}/libamarokarts.la
252 %attr(755,root,root) %{_libdir}/libamarokarts.so
253 %{_libdir}/mcop/Amarok
254 %{_libdir}/mcop/amarokarts.mcopclass
255 %{_libdir}/mcop/amarokarts.mcoptype
256 %{_datadir}/services/amarok_artsengine_plugin.desktop
257 %endif
258
259 %if %{with akode}
260 %files akode
261 %defattr(644,root,root,755)
262 %{_libdir}/kde3/libamarok_aKode-engine.la
263 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
264 %{_datadir}/services/amarok_aKode-engine.desktop
265 %endif
266
267 %if %{with gstreamer}
268 %files gstreamer
269 %defattr(644,root,root,755)
270 %{_libdir}/kde3/libamarok_gstengine_plugin.la
271 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
272 %{_datadir}/config.kcfg/gstconfig.kcfg
273 %{_datadir}/services/amarok_gstengine_plugin.desktop
274 %endif
275
276 %if %{with xine}
277 %files xine
278 %defattr(644,root,root,755)
279 %{_libdir}/kde3/libamarok_xine-engine.la
280 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
281 %{_datadir}/config.kcfg/xinecfg.kcfg
282 %{_datadir}/services/amarok_xine-engine.desktop
283 #%{_datadir}/services/amarok_xineengine_plugin.desktop
284 %endif
285
286 %if %{with zeroconf}
287 %files zeroconf
288 %defattr(644,root,root,755)
289 %{_datadir}/apps/zeroconf/_shoutcast._tcp
290 %endif
291
292 %files scripts
293 %defattr(644,root,root,755)
294
295 %dir %{_datadir}/apps/amarok/scripts/alarm
296 %{_datadir}/apps/amarok/scripts/alarm/README
297 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
298
299 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
300 %{_datadir}/apps/amarok/scripts/graphequalizer/README
301 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
302
303 %dir %{_datadir}/apps/amarok/scripts/playlist2html
304 %{_datadir}/apps/amarok/scripts/playlist2html/README
305 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
306 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
307 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
308
309 %dir %{_datadir}/apps/amarok/scripts/templates
310 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
311 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
312 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
313
314 %dir %{_datadir}/apps/amarok/scripts/webcontrol
315 %{_datadir}/apps/amarok/scripts/webcontrol/README
316 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
317 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
318 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
319 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
320 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
321 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
322 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
323 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
324 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
325 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
326 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
327 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
328 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
329 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
330 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
331 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
332
333 %dir %{_datadir}/apps/amarok/scripts/common
334 %{_datadir}/apps/amarok/scripts/common/Publisher.py
335 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
336
337 %dir %{_datadir}/apps/amarok/scripts/shouter
338 %{_datadir}/apps/amarok/scripts/shouter/README
339 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
340 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
341 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
342 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
343 %{_datadir}/apps/amarok/scripts/shouter/Services.py
344 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
345 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
346 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
347 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
348 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
349 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
350 %{_datadir}/apps/amarok/scripts/shouter/debug.py
351 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
352 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
353 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-128.mp3
354 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-160.mp3
355 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-192.mp3
356 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-224.mp3
357 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-256.mp3
358 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-320.mp3
359 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
360 %dir %{_datadir}/apps/amarok/scripts/shouter/test
361 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
362 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
363
364 %dir %{_datadir}/apps/amarok/scripts/amarok_live
365 %{_datadir}/apps/amarok/scripts/amarok_live/README
366 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
367 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
368 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
This page took 0.086734 seconds and 4 git commands to generate.