]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- fix path to libnjb
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
9 %bcond_without  mas             # disable MAS audio backend
10 %bcond_without  xine            # disable xine engine
11 %bcond_without  xmms            # disable xmms wrapping
12 %bcond_without  zeroconf        # disable support for zeroconf
13 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
14 %bcond_without  helix           # disable HelixPlayer engine
15 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable MySQL support
18 %bcond_with     pgsql           # enable PostgreSQL support
19 #
20 %ifarch i386
21 %undefine       with_helix
22 %endif
23
24 %define         _beta   beta1
25
26 Summary:        A KDE audio player
27 Summary(pl):    Odtwarzacz audio dla KDE
28 Name:           amarok
29 Version:        1.4.1
30 Release:        0.%{_beta}.1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
34 # Source0-md5:  ee043cf6efa3f2ac7b470eb6c050c0f7
35 Patch0:         %{name}-helixplayer-morearchs.patch
36 URL:            http://amarok.kde.org/
37 BuildRequires:  SDL-devel
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  dbus-glib-devel
42 BuildRequires:  gettext-devel
43 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
44 BuildRequires:  kdebase-devel
45 %{?with_akode:BuildRequires:    kdemultimedia-akode}
46 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
47 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
48 %{?with_mp3players:BuildRequires:       libifp-devel}
49 BuildRequires:  libltdl-devel
50 %{?with_mp3players:BuildRequires:       libnjb-devel}
51 %{?with_pgsql:BuildRequires:            libpqxx-devel}
52 BuildRequires:  libtunepimp-devel >= 0.4.0
53 BuildRequires:  libvisual-devel >= 0.4.0
54 BuildRequires:  mpeg4ip-devel
55 %{?with_mysql:BuildRequires:            mysql-devel}
56 BuildRequires:  pcre-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  rpm-pythonprov
59 BuildRequires:  rpmbuild(macros) >= 1.129
60 BuildRequires:  ruby-devel >= 1.8
61 BuildRequires:  sed >= 4.0
62 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
63 BuildRequires:  taglib-devel >= 1.4
64 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
65 %{?with_xmms:BuildRequires:     xmms-devel}
66 Requires:       %{name}-plugin = %{version}-%{release}
67 Requires:       kdebase-core >= 9:3.1.93
68 Requires:       kdemultimedia-audiocd >= 9:3.1.93
69 Obsoletes:      amarok-arts
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 A KDE audio player.
74
75 %description -l pl
76 Odtwarzacz audio dla KDE.
77
78 %package akode
79 Summary:        Plugin akode
80 Summary(pl):    Wtyczka akode
81 Group:          X11/Applications/Multimedia
82 Requires:       %{name} = %{version}-%{release}
83 Provides:       %{name}-plugin = %{version}-%{release}
84
85 %description akode
86 Plugin akode.
87
88 %description akode -l pl
89 Wtyczka akode.
90
91 %package helix
92 Summary:        Helix/Realplayer playback support for amarok
93 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
94 Group:          X11/Applications/Multimedia
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       helix-core
97 Provides:       %{name}-plugin = %{version}-%{release}
98
99 %description helix
100 Helix/Realplayer playback support for amarok.
101
102 %description helix -l pl
103 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
104
105 %package gstreamer
106 Summary:        Plugin gstreamer
107 Summary(pl):    Wtyczka gstreamer
108 Group:          X11/Applications/Multimedia
109 # deps, to get it working:
110 # mp3 decoder:  gstreamer-mad
111 # ogg decoder:  gstreamer-vorbis
112 # audio output driver:  gstreamer-audiosink-alsa
113 # from gstreamer-audio-effects to control volume, etc
114 # needed libs:
115 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
116 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
117 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
118 # gstreamer-musicbrainz for being able to edit id3 tags on files.
119 Requires:       %{name} = %{version}-%{release}
120 Requires:       gstreamer-audio-effects
121 Requires:       gstreamer-audiosink
122 Requires:       gstreamer-mad
123 Requires:       gstreamer-musicbrainz
124 Requires:       gstreamer-vorbis
125 Provides:       %{name}-plugin = %{version}-%{release}
126
127 %description gstreamer
128 Plugin gstreamer.
129
130 %description gstreamer -l pl
131 Wtyczka gstreamer.
132
133 %package xine
134 Summary:        Plugin xine
135 Summary(pl):    Wtyczka xine
136 Group:          X11/Applications/Multimedia
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       xine-plugin-audio
139 Provides:       %{name}-plugin = %{version}-%{release}
140
141 %description xine
142 Plugin xine.
143
144 %description xine -l pl
145 Wtyczka xine.
146
147 %package xmms
148 Summary:        Xmms wrapper
149 Summary(pl):    Wrapper xmms
150 Group:          X11/Applications/Multimedia
151 Requires:       %{name} = %{version}-%{release}
152
153 %description xmms
154 Xmms wrapper.
155
156 %description xmms -l pl
157 Wrapper xmms.
158
159 %package zeroconf
160 Summary:        Zeroconf data
161 Summary(pl):    Dane dla zeroconf
162 Group:          X11/Applications/Multimedia
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       kdenetwork-kdnssd
165 Provides:       %{name}-plugin = %{version}-%{release}
166
167 %description zeroconf
168 Zeroconf data.
169
170 %description zeroconf -l pl
171 Dane dla zeroconf.
172
173 %package scripts
174 Summary:        amaroK scripts
175 Summary(pl):    Skrypty amaroKa
176 Group:          X11/Applications/Multimedia
177 Requires:       %{name} = %{version}-%{release}
178 Requires:       kdebase-kdialog
179 Requires:       python-PyQt
180 Requires:       ruby-modules
181
182 %description scripts
183 amaroK scripts allow you extend amaroK functionality.
184
185 You can learn more about scripts in amaroK from here:
186 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
187
188 %description scripts -l pl
189 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
190
191 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
192 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
193
194 %prep
195 %setup -q -n %{name}-%{version}-%{_beta}
196 %patch0 -p1
197 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
198         amarok/src/amarok.desktop \
199
200 # see kde bug #110909
201 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
202
203 # kill env, call interpreter directly, so rpm automatics could rule
204 %{__sed} -i -e '
205         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
206         1s,#!.*bin/env.*python,#!%{_bindir}/python,
207         1s,#!.*bin/env.*bash,#!/bin/bash,
208 ' amarok/src/scripts/*/*.{py,rb,sh}
209
210 %build
211 cp -f /usr/share/automake/config.sub admin
212 %{__make} -f admin/Makefile.common cvs
213
214 # hack: passing something other than "no" or "yes" to --with-helix allows
215 # us to pass HELIX_LIBS
216 %configure \
217         HELIX_LIBS=%{_libdir}/helixplayer \
218         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
219         --disable-rpath \
220         --with%{!?with_mas:out}-mas \
221         --with%{!?with_xine:out}-xine \
222         --with%{!?with_gstreamer:out}-gstreamer10 \
223         --with%{!?with_akode:out}-akode \
224         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
225         --with%{!?with_nmm:out}-nmm \
226         --with%{!?with_mp3players:out}-libgpod \
227         --with%{!?with_mp3players:out}-libnjb \
228         --with%{!?with_mp3players:out}-ifp \
229         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
230         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
231         --disable-final \
232         --with-mp4v2 \
233         --with-qt-libraries=%{_libdir} \
234         --with%{!?with_included_sqlite:out}-included-sqlite
235
236 %{__make}
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240
241 %{__make} install \
242         DESTDIR=$RPM_BUILD_ROOT \
243         kde_htmldir=%{_kdedocdir} \
244         kde_libs_htmldir=%{_kdedocdir}
245
246 # remove bogus dir
247 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
248
249 %find_lang amarok --all-name --with-kde
250
251 %clean
252 rm -rf $RPM_BUILD_ROOT
253
254 if [ "$1" = 1 ]; then
255         echo "Remember to install libvisual-plugins-* packages if you"
256         echo "want to have a visualizations in amaroK."
257 fi
258
259 %post   -p /sbin/ldconfig
260 %postun -p /sbin/ldconfig
261
262 %files -f %{name}.lang
263 %defattr(644,root,root,755)
264 %doc AUTHORS ChangeLog README
265 %attr(755,root,root) %{_bindir}/amarok
266 %attr(755,root,root) %{_bindir}/amarokapp
267 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
268 %attr(755,root,root) %{_bindir}/amarok_libvisual
269 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
270 %{_libdir}/kde3/konqsidebar_universalamarok.la
271 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
272 %{_libdir}/kde3/libamarok_generic-mediadevice.la
273 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
274 %{_libdir}/kde3/libamarok_void-engine_plugin.la
275 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
276 %{_libdir}/libamarok.la
277 %dir %{_datadir}/apps/amarok
278 %dir %{_datadir}/apps/amarok/scripts
279 %{_datadir}/apps/amarok/*.rc
280 %{_datadir}/apps/amarok/data
281 %{_datadir}/apps/amarok/icons
282 %{_datadir}/apps/amarok/images
283 %{_datadir}/apps/amarok/themes
284 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
285 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
286 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
287 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
288 %{_datadir}/apps/profiles/amarok.profile.xml
289 %{_datadir}/config/amarokrc
290 %{_datadir}/config.kcfg/amarok.kcfg
291 %{_datadir}/services/amarok_generic-mediadevice.desktop
292 %{_datadir}/services/amarok_void-engine_plugin.desktop
293 %{_datadir}/servicetypes/amarok_plugin.desktop
294 %{_desktopdir}/kde/amarok.desktop
295 %{_iconsdir}/*/*/apps/amarok.*
296 # TODO: move to subpackage
297 %if %{with mp3players}
298 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
299 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
300 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
301 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
302 %{_datadir}/services/amarok_ipod-mediadevice.desktop
303 %{_datadir}/services/amarok_ifp-mediadevice.desktop
304 %endif
305
306 %if %{with akode}
307 %files akode
308 %defattr(644,root,root,755)
309 %{_libdir}/kde3/libamarok_aKode-engine.la
310 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
311 %{_datadir}/services/amarok_aKode-engine.desktop
312 %endif
313
314 %if %{with gstreamer}
315 %files gstreamer
316 %defattr(644,root,root,755)
317 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
318 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
319 %{_datadir}/config.kcfg/gstconfig.kcfg
320 %{_datadir}/services/amarok_gst10engine_plugin.desktop
321 %endif
322
323 %if %{with helix}
324 %files helix
325 %defattr(644,root,root,755)
326 %{_libdir}/kde3/libamarok_helixengine_plugin.la
327 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
328 %{_datadir}/config.kcfg/helixconfig.kcfg
329 %{_datadir}/services/amarok_helixengine_plugin.desktop
330 %endif
331
332 %if %{with xine}
333 %files xine
334 %defattr(644,root,root,755)
335 %{_libdir}/kde3/libamarok_xine-engine.la
336 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
337 %{_datadir}/config.kcfg/xinecfg.kcfg
338 %{_datadir}/services/amarok_xine-engine.desktop
339 #%{_datadir}/services/amarok_xineengine_plugin.desktop
340 %endif
341
342 %if %{with xmms}
343 %files xmms
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
346 %endif
347
348 %if 0
349 %if %{with zeroconf}
350 %files zeroconf
351 %defattr(644,root,root,755)
352 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
353 %endif
354 %endif
355
356 %files scripts
357 %defattr(644,root,root,755)
358 %dir %{_datadir}/apps/amarok/scripts/common
359 %{_datadir}/apps/amarok/scripts/common/Publisher.py
360 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
361
362 %dir %{_datadir}/apps/amarok/scripts/templates
363 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
364 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
365 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
366
367 # amarok searches for executable programs for scripts
368 # to figure out which files need to have execute permission, use this
369 # find command:
370 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
371
372 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
373 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
374 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
375
376 %dir %{_datadir}/apps/amarok/scripts/playlist2html
377 %{_datadir}/apps/amarok/scripts/playlist2html/README
378 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
379 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
380 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
381
382 %dir %{_datadir}/apps/amarok/scripts/webcontrol
383 %{_datadir}/apps/amarok/scripts/webcontrol/README
384 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
385 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
386 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
387 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
388 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
389 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
390 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
391 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
392 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
393 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
394 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
395 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
396 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
397 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
398 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
399 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
400 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
401 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
402 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
403
404 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
405 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
406 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
407 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
408 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
409
410 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
411 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
412 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
413 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
414 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
415
416 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
417 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
418
419 %if 0
420 %dir %{_datadir}/apps/amarok/scripts/amarok_live
421 %{_datadir}/apps/amarok/scripts/amarok_live/README
422 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
423 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
424 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
425 %endif
This page took 0.100482 seconds and 3 git commands to generate.