]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
f49dd338af215b66e50fb99f44a1a87e582a9190
[packages/amarok.git] / amarok.spec
1 # TODO
2 # - try not to link with static mysql
3
4 %define         state   stable
5 %define         qtver   4.6.2
6 %define         kdever  4.4.1
7
8 Summary:        A KDE audio player
9 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        2.2.2
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}-patched.tar.bz2
16 # Source0-md5:  9b4453597e4affb1a6bebe715499782f
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-qthreadpool.patch
19 Patch2:         %{name}-disable_qtscriptbindings_check_fix.patch
20 URL:            http://amarok.kde.org/
21 BuildRequires:  Qt3Support-devel >= %{qtver}
22 BuildRequires:  QtCore-devel >= %{qtver}
23 BuildRequires:  QtDBus-devel >= %{qtver}
24 BuildRequires:  QtNetwork-devel >= %{qtver}
25 BuildRequires:  QtOpenGL-devel >= %{qtver}
26 BuildRequires:  QtScript-devel >= %{qtver}
27 BuildRequires:  QtSql-devel >= %{qtver}
28 BuildRequires:  QtSvg-devel >= %{qtver}
29 BuildRequires:  QtUiTools-devel >= %{qtver}
30 BuildRequires:  QtWebKit-devel >= %{qtver}
31 BuildRequires:  QtXml-devel >= %{qtver}
32 BuildRequires:  automoc4 >= 0.9.88
33 BuildRequires:  cmake >= 2.6.3
34 BuildRequires:  curl-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib2-devel
37 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
38 BuildRequires:  libgpod-devel >= 0.7.0
39 BuildRequires:  liblastfm-devel
40 BuildRequires:  libmtp-devel >= 0.3.0
41 BuildRequires:  loudmouth-devel
42 BuildRequires:  mysql-devel >= 5.1.31-3
43 BuildRequires:  pcre-devel
44 BuildRequires:  pkgconfig
45 BuildRequires:  qca-devel
46 BuildRequires:  qt4-build >= %{qtver}
47 BuildRequires:  qt4-qmake >= %{qtver}
48 BuildRequires:  qtscriptbindings
49 BuildRequires:  rpmbuild(macros) >= 1.129
50 BuildRequires:  strigi-devel >= 0.5.10
51 BuildRequires:  taglib-devel >= 1.6
52 BuildRequires:  taglib-extras-devel >= 1.0.0
53 BuildRequires:  xorg-lib-libXpm-devel
54 Requires(post,postun):  /sbin/ldconfig
55 Requires:       kde4-kdebase-core
56 Requires:       kde4-kdemultimedia-audiocd
57 Requires:       kde4-phonon
58 Requires:       qtscriptbindings
59 Suggests:       libvisual-plugin-actor-JESS
60 Suggests:       libvisual-plugin-actor-bumpscope
61 Suggests:       libvisual-plugin-actor-corona
62 Suggests:       libvisual-plugin-actor-flower
63 Suggests:       libvisual-plugin-actor-gdkpixbuf
64 Suggests:       libvisual-plugin-actor-gforce
65 Suggests:       libvisual-plugin-actor-gstreamer
66 Suggests:       libvisual-plugin-actor-infinite
67 Suggests:       libvisual-plugin-actor-jakdaw
68 Suggests:       libvisual-plugin-actor-lv_analyzer
69 Suggests:       libvisual-plugin-actor-lv_gltest
70 Suggests:       libvisual-plugin-actor-lv_scope
71 Suggests:       libvisual-plugin-actor-madspin
72 Suggests:       libvisual-plugin-actor-nastyfft
73 Suggests:       libvisual-plugin-actor-oinksie
74 Suggests:       libvisual-plugin-input-alsa
75 Suggests:       libvisual-plugin-input-esd
76 Suggests:       libvisual-plugin-input-jack
77 Suggests:       libvisual-plugin-input-mplayer
78 Suggests:       libvisual-plugin-morph-alphablend
79 Suggests:       libvisual-plugin-morph-flash
80 Suggests:       libvisual-plugin-morph-slide
81 Suggests:       libvisual-plugin-morph-tentacle
82 Obsoletes:      amarok-arts
83 Obsoletes:      amarok-xmms
84 # It should require mysql-embeded
85 Requires:       mysql >= 5.1.31-3
86 Conflicts:      mysql < 5.1.31-3
87 # sr@Latn vs. sr@latin
88 Conflicts:      glibc-misc < 6:2.7
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %description
92 A KDE audio player.
93
94 %description -l pl.UTF-8
95 Odtwarzacz audio dla KDE.
96
97 %package scripts
98 Summary:        amaroK scripts
99 Summary(pl.UTF-8):      Skrypty amaroKa
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       kde4-kdebase-kdialog
103
104 %description scripts
105 amaroK scripts allow you extend amaroK functionality.
106
107 You can learn more about scripts in amaroK from here:
108 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
109
110 %description scripts -l pl.UTF-8
111 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
112
113 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
114 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
115
116 %prep
117 %setup -q
118 #%patch0 -p0
119 #%patch1 -p0
120 %patch2 -p1
121
122 %build
123 install -d build
124 cd build
125 %cmake \
126         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
127         -DLIB_INSTALL_DIR=%{_libdir} \
128         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
129 %if "%{_lib}" == "lib64"
130         -DLIB_SUFFIX=64 \
131 %endif
132         ../
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} -C build install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         kde_htmldir=%{_kdedocdir} \
142         kde_libs_htmldir=%{_kdedocdir}
143
144 # remove bogus dir
145 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
146
147 %find_lang %{name} --with-kde
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post           -p /sbin/ldconfig
153 %postun         -p /sbin/ldconfig
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog README
158 %attr(755,root,root) %{_bindir}/amarok
159 %attr(755,root,root) %{_bindir}/amarokpkg
160 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
161 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
162 %attr(755,root,root) %{_bindir}/amarok_afttagger
163 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
164 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
166 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
167 %attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
168 %attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
169 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
170 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
171 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
172 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
173 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
174 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
183 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
184 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
185 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
186 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
203 %dir %{_datadir}/apps/amarok
204 %attr(755,root,root) %{_libdir}/libamaroklib.so
205 %attr(755,root,root) %{_libdir}/libamarokocsclient.so
206 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
207 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
208 %attr(755,root,root) %{_libdir}/libamarokpud.so
209 %dir %{_datadir}/apps/amarok/scripts
210 %{_datadir}/apps/amarok/data
211 %{_datadir}/apps/amarok/icons
212 %{_datadir}/apps/amarok/images
213 %{_datadir}/apps/amarok/amarok.notifyrc
214 %{_datadir}/apps/desktoptheme
215 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
216 %{_datadir}/config.kcfg/amarokconfig.kcfg
217 %{_datadir}/config/amarok.knsrc
218 %{_datadir}/config/amarokapplets.knsrc
219 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
220 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
221 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
222 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
223 %{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
224 %{_datadir}/kde4/services/amarok.protocol
225 %{_datadir}/kde4/services/amaroklastfm.protocol
226 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
227 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
228 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
229 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
230 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
231 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
232 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
233 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
234 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
235 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
236 %{_datadir}/kde4/services/amarok_service_ampache.desktop
237 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
238 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
239 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
240 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
241 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
242 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
243 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
244 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
245 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
246 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
247 %{_datadir}/kde4/services/amarok_massstorage-device.desktop
248 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
250 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
251 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
252 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
253 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
254 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
255 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
256 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
257 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
258 %{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
259 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
260 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
261 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
262 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
263 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
264 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
265 %{_desktopdir}/kde4/amarok.desktop
266 %{_iconsdir}/*/*/apps/amarok.*
267 %{_datadir}/config/amarok_homerc
268
269 %files scripts
270 %defattr(644,root,root,755)
271 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
272 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
273 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
274 %dir %{_datadir}/apps/amarok/scripts/script_console
275 %{_datadir}/apps/amarok/scripts/script_console/main.js
276 %{_datadir}/apps/amarok/scripts/script_console/script.spec
277 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
278 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
279 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
280 %dir %{_datadir}/apps/amarok/scripts/librivox_service
281 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
282 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
283 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
284 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
285 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
286 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
287 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
288 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.064682 seconds and 3 git commands to generate.