]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- unifications
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * HelixPlayer engine (fix build - propably some BRs)
6 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
7 #
8 # Conditional builds:
9 %bcond_without  arts            # disable arts engine
10 %bcond_without  gstreamer       # disable gstreamer
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable support for zeroconf
15 %bcond_with     included_sqlite # use included sqlite, not the distro's
16 %bcond_with     helix           # enable HelixPlayer engine
17 %bcond_with     nmm             # enable NMM audio backend
18 %bcond_with     mysql           # enable mysql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3.3
25 Release:        2
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  13f02c3cce06d9c1d0511171d736efa3
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         %{name}-lyricsurl.patch
32 URL:            http://amarok.kde.org/
33 #BuildRequires: kdebindings-kjsembed-devel
34 #BuildRequires: unsermake >= 040511
35 BuildRequires:  SDL-devel
36 BuildRequires:  alsa-lib-devel
37 BuildRequires:  arts-qt-devel
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
41 BuildRequires:  kdebase-devel
42 %{?with_akode:BuildRequires:    kdemultimedia-akode}
43 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
44 BuildRequires:  libltdl-devel
45 BuildRequires:  libmusicbrainz-devel
46 BuildRequires:  libvisual-devel >= 0.2.0
47 %{?with_mysql:BuildRequires:            mysql-devel}
48 BuildRequires:  pcre-devel
49 BuildRequires:  rpm-pythonprov
50 BuildRequires:  rpmbuild(macros) >= 1.129
51 BuildRequires:  sed >= 4.0
52 %{?!with_included_sqlite:BuildRequires: sqlite3-devel}
53 BuildRequires:  taglib-devel >= 1.4
54 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
55 %{?with_xmms:BuildRequires:             xmms-devel}
56 Requires:       %{name}-plugin = %{version}-%{release}
57 Requires:       kdebase-core >= 9:3.1.93
58 Requires:       kdemultimedia-audiocd >= 9:3.1.93
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 A KDE audio player.
63
64 %description -l pl
65 Odtwarzacz audio dla KDE.
66
67 %package arts
68 Summary:        Plugin arts
69 Summary(pl):    Wtyczka arts
70 Group:          X11/Applications/Multimedia
71 Requires:       %{name} = %{version}-%{release}
72 Provides:       %{name}-plugin = %{version}-%{release}
73
74 %description arts
75 Plugin arts.
76
77 %description arts -l pl
78 Wtyczka arts.
79
80 %package akode
81 Summary:        Plugin akode
82 Summary(pl):    Wtyczka akode
83 Group:          X11/Applications/Multimedia
84 Requires:       %{name} = %{version}-%{release}
85 Provides:       %{name}-plugin = %{version}-%{release}
86
87 %description akode
88 Plugin akode.
89
90 %description akode -l pl
91 Wtyczka akode.
92
93 %package gstreamer
94 Summary:        Plugin gstreamer
95 Summary(pl):    Wtyczka gstreamer
96 Group:          X11/Applications/Multimedia
97 # deps, to get it working:
98 # mp3 decoder: gstreamer-mad
99 # ogg decoder: gstreamer-vorbis
100 # audio output driver: gstreamer-audiosink-alsa
101 # from gstreamer-audio-effects to control volume, etc
102 # needed libs:
103 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
104 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
105 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
106 # gstreamer-musicbrainz for being able to edit id3 tags on files.
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       gstreamer-audio-effects
109 Requires:       gstreamer-audiosink
110 Requires:       gstreamer-mad
111 Requires:       gstreamer-musicbrainz
112 Requires:       gstreamer-vorbis
113 Provides:       %{name}-plugin = %{version}-%{release}
114
115 %description gstreamer
116 Plugin gstreamer.
117
118 %description gstreamer -l pl
119 Wtyczka gstreamer.
120
121 %package xine
122 Summary:        Plugin xine
123 Summary(pl):    Wtyczka xine
124 Group:          X11/Applications/Multimedia
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       xine-plugin-audio
127 Provides:       %{name}-plugin = %{version}-%{release}
128
129 %description xine
130 Plugin xine.
131
132 %description xine -l pl
133 Wtyczka xine.
134
135 %package zeroconf
136 Summary:        Zeroconf data
137 Summary(pl):    Dane dla zeroconf
138 Group:          X11/Applications/Multimedia
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       kdenetwork-kdnssd
141 Provides:       %{name}-plugin = %{version}-%{release}
142
143 %description zeroconf
144 Zeroconf data.
145
146 %description zeroconf -l pl
147 Dane dla zeroconf.
148
149 %package scripts
150 Summary:        amaroK scripts
151 Summary(pl):    Skrypty amaroKa
152 Group:          X11/Applications/Multimedia
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       kdebase-kdialog
155 Requires:       python-PyQt
156
157 %description scripts
158 amaroK scripts allow you extend amaroK functionality.
159
160 You can learn more about scripts in amaroK from here:
161 <http://amarok.kde.org/wiki/index.php/Scripts>.
162
163 %description scripts -l pl
164 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
165
166 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
167 <http://amarok.kde.org/wiki/index.php/Scripts>.
168
169 %prep
170 %setup -q
171 %patch0 -p1
172 %{?with_altlyrics:%patch1 -p1}
173 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
174         amarok/src/amarok.desktop \
175
176 # see kde bug #110909
177 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
178
179 %build
180 %{__aclocal}
181 %{__autoconf}
182 %{__autoheader}
183 %{__automake}
184
185 cp -f /usr/share/automake/config.sub admin
186
187 #export UNSERMAKE=/usr/share/unsermake/unsermake
188
189 %{__make} -f admin/Makefile.common cvs
190
191 %configure \
192         --disable-rpath \
193         %{!?with_arts:--without-arts} \
194         %{?with_mas:--with-mas} \
195         %{!?with_xine:--without-xine} \
196         %{!?with_gstreamer:--without-gstreamer} \
197         %{!?with_akode:--without-akode} \
198         %{?with_helix:--with-helix} \
199         %{?with_nmm:--with-nmm} \
200         %{?with_mysql:--with-mysql} \
201         --disable-final \
202         --with-qt-libraries=%{_libdir} \
203         --with%{?!with_included_sqlite:out}-included-sqlite
204
205 %{__make}
206
207 %install
208 rm -rf $RPM_BUILD_ROOT
209
210 %{__make} install \
211         DESTDIR=$RPM_BUILD_ROOT \
212         kde_htmldir=%{_kdedocdir} \
213         kde_libs_htmldir=%{_kdedocdir}
214
215 # remove bogus dir
216 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
217
218 %find_lang amarok --all-name --with-kde
219
220 %clean
221 rm -rf $RPM_BUILD_ROOT
222
223 %post
224 if [ "$1" = 1 ]; then
225         echo "Remember to install libvisual-plugins-* packages if you"
226         echo "want to have a visualizations in amaroK."
227 fi
228
229 %files -f %{name}.lang
230 %defattr(644,root,root,755)
231 %doc AUTHORS ChangeLog README TODO
232 %attr(755,root,root) %{_bindir}/amarok
233 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
234 %attr(755,root,root) %{_bindir}/amarokapp
235 %attr(755,root,root) %{_bindir}/amarok_libvisual
236 #%attr(755,root,root) %{_bindir}/release_amarok
237 %{_libdir}/kde3/konqsidebar_universalamarok.la
238 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
239 %{_libdir}/kde3/libamarok_void-engine_plugin.la
240 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
241 %dir %{_datadir}/apps/amarok
242 %dir %{_datadir}/apps/amarok/scripts
243 %{_datadir}/apps/amarok/*.rc
244 %{_datadir}/apps/amarok/data
245 %{_datadir}/apps/amarok/icons
246 %{_datadir}/apps/amarok/images
247 %{_datadir}/apps/amarok/themes
248 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
249 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
250 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
251 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
252 %{_datadir}/apps/profiles/amarok.profile.xml
253 %{_datadir}/config/amarokrc
254 %{_datadir}/config.kcfg/amarok.kcfg
255 %{_datadir}/services/amarok_void-engine_plugin.desktop
256 %{_datadir}/servicetypes/amarok_plugin.desktop
257 %{_desktopdir}/kde/amarok.desktop
258 %{_iconsdir}/*/*/apps/amarok.*
259
260 %if %{with arts}
261 %files arts
262 %defattr(644,root,root,755)
263 %{_libdir}/kde3/libamarok_artsengine_plugin.la
264 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
265 %{_libdir}/libamarokarts.la
266 %attr(755,root,root) %{_libdir}/libamarokarts.so
267 %{_libdir}/mcop/Amarok
268 %{_libdir}/mcop/amarokarts.mcopclass
269 %{_libdir}/mcop/amarokarts.mcoptype
270 %{_datadir}/services/amarok_artsengine_plugin.desktop
271 %endif
272
273 %if %{with akode}
274 %files akode
275 %defattr(644,root,root,755)
276 %{_libdir}/kde3/libamarok_aKode-engine.la
277 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
278 %{_datadir}/services/amarok_aKode-engine.desktop
279 %endif
280
281 %if %{with gstreamer}
282 %files gstreamer
283 %defattr(644,root,root,755)
284 %{_libdir}/kde3/libamarok_gstengine_plugin.la
285 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
286 %{_datadir}/config.kcfg/gstconfig.kcfg
287 %{_datadir}/services/amarok_gstengine_plugin.desktop
288 %endif
289
290 %if %{with xine}
291 %files xine
292 %defattr(644,root,root,755)
293 %{_libdir}/kde3/libamarok_xine-engine.la
294 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
295 %{_datadir}/config.kcfg/xinecfg.kcfg
296 %{_datadir}/services/amarok_xine-engine.desktop
297 #%{_datadir}/services/amarok_xineengine_plugin.desktop
298 %endif
299
300 %if %{with zeroconf}
301 %files zeroconf
302 %defattr(644,root,root,755)
303 %{_datadir}/apps/zeroconf/_shoutcast._tcp
304 %endif
305
306 %files scripts
307 %defattr(644,root,root,755)
308
309 %dir %{_datadir}/apps/amarok/scripts/alarm
310 %{_datadir}/apps/amarok/scripts/alarm/README
311 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
312
313 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
314 %{_datadir}/apps/amarok/scripts/graphequalizer/README
315 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
316
317 %dir %{_datadir}/apps/amarok/scripts/playlist2html
318 %{_datadir}/apps/amarok/scripts/playlist2html/README
319 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
320 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
321 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
322
323 %dir %{_datadir}/apps/amarok/scripts/templates
324 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
325 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
326 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
327
328 %dir %{_datadir}/apps/amarok/scripts/webcontrol
329 %{_datadir}/apps/amarok/scripts/webcontrol/README
330 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
331 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
332 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
333 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
334 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
335 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
336 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
337 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
338 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
339 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
340 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
341 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
342 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
343 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
344 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
345 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
346
347 %dir %{_datadir}/apps/amarok/scripts/common
348 %{_datadir}/apps/amarok/scripts/common/Publisher.py
349 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
350
351 %dir %{_datadir}/apps/amarok/scripts/shouter
352 %{_datadir}/apps/amarok/scripts/shouter/README
353 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
354 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
355 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
356 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
357 %{_datadir}/apps/amarok/scripts/shouter/Services.py
358 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
359 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
360 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
361 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
362 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
363 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
364 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
365 %{_datadir}/apps/amarok/scripts/shouter/debug.py
366 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
367 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
368 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
369 %dir %{_datadir}/apps/amarok/scripts/shouter/test
370 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
371 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
372
373 %if 0
374 %dir %{_datadir}/apps/amarok/scripts/amarok_live
375 %{_datadir}/apps/amarok/scripts/amarok_live/README
376 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
377 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
378 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
379 %endif
This page took 0.075491 seconds and 3 git commands to generate.