]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
e6ec0244c32e18da58eb83d82093328ed470284c
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3.6
25 Release:        1
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://nchc.dl.sourceforge.net/sourceforge/amarok/amarok-1.3.6.tar.bz2
29 # Source0-md5:  f97ac51a8c2f150ffc4cc0ef49c59a2f
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         %{name}-lyricsurl.patch
32 URL:            http://amarok.kde.org/
33 #BuildRequires: kdebindings-kjsembed-devel
34 #BuildRequires: unsermake >= 040511
35 BuildRequires:  SDL-devel
36 BuildRequires:  alsa-lib-devel
37 BuildRequires:  arts-qt-devel
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
41 BuildRequires:  kdebase-devel
42 %{?with_akode:BuildRequires:    kdemultimedia-akode}
43 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
44 BuildRequires:  libltdl-devel
45 BuildRequires:  libmusicbrainz-devel
46 BuildRequires:  libvisual-devel >= 0.2.0
47 %{?with_mysql:BuildRequires:            mysql-devel}
48 %{?with_pgsql:BuildRequires:            libpqxx-devel}
49 BuildRequires:  pcre-devel
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.129
52 BuildRequires:  sed >= 4.0
53 %{?with_helix:BuildRequires: helix-core}
54 %{?!with_included_sqlite:BuildRequires: sqlite3-devel}
55 BuildRequires:  taglib-devel >= 1.4
56 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
57 %{?with_xmms:BuildRequires:             xmms-devel}
58 Requires:       %{name}-plugin = %{version}-%{release}
59 Requires:       kdebase-core >= 9:3.1.93
60 Requires:       kdemultimedia-audiocd >= 9:3.1.93
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 A KDE audio player.
65
66 %description -l pl
67 Odtwarzacz audio dla KDE.
68
69 %package arts
70 Summary:        Plugin arts
71 Summary(pl):    Wtyczka arts
72 Group:          X11/Applications/Multimedia
73 Requires:       %{name} = %{version}-%{release}
74 Provides:       %{name}-plugin = %{version}-%{release}
75
76 %description arts
77 Plugin arts.
78
79 %description arts -l pl
80 Wtyczka arts.
81
82 %package akode
83 Summary:        Plugin akode
84 Summary(pl):    Wtyczka akode
85 Group:          X11/Applications/Multimedia
86 Requires:       %{name} = %{version}-%{release}
87 Provides:       %{name}-plugin = %{version}-%{release}
88
89 %description akode
90 Plugin akode.
91
92 %description akode -l pl
93 Wtyczka akode.
94
95 %package helix
96 Summary:        Helix/Realplayer playback support for amarok
97 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
98 Group:          X11/Applications/Multimedia
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       helix-core
101 Provides:       %{name}-plugin = %{version}-%{release}
102
103 %description helix
104 Helix/Realplayer playback support for amarok.
105
106 %description helix -l pl
107 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
108
109
110 %package gstreamer
111 Summary:        Plugin gstreamer
112 Summary(pl):    Wtyczka gstreamer
113 Group:          X11/Applications/Multimedia
114 # deps, to get it working:
115 # mp3 decoder: gstreamer-mad
116 # ogg decoder: gstreamer-vorbis
117 # audio output driver: gstreamer-audiosink-alsa
118 # from gstreamer-audio-effects to control volume, etc
119 # needed libs:
120 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
121 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
122 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
123 # gstreamer-musicbrainz for being able to edit id3 tags on files.
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       gstreamer-audio-effects
126 Requires:       gstreamer-audiosink
127 Requires:       gstreamer-mad
128 Requires:       gstreamer-musicbrainz
129 Requires:       gstreamer-vorbis
130 Provides:       %{name}-plugin = %{version}-%{release}
131
132 %description gstreamer
133 Plugin gstreamer.
134
135 %description gstreamer -l pl
136 Wtyczka gstreamer.
137
138 %package xine
139 Summary:        Plugin xine
140 Summary(pl):    Wtyczka xine
141 Group:          X11/Applications/Multimedia
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       xine-plugin-audio
144 Provides:       %{name}-plugin = %{version}-%{release}
145
146 %description xine
147 Plugin xine.
148
149 %description xine -l pl
150 Wtyczka xine.
151
152 %package zeroconf
153 Summary:        Zeroconf data
154 Summary(pl):    Dane dla zeroconf
155 Group:          X11/Applications/Multimedia
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       kdenetwork-kdnssd
158 Provides:       %{name}-plugin = %{version}-%{release}
159
160 %description zeroconf
161 Zeroconf data.
162
163 %description zeroconf -l pl
164 Dane dla zeroconf.
165
166 %package scripts
167 Summary:        amaroK scripts
168 Summary(pl):    Skrypty amaroKa
169 Group:          X11/Applications/Multimedia
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       kdebase-kdialog
172 Requires:       python-PyQt
173
174 %description scripts
175 amaroK scripts allow you extend amaroK functionality.
176
177 You can learn more about scripts in amaroK from here:
178 <http://amarok.kde.org/wiki/index.php/Scripts>.
179
180 %description scripts -l pl
181 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
182
183 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
184 <http://amarok.kde.org/wiki/index.php/Scripts>.
185
186 %prep
187 %setup -q
188 %patch0 -p1
189 %{?with_altlyrics:%patch1 -p1}
190 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
191         amarok/src/amarok.desktop \
192
193 # see kde bug #110909
194 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
195
196 %build
197 cp -f /usr/share/automake/config.sub admin
198
199 #export UNSERMAKE=/usr/share/unsermake/unsermake
200
201 %{__make} -f admin/Makefile.common cvs
202
203 %configure \
204         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
205         --disable-rpath \
206         --with%{!?with_arts:out}-arts \
207         --with%{!?with_mas:out}-mas \
208         --with%{!?with_xine:out}-xine \
209         --with%{!?with_gstreamer:out}-gstreamer \
210         --with%{!?with_akode:out}-akode \
211         --with%{!?with_helix:out}-helix \
212         --with%{!?with_nmm:out}-nmm \
213         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
214         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
215         --disable-final \
216         --with-qt-libraries=%{_libdir} \
217         --with%{!?with_included_sqlite:out}-included-sqlite
218
219 %{__make}
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223
224 %{__make} install \
225         DESTDIR=$RPM_BUILD_ROOT \
226         kde_htmldir=%{_kdedocdir} \
227         kde_libs_htmldir=%{_kdedocdir}
228
229 # remove bogus dir
230 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
231
232 %find_lang amarok --all-name --with-kde
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post
238 if [ "$1" = 1 ]; then
239         echo "Remember to install libvisual-plugins-* packages if you"
240         echo "want to have a visualizations in amaroK."
241 fi
242
243 %files -f %{name}.lang
244 %defattr(644,root,root,755)
245 %doc AUTHORS ChangeLog README
246 %attr(755,root,root) %{_bindir}/amarok
247 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
248 %attr(755,root,root) %{_bindir}/amarokapp
249 %attr(755,root,root) %{_bindir}/amarok_libvisual
250 #%attr(755,root,root) %{_bindir}/release_amarok
251 %{_libdir}/kde3/konqsidebar_universalamarok.la
252 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
253 %{_libdir}/kde3/libamarok_void-engine_plugin.la
254 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
255 %dir %{_datadir}/apps/amarok
256 %dir %{_datadir}/apps/amarok/scripts
257 %{_datadir}/apps/amarok/*.rc
258 %{_datadir}/apps/amarok/data
259 %{_datadir}/apps/amarok/icons
260 %{_datadir}/apps/amarok/images
261 %{_datadir}/apps/amarok/themes
262 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
263 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
264 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
265 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
266 %{_datadir}/apps/profiles/amarok.profile.xml
267 %{_datadir}/config/amarokrc
268 %{_datadir}/config.kcfg/amarok.kcfg
269 %{_datadir}/services/amarok_void-engine_plugin.desktop
270 %{_datadir}/servicetypes/amarok_plugin.desktop
271 %{_desktopdir}/kde/amarok.desktop
272 %{_iconsdir}/*/*/apps/amarok.*
273
274 %if %{with arts}
275 %files arts
276 %defattr(644,root,root,755)
277 %{_libdir}/kde3/libamarok_artsengine_plugin.la
278 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
279 %{_libdir}/libamarokarts.la
280 %attr(755,root,root) %{_libdir}/libamarokarts.so
281 %{_libdir}/mcop/Amarok
282 %{_libdir}/mcop/amarokarts.mcopclass
283 %{_libdir}/mcop/amarokarts.mcoptype
284 %{_datadir}/services/amarok_artsengine_plugin.desktop
285 %endif
286
287 %if %{with akode}
288 %files akode
289 %defattr(644,root,root,755)
290 %{_libdir}/kde3/libamarok_aKode-engine.la
291 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
292 %{_datadir}/services/amarok_aKode-engine.desktop
293 %endif
294
295 %if %{with gstreamer}
296 %files gstreamer
297 %defattr(644,root,root,755)
298 %{_libdir}/kde3/libamarok_gstengine_plugin.la
299 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
300 %{_datadir}/config.kcfg/gstconfig.kcfg
301 %{_datadir}/services/amarok_gstengine_plugin.desktop
302 %endif
303
304 %if %{with helix}
305 %files helix
306 %defattr(644,root,root,755)
307 %{_libdir}/kde3/libamarok_helixengine_plugin.la
308 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
309 %{_datadir}/config.kcfg/helixconfig.kcfg
310 %{_datadir}/services/amarok_helixengine_plugin.desktop
311 %endif
312
313 %if %{with xine}
314 %files xine
315 %defattr(644,root,root,755)
316 %{_libdir}/kde3/libamarok_xine-engine.la
317 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
318 %{_datadir}/config.kcfg/xinecfg.kcfg
319 %{_datadir}/services/amarok_xine-engine.desktop
320 #%{_datadir}/services/amarok_xineengine_plugin.desktop
321 %endif
322
323 %if %{with zeroconf}
324 %files zeroconf
325 %defattr(644,root,root,755)
326 %{_datadir}/apps/zeroconf/_shoutcast._tcp
327 %endif
328
329 %files scripts
330 %defattr(644,root,root,755)
331
332 %dir %{_datadir}/apps/amarok/scripts/alarm
333 %{_datadir}/apps/amarok/scripts/alarm/README
334 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
335
336 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
337 %{_datadir}/apps/amarok/scripts/graphequalizer/README
338 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
339
340 %dir %{_datadir}/apps/amarok/scripts/playlist2html
341 %{_datadir}/apps/amarok/scripts/playlist2html/README
342 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
343 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
344 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
345
346 %dir %{_datadir}/apps/amarok/scripts/templates
347 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
348 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
349 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
350
351 %dir %{_datadir}/apps/amarok/scripts/webcontrol
352 %{_datadir}/apps/amarok/scripts/webcontrol/README
353 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
354 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
355 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
356 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
357 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
358 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
359 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
360 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
361 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
362 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
363 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
364 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
365 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
366 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
367 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
368 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
369
370 %dir %{_datadir}/apps/amarok/scripts/common
371 %{_datadir}/apps/amarok/scripts/common/Publisher.py
372 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
373
374 %dir %{_datadir}/apps/amarok/scripts/shouter
375 %{_datadir}/apps/amarok/scripts/shouter/README
376 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
377 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
378 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
379 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
380 %{_datadir}/apps/amarok/scripts/shouter/Services.py
381 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
382 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
383 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
384 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
385 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
386 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
387 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
388 %{_datadir}/apps/amarok/scripts/shouter/debug.py
389 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
390 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
391 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
392 %dir %{_datadir}/apps/amarok/scripts/shouter/test
393 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
394 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
395
396 %if 0
397 %dir %{_datadir}/apps/amarok/scripts/amarok_live
398 %{_datadir}/apps/amarok/scripts/amarok_live/README
399 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
400 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
401 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
402 %endif
This page took 0.061395 seconds and 2 git commands to generate.