]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- also adjust LINK for quotes
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 #
9 # Conditional builds:
10 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable support for zeroconf
15 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
16 %bcond_without  helix           # disable HelixPlayer engine
17 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable MySQL support
20 %bcond_with     pgsql           # enable PostgreSQL support
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25
26 Summary:        A KDE audio player
27 Summary(pl):    Odtwarzacz audio dla KDE
28 Name:           amarok
29 Version:        1.4.3
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
34 Source0:        http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
35 # Source0-md5:  b0b4f8952ad23705c70815d50fd0af52
36 Patch0:         %{name}-helixplayer-morearchs.patch
37 Patch1:         %{name}-libnjb.patch
38 URL:            http://amarok.kde.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  dbus-glib-devel
44 BuildRequires:  gettext-devel
45 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
46 BuildRequires:  kdebase-devel
47 %{?with_akode:BuildRequires:    kdemultimedia-akode}
48 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
49 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
50 %{?with_mp3players:BuildRequires:       libgpod-devel < 0.3.1}
51 %{?with_mp3players:BuildRequires:       libifp-devel}
52 %{?with_mp3players:BuildRequires:       libmtp-devel}
53 %{?with_mp3players:BuildRequires:       libnjb-devel}
54 BuildRequires:  libltdl-devel
55 %{?with_pgsql:BuildRequires:            libpqxx-devel}
56 BuildRequires:  libtunepimp-devel >= 0.4.0
57 BuildRequires:  libvisual-devel >= 0.4.0
58 BuildRequires:  mpeg4ip-devel
59 %{?with_mysql:BuildRequires:            mysql-devel}
60 BuildRequires:  pcre-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  rpm-pythonprov
63 BuildRequires:  rpmbuild(macros) >= 1.129
64 BuildRequires:  ruby-devel >= 1.8
65 BuildRequires:  sed >= 4.0
66 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
67 BuildRequires:  taglib-devel >= 1.4
68 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
69 %{?with_xmms:BuildRequires:     xmms-devel}
70 Requires(post): /sbin/ldconfig
71 Requires:       %{name}-plugin = %{version}-%{release}
72 Requires:       kdebase-core >= 9:3.1.93
73 Requires:       kdemultimedia-audiocd >= 9:3.1.93
74 Obsoletes:      amarok-arts
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 A KDE audio player.
79
80 %description -l pl
81 Odtwarzacz audio dla KDE.
82
83 %package akode
84 Summary:        Plugin akode
85 Summary(pl):    Wtyczka akode
86 Group:          X11/Applications/Multimedia
87 Requires:       %{name} = %{version}-%{release}
88 Provides:       %{name}-plugin = %{version}-%{release}
89
90 %description akode
91 Plugin akode.
92
93 %description akode -l pl
94 Wtyczka akode.
95
96 %package helix
97 Summary:        Helix/Realplayer playback support for amarok
98 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
99 Group:          X11/Applications/Multimedia
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       helix-core
102 Provides:       %{name}-plugin = %{version}-%{release}
103
104 %description helix
105 Helix/Realplayer playback support for amarok.
106
107 %description helix -l pl
108 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
109
110 %package gstreamer
111 Summary:        Plugin gstreamer
112 Summary(pl):    Wtyczka gstreamer
113 Group:          X11/Applications/Multimedia
114 # deps, to get it working:
115 # mp3 decoder:  gstreamer-mad
116 # ogg decoder:  gstreamer-vorbis
117 # audio output driver:  gstreamer-audiosink-alsa
118 # from gstreamer-audio-effects to control volume, etc
119 # needed libs:
120 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
121 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
122 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
123 # gstreamer-musicbrainz for being able to edit id3 tags on files.
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       gstreamer-audio-effects
126 Requires:       gstreamer-audiosink
127 Requires:       gstreamer-mad
128 Requires:       gstreamer-musicbrainz
129 Requires:       gstreamer-vorbis
130 Provides:       %{name}-plugin = %{version}-%{release}
131
132 %description gstreamer
133 Plugin gstreamer.
134
135 %description gstreamer -l pl
136 Wtyczka gstreamer.
137
138 %package xine
139 Summary:        Plugin xine
140 Summary(pl):    Wtyczka xine
141 Group:          X11/Applications/Multimedia
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       xine-plugin-audio
144 Provides:       %{name}-plugin = %{version}-%{release}
145
146 %description xine
147 Plugin xine.
148
149 %description xine -l pl
150 Wtyczka xine.
151
152 %package xmms
153 Summary:        Xmms wrapper
154 Summary(pl):    Wrapper xmms
155 Group:          X11/Applications/Multimedia
156 Requires:       %{name} = %{version}-%{release}
157
158 %description xmms
159 Xmms wrapper.
160
161 %description xmms -l pl
162 Wrapper xmms.
163
164 %package zeroconf
165 Summary:        Zeroconf data
166 Summary(pl):    Dane dla zeroconf
167 Group:          X11/Applications/Multimedia
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       kdenetwork-kdnssd
170 Provides:       %{name}-plugin = %{version}-%{release}
171
172 %description zeroconf
173 Zeroconf data.
174
175 %description zeroconf -l pl
176 Dane dla zeroconf.
177
178 %package scripts
179 Summary:        amaroK scripts
180 Summary(pl):    Skrypty amaroKa
181 Group:          X11/Applications/Multimedia
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       kdebase-kdialog
184 Requires:       python-PyQt
185 Requires:       ruby-modules
186
187 %description scripts
188 amaroK scripts allow you extend amaroK functionality.
189
190 You can learn more about scripts in amaroK from here:
191 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
192
193 %description scripts -l pl
194 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
195
196 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
197 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
198
199 %prep
200 %setup -q
201 %patch0 -p1
202 %patch1 -p1
203 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
204         amarok/src/amarok.desktop \
205
206 # see kde bug #110909
207 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
208
209 # kill env, call interpreter directly, so rpm automatics could rule
210 %{__sed} -i -e '
211         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
212         1s,#!.*bin/env.*python,#!%{_bindir}/python,
213         1s,#!.*bin/env.*bash,#!/bin/bash,
214 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
215
216 %build
217 cp -f /usr/share/automake/config.sub admin
218 %{__make} -f admin/Makefile.common cvs
219
220 # hack: passing something other than "no" or "yes" to --with-helix allows
221 # us to pass HELIX_LIBS
222 %configure \
223         HELIX_LIBS=%{_libdir}/helixplayer \
224         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
225         --disable-rpath \
226         --with%{!?with_mas:out}-mas \
227         --with%{!?with_xine:out}-xine \
228         --with%{!?with_gstreamer:out}-gstreamer10 \
229         --with%{!?with_akode:out}-akode \
230         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
231         --with%{!?with_nmm:out}-nmm \
232         --with%{!?with_xmms:out}-xmms \
233         --with%{!?with_mp3players:out}-libgpod \
234         --with%{!?with_mp3players:out}-libnjb \
235         --with%{!?with_mp3players:out}-libmtp \
236         --with%{!?with_mp3players:out}-ifp \
237         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
238         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
239         --disable-final \
240         --with-mp4v2 \
241         --with-qt-libraries=%{_libdir} \
242         --with%{!?with_included_sqlite:out}-included-sqlite
243
244 %{__make}
245
246 %install
247 rm -rf $RPM_BUILD_ROOT
248
249 %{__make} install \
250         DESTDIR=$RPM_BUILD_ROOT \
251         kde_htmldir=%{_kdedocdir} \
252         kde_libs_htmldir=%{_kdedocdir}
253
254 # remove bogus dir
255 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
256
257 %find_lang amarok --all-name --with-kde
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post
263 /sbin/ldconfig
264 if [ "$1" = 1 ]; then
265         echo "Remember to install libvisual-plugins-* packages if you"
266         echo "want to have a visualizations in amaroK."
267 fi
268
269 %postun -p /sbin/ldconfig
270
271 %files -f %{name}.lang
272 %defattr(644,root,root,755)
273 %doc AUTHORS ChangeLog README
274 %attr(755,root,root) %{_bindir}/amarok
275 %attr(755,root,root) %{_bindir}/amarokapp
276 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
277 %attr(755,root,root) %{_bindir}/amarok_libvisual
278 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
279 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
280 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
281 %{_libdir}/kde3/konqsidebar_universalamarok.la
282 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
283 %{_libdir}/kde3/libamarok_generic-mediadevice.la
284 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
285 %{_libdir}/kde3/libamarok_void-engine_plugin.la
286 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
287 %{_libdir}/libamarok.la
288 %{_libdir}/kde3/libamarok_daap-mediadevice.la
289 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
290 %{_libdir}/kde3/libamarok_massstorage-device.la
291 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
292 %{_libdir}/kde3/libamarok_nfs-device.la
293 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
294 %{_libdir}/kde3/libamarok_smb-device.la
295 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
296 %dir %{_datadir}/apps/amarok
297 %dir %{_datadir}/apps/amarok/scripts
298 %{_datadir}/apps/amarok/ruby_lib
299 %{_datadir}/apps/amarok/*.rc
300 %{_datadir}/apps/amarok/data
301 %{_datadir}/apps/amarok/icons
302 %{_datadir}/apps/amarok/images
303 %{_datadir}/apps/amarok/themes
304 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
305 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
306 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
307 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
308 %{_datadir}/apps/profiles/amarok.profile.xml
309 %{_datadir}/config/amarokrc
310 %{_datadir}/config.kcfg/amarok.kcfg
311 %{_datadir}/services/amarok_generic-mediadevice.desktop
312 %{_datadir}/services/amarok_void-engine_plugin.desktop
313 %{_datadir}/services/amarok_daap-mediadevice.desktop
314 %{_datadir}/services/amarok_massstorage-device.desktop
315 %{_datadir}/services/amarok_nfs-device.desktop
316 %{_datadir}/services/amarok_smb-device.desktop
317 %{_datadir}/services/amaroklastfm.protocol
318 %{_datadir}/services/amarokitpc.protocol
319 %{_datadir}/services/amarokpcast.protocol
320 %{_datadir}/servicetypes/amarok_codecinstall.desktop
321 %{_datadir}/servicetypes/amarok_plugin.desktop
322 %{_desktopdir}/kde/amarok.desktop
323 %{_iconsdir}/*/*/apps/amarok.*
324 # TODO: move to subpackage
325 %if %{with mp3players}
326 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
327 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
328 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
329 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
330 %{_libdir}/kde3/libamarok_mtp-mediadevice.la
331 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
332 %{_libdir}/kde3/libamarok_njb-mediadevice.la
333 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
334 %{_datadir}/services/amarok_ifp-mediadevice.desktop
335 %{_datadir}/services/amarok_ipod-mediadevice.desktop
336 %{_datadir}/services/amarok_mtp-mediadevice.desktop
337 %{_datadir}/services/amarok_njb-mediadevice.desktop
338 %endif
339
340 %if %{with akode}
341 %files akode
342 %defattr(644,root,root,755)
343 %{_libdir}/kde3/libamarok_aKode-engine.la
344 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
345 %{_datadir}/services/amarok_aKode-engine.desktop
346 %endif
347
348 %if %{with gstreamer}
349 %files gstreamer
350 %defattr(644,root,root,755)
351 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
352 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
353 %{_datadir}/config.kcfg/gstconfig.kcfg
354 %{_datadir}/services/amarok_gst10engine_plugin.desktop
355 %endif
356
357 %if %{with helix}
358 %files helix
359 %defattr(644,root,root,755)
360 %{_libdir}/kde3/libamarok_helixengine_plugin.la
361 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
362 %{_datadir}/config.kcfg/helixconfig.kcfg
363 %{_datadir}/services/amarok_helixengine_plugin.desktop
364 %endif
365
366 %if %{with xine}
367 %files xine
368 %defattr(644,root,root,755)
369 %{_libdir}/kde3/libamarok_xine-engine.la
370 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
371 %{_datadir}/config.kcfg/xinecfg.kcfg
372 %{_datadir}/services/amarok_xine-engine.desktop
373 %endif
374
375 %if %{with xmms}
376 %files xmms
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
379 %endif
380
381 %if 0
382 %if %{with zeroconf}
383 %files zeroconf
384 %defattr(644,root,root,755)
385 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
386 %endif
387 %endif
388
389 %files scripts
390 %defattr(644,root,root,755)
391 %dir %{_datadir}/apps/amarok/scripts/common
392 %{_datadir}/apps/amarok/scripts/common/Publisher.py
393 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
394
395 %dir %{_datadir}/apps/amarok/scripts/templates
396 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
397 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
398 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
399
400 # amarok searches for executable programs for scripts
401 # to figure out which files need to have execute permission, use this
402 # find command:
403 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
404
405 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
406 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
407 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
408
409 %dir %{_datadir}/apps/amarok/scripts/playlist2html
410 %{_datadir}/apps/amarok/scripts/playlist2html/README
411 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
412 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
413 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
414
415 %dir %{_datadir}/apps/amarok/scripts/webcontrol
416 %{_datadir}/apps/amarok/scripts/webcontrol/README
417 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
418 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
419 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
420 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
421 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
422 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
423 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
424 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
425 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
426 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
427 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
428 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
429 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
430 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
431 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
432 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
433 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
434 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
435 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
436
437 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
438 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
439 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
440 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
441 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
442
443 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
444 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
445 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
446 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
447 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
448
449 %dir %{_datadir}/apps/amarok/scripts/score_default
450 %{_datadir}/apps/amarok/scripts/score_default/COPYING
451 %{_datadir}/apps/amarok/scripts/score_default/README
452 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
453 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
454 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
455 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
456 %{_datadir}/apps/amarok/scripts/score_impulsive/README
457 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
458 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
459
460 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
461 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
462
463 %if 0
464 %dir %{_datadir}/apps/amarok/scripts/amarok_live
465 %{_datadir}/apps/amarok/scripts/amarok_live/README
466 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
467 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
468 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
469 %endif
This page took 0.082516 seconds and 3 git commands to generate.