]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- typo and more fixes
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - does not run
5 #
6
7 %define         state   stable
8 %define         qtver   4.7.1
9 %define         kdever  4.5.5
10
11 Summary:        A KDE audio player
12 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        2.4.1
15 Release:        0.1
16 License:        GPL v2+ and LGPL v2.1+
17 Group:          X11/Applications/Multimedia
18 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  4c65c5cd4d7bd267bdbef8e912fd6cb6
20 Patch0:         %{name}-disable_qtscriptbindings_check_fix.patch
21 Patch1:         %{name}-ffmpeg08.patch
22 URL:            http://amarok.kde.org/
23 BuildRequires:  QtNetwork-devel >= %{qtver}
24 BuildRequires:  QtSql-devel >= %{qtver}
25 BuildRequires:  automoc4 >= 0.9.88
26 BuildRequires:  cmake >= 2.8.0
27 BuildRequires:  curl-devel
28 BuildRequires:  ffmpeg-devel >= 0.7.1
29 BuildRequires:  gettext-devel
30 BuildRequires:  glib2-devel
31 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
32 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
33 BuildRequires:  libaio-devel
34 BuildRequires:  libgpod-devel >= 0.7.0
35 BuildRequires:  liblastfm-devel
36 BuildRequires:  libmtp-devel >= 0.3.0
37 BuildRequires:  libofa-devel
38 BuildRequires:  libwrap-devel
39 BuildRequires:  loudmouth-devel
40 BuildRequires:  mysql-devel >= 5.1.31-3
41 BuildRequires:  pcre-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  qca-devel
44 BuildRequires:  qt4-build >= %{qtver}
45 BuildRequires:  qt4-qmake >= %{qtver}
46 BuildRequires:  qtscriptbindings
47 BuildRequires:  rpmbuild(macros) >= 1.600
48 BuildRequires:  soprano-devel
49 BuildRequires:  strigi-devel >= 0.7.0
50 BuildRequires:  taglib-devel >= 1.6
51 BuildRequires:  taglib-extras-devel >= 1.0.0
52 BuildRequires:  xorg-lib-libXpm-devel
53 Requires(post,postun):  /sbin/ldconfig
54 Requires:       kde4-kdemultimedia-audiocd
55 Requires:       kde4-phonon
56 Requires:       qtscriptbindings
57 Suggests:       libvisual-plugin-actor-JESS
58 Suggests:       libvisual-plugin-actor-bumpscope
59 Suggests:       libvisual-plugin-actor-corona
60 Suggests:       libvisual-plugin-actor-flower
61 Suggests:       libvisual-plugin-actor-gdkpixbuf
62 Suggests:       libvisual-plugin-actor-gforce
63 Suggests:       libvisual-plugin-actor-gstreamer
64 Suggests:       libvisual-plugin-actor-infinite
65 Suggests:       libvisual-plugin-actor-jakdaw
66 Suggests:       libvisual-plugin-actor-lv_analyzer
67 Suggests:       libvisual-plugin-actor-lv_gltest
68 Suggests:       libvisual-plugin-actor-lv_scope
69 Suggests:       libvisual-plugin-actor-madspin
70 Suggests:       libvisual-plugin-actor-nastyfft
71 Suggests:       libvisual-plugin-actor-oinksie
72 Suggests:       libvisual-plugin-input-alsa
73 Suggests:       libvisual-plugin-input-jack
74 Suggests:       libvisual-plugin-input-mplayer
75 Suggests:       libvisual-plugin-morph-alphablend
76 Suggests:       libvisual-plugin-morph-flash
77 Suggests:       libvisual-plugin-morph-slide
78 Suggests:       libvisual-plugin-morph-tentacle
79 Obsoletes:      amarok-arts
80 Obsoletes:      amarok-xmms
81 # It should require mysql-embeded
82 Requires:       mysql >= 5.1.31-3
83 Conflicts:      mysql < 5.1.31-3
84 # sr@Latn vs. sr@latin
85 Conflicts:      glibc-misc < 6:2.7
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %description
89 A KDE audio player.
90
91 %description -l pl.UTF-8
92 Odtwarzacz audio dla KDE.
93
94 %package scripts
95 Summary:        amaroK scripts
96 Summary(pl.UTF-8):      Skrypty amaroKa
97 Group:          X11/Applications/Multimedia
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       kde4-kdebase-kdialog
100
101 %description scripts
102 amaroK scripts allow you extend amaroK functionality.
103
104 You can learn more about scripts in amaroK from here:
105 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
106
107 %description scripts -l pl.UTF-8
108 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
109
110 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
111 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %patch1 -p1
117
118 %build
119 install -d build
120 cd build
121 %cmake \
122         -DWITH_MYSQL_EMBEDDED=OFF \
123         ../
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} -C build install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         kde_htmldir=%{_kdedocdir} \
133         kde_libs_htmldir=%{_kdedocdir}
134
135 # remove unsupported locale
136 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
137
138 # remove .so symlinks so that noone gets the stupid idea to package them
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
140
141 %find_lang %{name} --all-name --with-kde
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post           -p /sbin/ldconfig
147 %postun         -p /sbin/ldconfig
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog README
152 %attr(755,root,root) %{_bindir}/amarok
153 %attr(755,root,root) %{_bindir}/amarokpkg
154 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
155 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
156 %attr(755,root,root) %{_bindir}/amarok_afttagger
157 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
158 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
160 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
162 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
164 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
166 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
168 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
169 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
170 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
171 %attr(755,root,root) %{_libdir}/libampache_account_login.so
172 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
173 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
174 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
177 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
210 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
211 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
212 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
213 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
214 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
215 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
216 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
217 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
218 %dir %{_datadir}/apps/amarok
219 %dir %{_datadir}/apps/amarok/scripts
220 %{_datadir}/apps/amarok/data
221 %{_datadir}/apps/amarok/icons
222 %{_datadir}/apps/amarok/images
223 %{_datadir}/apps/amarok/amarok.notifyrc
224 %{_datadir}/apps/desktoptheme
225 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
226 %{_datadir}/config.kcfg/amarokconfig.kcfg
227 %{_datadir}/config/amarok.knsrc
228 %{_datadir}/config/amarokapplets.knsrc
229 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
230 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
231 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
232 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
233 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
234 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
235 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
236 %{_desktopdir}/kde4/amarok_containers.desktop
237 %{_datadir}/kde4/services/amarok.protocol
238 %{_datadir}/kde4/services/amaroklastfm.protocol
239 %{_datadir}/kde4/services/amarokitpc.protocol
240 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
241 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
242 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
243 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
244 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
245 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
246 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
247 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
248 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
250 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
251 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
252 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
253 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
254 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
255 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
256 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
257 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
258 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
259 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
260 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
261 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
262 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
263 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
264 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
265 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
266 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
267 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
268 %{_datadir}/kde4/services/amarok_device_massstorage.desktop
269 %{_datadir}/kde4/services/amarok_device_nfs.desktop
270 %{_datadir}/kde4/services/amarok_device_smb.desktop
271 %{_datadir}/kde4/services/amarok_service_ampache.desktop
272 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
273 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
274 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
275 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
276 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
277 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
278 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
279 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
280 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
281 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
282 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
283 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
284 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
285 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
286 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
287 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
288 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
289 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
290 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
291 %{_desktopdir}/kde4/amarok.desktop
292 %{_iconsdir}/*/*/apps/amarok.*
293 %{_datadir}/config/amarok_homerc
294
295 %files scripts
296 %defattr(644,root,root,755)
297 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
298 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
299 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
300 %dir %{_datadir}/apps/amarok/scripts/script_console
301 %{_datadir}/apps/amarok/scripts/script_console/main.js
302 %{_datadir}/apps/amarok/scripts/script_console/script.spec
303 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
304 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
305 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
306 %dir %{_datadir}/apps/amarok/scripts/librivox_service
307 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
308 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
309 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
310 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
311 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
312 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
313 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
314 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.091681 seconds and 3 git commands to generate.