]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- rebuild with ffmpeg 4.0
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - amarok now requires his own database which is not automaticly created
5 # Add spec:
6 # libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
7 #     Enable gpodder.net service
8 # -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
9 # /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
10 %define         state   stable
11 %define         qtver   4.7.1
12 %define         kdever  4.5.5
13
14 Summary:        A KDE audio player
15 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
16 Name:           amarok
17 Version:        2.8.0
18 Release:        9
19 License:        GPL v2+ and LGPL v2.1+
20 Group:          X11/Applications/Multimedia
21 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
22 # Source0-md5:  53cfcb4819668b10e13b061478c7b32a
23 Patch0:         %{name}-upnp-dep.patch
24 Patch1:         find-taglib.patch
25 Patch2:         ffmpeg3.patch
26 URL:            http://amarok.kde.org/
27 BuildRequires:  QtCore-devel >= %{qtver}
28 BuildRequires:  QtGui-devel >= %{qtver}
29 BuildRequires:  QtNetwork-devel >= %{qtver}
30 BuildRequires:  QtOpenGL-devel >= %{qtver}
31 BuildRequires:  QtScript-devel >= %{qtver}
32 BuildRequires:  QtSql-devel >= %{qtver}
33 BuildRequires:  QtSvg-devel >= %{qtver}
34 BuildRequires:  QtWebKit-devel >= %{qtver}
35 BuildRequires:  QtXml-devel >= %{qtver}
36 BuildRequires:  automoc4 >= 0.9.88
37 BuildRequires:  cmake >= 2.8.0
38 BuildRequires:  curl-devel
39 BuildRequires:  ffmpeg-devel >= 0.7.1
40 BuildRequires:  gettext-tools
41 BuildRequires:  glib2-devel
42 BuildRequires:  herqq-devel
43 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
44 BuildRequires:  kde4-nepomuk-core-devel
45 BuildRequires:  libaio-devel
46 BuildRequires:  libgpod-devel >= 0.7.0
47 BuildRequires:  liblastfm-devel
48 BuildRequires:  libmtp-devel >= 1.0.4
49 BuildRequires:  libofa-devel
50 BuildRequires:  libwrap-devel
51 BuildRequires:  loudmouth-devel
52 BuildRequires:  mysql-devel >= 5.1.31-3
53 BuildRequires:  pcre-devel
54 BuildRequires:  pkgconfig
55 BuildRequires:  qca-devel
56 BuildRequires:  qjson-devel >= 0.5
57 BuildRequires:  qt4-build >= %{qtver}
58 BuildRequires:  qt4-qmake >= %{qtver}
59 BuildRequires:  qtscriptbindings
60 BuildRequires:  rpmbuild(macros) >= 1.600
61 BuildRequires:  soprano-devel
62 BuildRequires:  strigi-devel >= 0.7.0
63 BuildRequires:  taglib-devel >= 1.7
64 BuildRequires:  taglib-extras-devel >= 1.0.0
65 BuildRequires:  xorg-lib-libXpm-devel
66 Requires(post,postun):  /sbin/ldconfig
67 Requires:       kde4-phonon
68 Requires:       qtscriptbindings
69 Suggests:       libvisual-plugin-actor-JESS
70 Suggests:       libvisual-plugin-actor-bumpscope
71 Suggests:       libvisual-plugin-actor-corona
72 Suggests:       libvisual-plugin-actor-flower
73 Suggests:       libvisual-plugin-actor-gdkpixbuf
74 Suggests:       libvisual-plugin-actor-gforce
75 Suggests:       libvisual-plugin-actor-gstreamer
76 Suggests:       libvisual-plugin-actor-infinite
77 Suggests:       libvisual-plugin-actor-jakdaw
78 Suggests:       libvisual-plugin-actor-lv_analyzer
79 Suggests:       libvisual-plugin-actor-lv_gltest
80 Suggests:       libvisual-plugin-actor-lv_scope
81 Suggests:       libvisual-plugin-actor-madspin
82 Suggests:       libvisual-plugin-actor-nastyfft
83 Suggests:       libvisual-plugin-actor-oinksie
84 Suggests:       libvisual-plugin-input-alsa
85 Suggests:       libvisual-plugin-input-jack
86 Suggests:       libvisual-plugin-input-mplayer
87 Suggests:       libvisual-plugin-morph-alphablend
88 Suggests:       libvisual-plugin-morph-flash
89 Suggests:       libvisual-plugin-morph-slide
90 Suggests:       libvisual-plugin-morph-tentacle
91 Obsoletes:      amarok-arts
92 Obsoletes:      amarok-xmms
93 # It should require mysql-embeded
94 Requires:       mysql >= 5.1.31-3
95 Conflicts:      mysql < 5.1.31-3
96 # sr@Latn vs. sr@latin
97 Conflicts:      glibc-misc < 6:2.7
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 A KDE audio player.
102
103 %description -l pl.UTF-8
104 Odtwarzacz audio dla KDE.
105
106 %package scripts
107 Summary:        amaroK scripts
108 Summary(pl.UTF-8):      Skrypty amaroKa
109 Group:          X11/Applications/Multimedia
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       kde4-kdebase-kdialog
112
113 %description scripts
114 amaroK scripts allow you extend amaroK functionality.
115
116 You can learn more about scripts in amaroK from here:
117 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
118
119 %description scripts -l pl.UTF-8
120 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
121
122 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
123 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129 %patch2 -p1
130
131 %build
132 install -d build
133 cd build
134 %cmake \
135         -DKDE4_BUILD_TESTS=OFF \
136         -DWITH_MYSQL_EMBEDDED=OFF \
137         ../
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} -C build install \
145         DESTDIR=$RPM_BUILD_ROOT \
146         kde_htmldir=%{_kdedocdir} \
147         kde_libs_htmldir=%{_kdedocdir}
148
149 # remove unsupported locale
150 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavian*
151
152 # remove .so symlinks so that noone gets the stupid idea to package them
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
154
155 %find_lang %{name} --all-name --with-kde
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post           -p /sbin/ldconfig
161 %postun         -p /sbin/ldconfig
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %doc AUTHORS ChangeLog README
166 %attr(755,root,root) %{_bindir}/amarok
167 %attr(755,root,root) %{_bindir}/amarokpkg
168 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
169 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
170 %attr(755,root,root) %{_bindir}/amarok_afttagger
171 %attr(755,root,root) %{_bindir}/amzdownloader
172 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
173 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
175 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
177 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
179 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
181 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libamarokshared.so.?
183 %attr(755,root,root) %{_libdir}/libamarokshared.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
185 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
186 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
187 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
188 %attr(755,root,root) %{_libdir}/libampache_account_login.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
193 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_analyzer.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
214 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
215 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
216 %attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
217 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
218 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
219 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
220 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
221 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-nepomukcollection.so
222 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
223 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
224 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
225 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
226 %dir %{_datadir}/apps/amarok
227 %dir %{_datadir}/apps/amarok/scripts
228 %{_datadir}/apps/amarok/data
229 %{_datadir}/apps/amarok/icons
230 %{_datadir}/apps/amarok/images
231 %{_datadir}/apps/amarok/amarok.notifyrc
232 %{_datadir}/apps/desktoptheme
233 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
234 %{_datadir}/config.kcfg/amarokconfig.kcfg
235 %{_datadir}/config/amarok.knsrc
236 %{_datadir}/config/amarokapplets.knsrc
237 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
238 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
239 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
240 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
241 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
242 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
243 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
244 %{_desktopdir}/kde4/amarok_containers.desktop
245 %{_desktopdir}/kde4/amzdownloader.desktop
246 %{_datadir}/kde4/services/amarok.protocol
247 %{_datadir}/kde4/services/amarokitpc.protocol
248 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
249 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
250 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
251 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
252 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
253 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
254 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
255 %{_datadir}/kde4/services/amarok_collection-nepomukcollection.desktop
256 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
257 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
258 %{_datadir}/kde4/services/amarok-context-applet-analyzer.desktop
259 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
260 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
261 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
262 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
263 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
264 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
265 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
266 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
267 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
268 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
269 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
270 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
271 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
272 %{_datadir}/kde4/services/amarok_service_amazonstore.desktop
273 %{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
274 %{_datadir}/kde4/services/amarok_service_ampache.desktop
275 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
276 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
277 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
278 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
279 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
280 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
281 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
282 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
283 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
284 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
285 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
286 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
287 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
288 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
289 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
290 %{_desktopdir}/kde4/amarok.desktop
291 %{_iconsdir}/*/*/apps/amarok.*
292 %{_datadir}/config/amarok_homerc
293 %attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
294 %{_datadir}/apps/kconf_update/amarok.upd
295 %{_datadir}/mime/packages/amzdownloader.xml
296
297 %files scripts
298 %defattr(644,root,root,755)
299 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
300 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
301 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
302 %dir %{_datadir}/apps/amarok/scripts/script_console
303 %{_datadir}/apps/amarok/scripts/script_console/main.js
304 %{_datadir}/apps/amarok/scripts/script_console/script.spec
305 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
306 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
307 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
308 %dir %{_datadir}/apps/amarok/scripts/librivox_service
309 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
310 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
311 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
312 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
313 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
314 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
315 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
316 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
317 %dir %{_datadir}/apps/amarok/scripts/free_music_charts_service
318 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCEmblem.png
319 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCIcon.png
320 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCShow.png
321 %{_datadir}/apps/amarok/scripts/free_music_charts_service/main.js
322 %{_datadir}/apps/amarok/scripts/free_music_charts_service/script.spec
This page took 0.12729 seconds and 3 git commands to generate.