]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- up to 2.5.0
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - amarok now requires his own database which is not automaticly created 
5 # Add spec:
6 # libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
7 #     Enable gpodder.net service
8 # -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
9 # /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
10 %define         state   stable
11 %define         qtver   4.7.1
12 %define         kdever  4.5.5
13
14 Summary:        A KDE audio player
15 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
16 Name:           amarok
17 Version:        2.5.0
18 Release:        1
19 License:        GPL v2+ and LGPL v2.1+
20 Group:          X11/Applications/Multimedia
21 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
22 # Source0-md5:  b7983eaa33e4771769ae9e330c811995
23 Patch0:         %{name}-upnp-dep.patch
24 URL:            http://amarok.kde.org/
25 BuildRequires:  QtNetwork-devel >= %{qtver}
26 BuildRequires:  QtSql-devel >= %{qtver}
27 BuildRequires:  automoc4 >= 0.9.88
28 BuildRequires:  cmake >= 2.8.0
29 BuildRequires:  curl-devel
30 BuildRequires:  ffmpeg-devel >= 0.7.1
31 BuildRequires:  gettext-devel
32 BuildRequires:  glib2-devel
33 BuildRequires:  herqq-devel
34 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
35 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
36 BuildRequires:  libaio-devel
37 BuildRequires:  libgpod-devel >= 0.7.0
38 BuildRequires:  liblastfm-devel
39 BuildRequires:  libmtp-devel >= 1.0.4
40 BuildRequires:  libofa-devel
41 BuildRequires:  libwrap-devel
42 BuildRequires:  loudmouth-devel
43 BuildRequires:  mysql-devel >= 5.1.31-3
44 BuildRequires:  pcre-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  qca-devel
47 BuildRequires:  qjson-devel >= 0.5
48 BuildRequires:  qt4-build >= %{qtver}
49 BuildRequires:  qt4-qmake >= %{qtver}
50 BuildRequires:  qtscriptbindings
51 BuildRequires:  rpmbuild(macros) >= 1.600
52 BuildRequires:  soprano-devel
53 BuildRequires:  strigi-devel >= 0.7.0
54 BuildRequires:  taglib-devel >= 1.7
55 BuildRequires:  taglib-extras-devel >= 1.0.0
56 BuildRequires:  xorg-lib-libXpm-devel
57 Requires(post,postun):  /sbin/ldconfig
58 Requires:       kde4-kdemultimedia-audiocd
59 Requires:       kde4-phonon
60 Requires:       qtscriptbindings
61 Suggests:       libvisual-plugin-actor-JESS
62 Suggests:       libvisual-plugin-actor-bumpscope
63 Suggests:       libvisual-plugin-actor-corona
64 Suggests:       libvisual-plugin-actor-flower
65 Suggests:       libvisual-plugin-actor-gdkpixbuf
66 Suggests:       libvisual-plugin-actor-gforce
67 Suggests:       libvisual-plugin-actor-gstreamer
68 Suggests:       libvisual-plugin-actor-infinite
69 Suggests:       libvisual-plugin-actor-jakdaw
70 Suggests:       libvisual-plugin-actor-lv_analyzer
71 Suggests:       libvisual-plugin-actor-lv_gltest
72 Suggests:       libvisual-plugin-actor-lv_scope
73 Suggests:       libvisual-plugin-actor-madspin
74 Suggests:       libvisual-plugin-actor-nastyfft
75 Suggests:       libvisual-plugin-actor-oinksie
76 Suggests:       libvisual-plugin-input-alsa
77 Suggests:       libvisual-plugin-input-jack
78 Suggests:       libvisual-plugin-input-mplayer
79 Suggests:       libvisual-plugin-morph-alphablend
80 Suggests:       libvisual-plugin-morph-flash
81 Suggests:       libvisual-plugin-morph-slide
82 Suggests:       libvisual-plugin-morph-tentacle
83 Obsoletes:      amarok-arts
84 Obsoletes:      amarok-xmms
85 # It should require mysql-embeded
86 Requires:       mysql >= 5.1.31-3
87 Conflicts:      mysql < 5.1.31-3
88 # sr@Latn vs. sr@latin
89 Conflicts:      glibc-misc < 6:2.7
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %description
93 A KDE audio player.
94
95 %description -l pl.UTF-8
96 Odtwarzacz audio dla KDE.
97
98 %package scripts
99 Summary:        amaroK scripts
100 Summary(pl.UTF-8):      Skrypty amaroKa
101 Group:          X11/Applications/Multimedia
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       kde4-kdebase-kdialog
104
105 %description scripts
106 amaroK scripts allow you extend amaroK functionality.
107
108 You can learn more about scripts in amaroK from here:
109 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
110
111 %description scripts -l pl.UTF-8
112 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
113
114 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
115 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120
121 %build
122 install -d build
123 cd build
124 %cmake \
125         -DWITH_MYSQL_EMBEDDED=OFF \
126         ../
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} -C build install \
134         DESTDIR=$RPM_BUILD_ROOT \
135         kde_htmldir=%{_kdedocdir} \
136         kde_libs_htmldir=%{_kdedocdir}
137
138 # remove unsupported locale
139 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
140
141 # remove .so symlinks so that noone gets the stupid idea to package them
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
143
144 %find_lang %{name} --all-name --with-kde
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post           -p /sbin/ldconfig
150 %postun         -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog README
155 %attr(755,root,root) %{_bindir}/amarok
156 %attr(755,root,root) %{_bindir}/amarokpkg
157 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
158 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
159 %attr(755,root,root) %{_bindir}/amarok_afttagger
160 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
161 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
163 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
165 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
167 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
169 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
171 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
172 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
173 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
174 %attr(755,root,root) %{_libdir}/libampache_account_login.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
180 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_spectrum_analyzer.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_spectrum_analyzer.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
214 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
215 %attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
216 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
217 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
218 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
219 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
220 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
221 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
222 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
223 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
224 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
225 %dir %{_datadir}/apps/amarok
226 %dir %{_datadir}/apps/amarok/scripts
227 %{_datadir}/apps/amarok/data
228 %{_datadir}/apps/amarok/icons
229 %{_datadir}/apps/amarok/images
230 %{_datadir}/apps/amarok/amarok.notifyrc
231 %{_datadir}/apps/desktoptheme
232 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
233 %{_datadir}/config.kcfg/amarokconfig.kcfg
234 %{_datadir}/config/amarok.knsrc
235 %{_datadir}/config/amarokapplets.knsrc
236 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
237 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
238 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
239 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
240 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
241 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
242 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
243 %{_desktopdir}/kde4/amarok_containers.desktop
244 %{_datadir}/kde4/services/amarok.protocol
245 %{_datadir}/kde4/services/amaroklastfm.protocol
246 %{_datadir}/kde4/services/amarokitpc.protocol
247 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
248 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
249 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
250 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
251 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
252 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
253 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
254 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
255 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
256 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
257 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
258 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
259 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
260 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
261 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
262 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
263 %{_datadir}/kde4/services/amarok-context-applet-spectrum-analyzer.desktop
264 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
265 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
266 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
267 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
268 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
269 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
270 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
271 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
272 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
273 %{_datadir}/kde4/services/amarok-data-engine-spectrum-analyzer.desktop
274 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
275 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
276 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
277 %{_datadir}/kde4/services/amarok_device_massstorage.desktop
278 %{_datadir}/kde4/services/amarok_device_nfs.desktop
279 %{_datadir}/kde4/services/amarok_device_smb.desktop
280 %{_datadir}/kde4/services/amarok_service_amazonstore.desktop
281 %{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
282 %{_datadir}/kde4/services/amarok_service_ampache.desktop
283 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
284 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
285 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
286 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
287 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
288 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
289 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
290 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
291 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
292 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
293 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
294 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
295 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
296 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
297 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
298 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
299 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
300 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
301 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
302 %{_desktopdir}/kde4/amarok.desktop
303 %{_iconsdir}/*/*/apps/amarok.*
304 %{_datadir}/config/amarok_homerc
305 %attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
306 %{_datadir}/apps/kconf_update/amarok.upd
307
308 %files scripts
309 %defattr(644,root,root,755)
310 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
311 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
312 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
313 %dir %{_datadir}/apps/amarok/scripts/script_console
314 %{_datadir}/apps/amarok/scripts/script_console/main.js
315 %{_datadir}/apps/amarok/scripts/script_console/script.spec
316 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
317 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
318 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
319 %dir %{_datadir}/apps/amarok/scripts/librivox_service
320 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
321 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
322 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
323 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
324 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
325 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
326 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
327 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.058201 seconds and 3 git commands to generate.