]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- up to 2.2.2 patched version
[packages/amarok.git] / amarok.spec
1 # TODO
2 # - try not to link with static mysql
3
4 %define         state   stable
5 %define         qtver   4.6.2
6 %define         kdever  4.4.1
7
8 Summary:        A KDE audio player
9 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        2.2.2
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}-patched.tar.bz2
16 # Source0-md5:  9b4453597e4affb1a6bebe715499782f
17 Patch0:         %{name}-link.patch
18 Patch1:         %{name}-qthreadpool.patch
19 Patch2:         %{name}-disable_qtscriptbindings_check_fix.patch
20 URL:            http://amarok.kde.org/
21 BuildRequires:  Qt3Support-devel >= %{qtver}
22 BuildRequires:  QtCore-devel >= %{qtver}
23 BuildRequires:  QtDBus-devel >= %{qtver}
24 #BuildRequires: QtDesigner-devel >= %{qtver}
25 BuildRequires:  QtNetwork-devel >= %{qtver}
26 BuildRequires:  QtOpenGL-devel >= %{qtver}
27 BuildRequires:  QtScript-devel >= %{qtver}
28 BuildRequires:  QtSql-devel >= %{qtver}
29 BuildRequires:  QtSvg-devel >= %{qtver}
30 #BuildRequires: QtTest-devel >= %{qtver}
31 BuildRequires:  QtUiTools-devel >= %{qtver}
32 BuildRequires:  QtWebKit-devel >= %{qtver}
33 BuildRequires:  QtXml-devel >= %{qtver}
34 BuildRequires:  automoc4
35 BuildRequires:  cmake >= 2.6.1-2
36 BuildRequires:  curl-devel
37 BuildRequires:  gettext-devel
38 #BuildRequires: giflib-devel
39 BuildRequires:  glib2-devel
40 BuildRequires:  kde4-kdebase-devel >= %{kdever}
41 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
42 BuildRequires:  libgpod-devel >= 0.7.0
43 #BuildRequires: libifp-devel >= 1.0.0.2
44 BuildRequires:  liblastfm-devel
45 BuildRequires:  libmtp-devel >= 0.3.0
46 #BuildRequires: libnjb-devel >= 2.2.4
47 #BuildRequires: libvisual-devel >= 0.4.0
48 BuildRequires:  loudmouth-devel
49 #BuildRequires: mpeg4ip-devel >= 1:1.6
50 BuildRequires:  mysql-devel >= 5.1.31-3
51 BuildRequires:  pcre-devel
52 BuildRequires:  pkgconfig
53 BuildRequires:  qca-devel
54 BuildRequires:  qt4-build >= %{qtver}
55 BuildRequires:  qt4-qmake >= %{qtver}
56 BuildRequires:  qtscriptbindings
57 #BuildRequires: rpm-pythonprov
58 BuildRequires:  rpmbuild(macros) >= 1.129
59 #BuildRequires: soprano-devel >= 2.1
60 BuildRequires:  strigi-devel >= 0.5.10
61 BuildRequires:  taglib-devel >= 1.6
62 BuildRequires:  taglib-extras-devel >= 1.0.0
63 #BuildRequires: utempter-devel
64 BuildRequires:  xorg-lib-libXpm-devel
65 Requires(post,postun):  /sbin/ldconfig
66 Requires:       kde4-kdebase-core
67 Requires:       kde4-kdemultimedia-audiocd
68 Requires:       kde4-phonon
69 Requires:       qtscriptbindings
70 Suggests:       libvisual-plugin-actor-JESS
71 Suggests:       libvisual-plugin-actor-bumpscope
72 Suggests:       libvisual-plugin-actor-corona
73 Suggests:       libvisual-plugin-actor-flower
74 Suggests:       libvisual-plugin-actor-gdkpixbuf
75 Suggests:       libvisual-plugin-actor-gforce
76 Suggests:       libvisual-plugin-actor-gstreamer
77 Suggests:       libvisual-plugin-actor-infinite
78 Suggests:       libvisual-plugin-actor-jakdaw
79 Suggests:       libvisual-plugin-actor-lv_analyzer
80 Suggests:       libvisual-plugin-actor-lv_gltest
81 Suggests:       libvisual-plugin-actor-lv_scope
82 Suggests:       libvisual-plugin-actor-madspin
83 Suggests:       libvisual-plugin-actor-nastyfft
84 Suggests:       libvisual-plugin-actor-oinksie
85 Suggests:       libvisual-plugin-input-alsa
86 Suggests:       libvisual-plugin-input-esd
87 Suggests:       libvisual-plugin-input-jack
88 Suggests:       libvisual-plugin-input-mplayer
89 Suggests:       libvisual-plugin-morph-alphablend
90 Suggests:       libvisual-plugin-morph-flash
91 Suggests:       libvisual-plugin-morph-slide
92 Suggests:       libvisual-plugin-morph-tentacle
93 Obsoletes:      amarok-arts
94 Obsoletes:      amarok-xmms
95 # It should require mysql-embeded
96 Requires:       mysql >= 5.1.31-3
97 Conflicts:      mysql < 5.1.31-3
98 # sr@Latn vs. sr@latin
99 Conflicts:      glibc-misc < 6:2.7
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %description
103 A KDE audio player.
104
105 %description -l pl.UTF-8
106 Odtwarzacz audio dla KDE.
107
108 %package scripts
109 Summary:        amaroK scripts
110 Summary(pl.UTF-8):      Skrypty amaroKa
111 Group:          X11/Applications/Multimedia
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       kde4-kdebase-kdialog
114
115 %description scripts
116 amaroK scripts allow you extend amaroK functionality.
117
118 You can learn more about scripts in amaroK from here:
119 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
120
121 %description scripts -l pl.UTF-8
122 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
123
124 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
125 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
126
127 %prep
128 %setup -q
129 #%patch0 -p0
130 #%patch1 -p0
131 %patch2 -p1
132
133 %build
134 install -d build
135 cd build
136 %cmake \
137         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
138         -DLIB_INSTALL_DIR=%{_libdir} \
139         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
140 %if "%{_lib}" == "lib64"
141         -DLIB_SUFFIX=64 \
142 %endif
143         ../
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} -C build install \
151         DESTDIR=$RPM_BUILD_ROOT \
152         kde_htmldir=%{_kdedocdir} \
153         kde_libs_htmldir=%{_kdedocdir}
154
155 # remove bogus dir
156 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
157
158 %find_lang %{name} --with-kde
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post           -p /sbin/ldconfig
164 %postun         -p /sbin/ldconfig
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc AUTHORS ChangeLog README
169 %attr(755,root,root) %{_bindir}/amarok
170 %attr(755,root,root) %{_bindir}/amarokpkg
171 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
172 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
173 %attr(755,root,root) %{_bindir}/amarok_afttagger
174 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
175 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
177 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
178 %attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
179 %attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
194 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
195 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
196 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
197 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
214 %dir %{_datadir}/apps/amarok
215 %attr(755,root,root) %{_libdir}/libamaroklib.so
216 %attr(755,root,root) %{_libdir}/libamarokocsclient.so
217 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.4
218 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.4.*.*
219 %attr(755,root,root) %{_libdir}/libamarokpud.so
220 %dir %{_datadir}/apps/amarok/scripts
221 %{_datadir}/apps/amarok/data
222 %{_datadir}/apps/amarok/icons
223 %{_datadir}/apps/amarok/images
224 %{_datadir}/apps/amarok/amarok.notifyrc
225 %{_datadir}/apps/desktoptheme
226 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
227 %{_datadir}/config.kcfg/amarokconfig.kcfg
228 %{_datadir}/config/amarok.knsrc
229 %{_datadir}/config/amarokapplets.knsrc
230 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
231 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
232 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
233 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
234 %{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
235 %{_datadir}/kde4/services/amarok.protocol
236 %{_datadir}/kde4/services/amaroklastfm.protocol
237 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
238 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
239 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
240 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
241 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
242 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
243 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
244 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
245 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
246 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
247 %{_datadir}/kde4/services/amarok_service_ampache.desktop
248 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
249 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
250 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
251 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
252 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
253 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
254 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
255 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
256 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
257 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
258 %{_datadir}/kde4/services/amarok_massstorage-device.desktop
259 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
260 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
261 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
262 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
263 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
264 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
265 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
266 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
267 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
268 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
269 %{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
270 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
271 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
272 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
273 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
274 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
275 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
276 %{_desktopdir}/kde4/amarok.desktop
277 %{_iconsdir}/*/*/apps/amarok.*
278 %{_datadir}/config/amarok_homerc
279
280 %files scripts
281 %defattr(644,root,root,755)
282 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
283 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
284 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
285 %dir %{_datadir}/apps/amarok/scripts/script_console
286 %{_datadir}/apps/amarok/scripts/script_console/main.js
287 %{_datadir}/apps/amarok/scripts/script_console/script.spec
288 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
289 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
290 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
291 %dir %{_datadir}/apps/amarok/scripts/librivox_service
292 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
293 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
294 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
295 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
296 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
297 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
298 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
299 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.051415 seconds and 3 git commands to generate.