]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- attpempt to fix build with ffmpeg 0.7 and 0.8
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - does not run
5 #
6
7 %define         state   stable
8 %define         qtver   4.7.1
9 %define         kdever  4.5.5
10
11 Summary:        A KDE audio player
12 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        2.4.1
15 Release:        0.1
16 License:        GPL v2+ and LGPL v2.1+
17 Group:          X11/Applications/Multimedia
18 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  4c65c5cd4d7bd267bdbef8e912fd6cb6
20 Patch0:         %{name}-disable_qtscriptbindings_check_fix.patch
21 Patch1:         %{name}-ffmpeg08.patch
22 URL:            http://amarok.kde.org/
23 BuildRequires:  QtNetwork-devel >= %{qtver}
24 BuildRequires:  QtSql-devel >= %{qtver}
25 BuildRequires:  automoc4 >= 0.9.88
26 BuildRequires:  cmake >= 2.8.0
27 BuildRequires:  curl-devel
28 BuildRequires:  gettext-devel
29 BuildRequires:  glib2-devel
30 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
31 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
32 BuildRequires:  libaio-devel
33 BuildRequires:  libgpod-devel >= 0.7.0
34 BuildRequires:  liblastfm-devel
35 BuildRequires:  libmtp-devel >= 0.3.0
36 BuildRequires:  libofa-devel
37 BuildRequires:  libwrap-devel
38 BuildRequires:  loudmouth-devel
39 BuildRequires:  mysql-devel >= 5.1.31-3
40 BuildRequires:  pcre-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  qca-devel
43 BuildRequires:  qt4-build >= %{qtver}
44 BuildRequires:  qt4-qmake >= %{qtver}
45 BuildRequires:  qtscriptbindings
46 BuildRequires:  rpmbuild(macros) >= 1.600
47 BuildRequires:  soprano-devel
48 BuildRequires:  strigi-devel >= 0.7.0
49 BuildRequires:  taglib-devel >= 1.6
50 BuildRequires:  taglib-extras-devel >= 1.0.0
51 BuildRequires:  xorg-lib-libXpm-devel
52 Requires(post,postun):  /sbin/ldconfig
53 Requires:       kde4-kdemultimedia-audiocd
54 Requires:       kde4-phonon
55 Requires:       qtscriptbindings
56 Suggests:       libvisual-plugin-actor-JESS
57 Suggests:       libvisual-plugin-actor-bumpscope
58 Suggests:       libvisual-plugin-actor-corona
59 Suggests:       libvisual-plugin-actor-flower
60 Suggests:       libvisual-plugin-actor-gdkpixbuf
61 Suggests:       libvisual-plugin-actor-gforce
62 Suggests:       libvisual-plugin-actor-gstreamer
63 Suggests:       libvisual-plugin-actor-infinite
64 Suggests:       libvisual-plugin-actor-jakdaw
65 Suggests:       libvisual-plugin-actor-lv_analyzer
66 Suggests:       libvisual-plugin-actor-lv_gltest
67 Suggests:       libvisual-plugin-actor-lv_scope
68 Suggests:       libvisual-plugin-actor-madspin
69 Suggests:       libvisual-plugin-actor-nastyfft
70 Suggests:       libvisual-plugin-actor-oinksie
71 Suggests:       libvisual-plugin-input-alsa
72 Suggests:       libvisual-plugin-input-jack
73 Suggests:       libvisual-plugin-input-mplayer
74 Suggests:       libvisual-plugin-morph-alphablend
75 Suggests:       libvisual-plugin-morph-flash
76 Suggests:       libvisual-plugin-morph-slide
77 Suggests:       libvisual-plugin-morph-tentacle
78 Obsoletes:      amarok-arts
79 Obsoletes:      amarok-xmms
80 # It should require mysql-embeded
81 Requires:       mysql >= 5.1.31-3
82 Conflicts:      mysql < 5.1.31-3
83 # sr@Latn vs. sr@latin
84 Conflicts:      glibc-misc < 6:2.7
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %description
88 A KDE audio player.
89
90 %description -l pl.UTF-8
91 Odtwarzacz audio dla KDE.
92
93 %package scripts
94 Summary:        amaroK scripts
95 Summary(pl.UTF-8):      Skrypty amaroKa
96 Group:          X11/Applications/Multimedia
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       kde4-kdebase-kdialog
99
100 %description scripts
101 amaroK scripts allow you extend amaroK functionality.
102
103 You can learn more about scripts in amaroK from here:
104 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
105
106 %description scripts -l pl.UTF-8
107 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
108
109 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
110 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116
117 %build
118 install -d build
119 cd build
120 %cmake \
121         -DWITH_MYSQL_EMBEDDED=OFF \
122         ../
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} -C build install \
130         DESTDIR=$RPM_BUILD_ROOT \
131         kde_htmldir=%{_kdedocdir} \
132         kde_libs_htmldir=%{_kdedocdir}
133
134 # remove unsupported locale
135 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
136
137 # remove .so symlinks so that noone gets the stupid idea to package them
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
139
140 %find_lang %{name} --all-name --with-kde
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post           -p /sbin/ldconfig
146 %postun         -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog README
151 %attr(755,root,root) %{_bindir}/amarok
152 %attr(755,root,root) %{_bindir}/amarokpkg
153 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
154 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
155 %attr(755,root,root) %{_bindir}/amarok_afttagger
156 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
157 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
159 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
161 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
163 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
165 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
167 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
168 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
169 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
170 %attr(755,root,root) %{_libdir}/libampache_account_login.so
171 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
172 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
173 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
174 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
176 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
209 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
210 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
211 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
212 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
214 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
215 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
216 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
217 %dir %{_datadir}/apps/amarok
218 %dir %{_datadir}/apps/amarok/scripts
219 %{_datadir}/apps/amarok/data
220 %{_datadir}/apps/amarok/icons
221 %{_datadir}/apps/amarok/images
222 %{_datadir}/apps/amarok/amarok.notifyrc
223 %{_datadir}/apps/desktoptheme
224 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
225 %{_datadir}/config.kcfg/amarokconfig.kcfg
226 %{_datadir}/config/amarok.knsrc
227 %{_datadir}/config/amarokapplets.knsrc
228 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
229 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
230 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
231 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
232 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
233 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
234 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
235 %{_desktopdir}/kde4/amarok_containers.desktop
236 %{_datadir}/kde4/services/amarok.protocol
237 %{_datadir}/kde4/services/amaroklastfm.protocol
238 %{_datadir}/kde4/services/amarokitpc.protocol
239 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
240 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
241 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
242 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
243 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
244 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
245 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
246 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
247 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
248 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
250 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
251 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
252 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
253 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
254 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
255 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
256 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
257 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
258 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
259 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
260 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
261 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
262 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
263 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
264 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
265 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
266 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
267 %{_datadir}/kde4/services/amarok_device_massstorage.desktop
268 %{_datadir}/kde4/services/amarok_device_nfs.desktop
269 %{_datadir}/kde4/services/amarok_device_smb.desktop
270 %{_datadir}/kde4/services/amarok_service_ampache.desktop
271 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
272 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
273 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
274 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
275 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
276 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
277 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
278 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
279 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
280 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
281 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
282 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
283 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
284 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
285 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
286 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
287 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
288 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
289 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
290 %{_desktopdir}/kde4/amarok.desktop
291 %{_iconsdir}/*/*/apps/amarok.*
292 %{_datadir}/config/amarok_homerc
293
294 %files scripts
295 %defattr(644,root,root,755)
296 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
297 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
298 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
299 %dir %{_datadir}/apps/amarok/scripts/script_console
300 %{_datadir}/apps/amarok/scripts/script_console/main.js
301 %{_datadir}/apps/amarok/scripts/script_console/script.spec
302 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
303 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
304 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
305 %dir %{_datadir}/apps/amarok/scripts/librivox_service
306 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
307 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
308 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
309 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
310 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
311 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
312 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
313 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.047956 seconds and 3 git commands to generate.