]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
359b2236af84e18622b8afd2e2f52b440056b8b2
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 # - ProjectM (see README)
10 # - karma & MFS (see README)
11 #
12 # Conditional builds:
13 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
14 %bcond_without  mas             # disable MAS audio backend
15 %bcond_without  xine            # disable xine engine
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
18 %bcond_without  helix           # disable HelixPlayer engine
19 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
20 %bcond_with     nmm             # enable NMM audio backend
21 %bcond_with     mysql           # enable MySQL support
22 %bcond_with     pgsql           # enable PostgreSQL support
23 #
24 %ifarch i386
25 %undefine       with_helix
26 %endif
27
28 Summary:        A KDE audio player
29 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
30 Name:           amarok
31 Version:        1.4.10
32 Release:        6
33 License:        GPL
34 Group:          X11/Applications/Multimedia
35 Source0:        ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  3bdbf26181bf5e5925f48968caba7ac2
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         %{name}-sparc.patch
41 Patch4:         kde-ac260-lt.patch
42 Patch5:         kde-common-PLD.patch
43 Patch6:         %{name}-gcc4.patch
44 Patch7:         %{name}-titleorder.patch
45 Patch8:         %{name}-mongrel.patch
46 Patch9:         %{name}-libmtp.patch
47 URL:            http://amarok.kde.org/
48 BuildRequires:  SDL-devel
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  dbus-glib-devel
53 BuildRequires:  gettext-devel
54 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
55 BuildRequires:  kdebase-devel
56 %{?with_akode:BuildRequires:    kdemultimedia-akode}
57 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
58 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.6.0}
59 %{?with_mp3players:BuildRequires:       libifp-devel >= 1.0.0.2}
60 BuildRequires:  libltdl-devel
61 %{?with_mp3players:BuildRequires:       libmtp-devel >= 0.3.0}
62 %{?with_mp3players:BuildRequires:       libnjb-devel >= 2.2.4}
63 %{?with_pgsql:BuildRequires:            libpqxx-devel}
64 BuildRequires:  libtunepimp-devel >= 0.5.1-6
65 BuildRequires:  libvisual-devel >= 0.4.0
66 BuildRequires:  mpeg4ip-devel >= 1:1.6
67 %{?with_mysql:BuildRequires:            mysql-devel}
68 BuildRequires:  pcre-devel
69 BuildRequires:  pkgconfig
70 BuildRequires:  rpm-pythonprov
71 BuildRequires:  rpmbuild(macros) >= 1.129
72 BuildRequires:  ruby-devel >= 1.8
73 BuildRequires:  sed >= 4.0
74 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
75 BuildRequires:  taglib-devel >= 1.4
76 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
77 Requires(post): /sbin/ldconfig
78 Requires:       %{name}-plugin = %{version}-%{release}
79 Requires:       ruby-mongrel
80 Suggests:       kdemultimedia(audiocd) >= 9:3.1.93
81 Suggests:       libvisual-plugin-actor-JESS
82 Suggests:       libvisual-plugin-actor-bumpscope
83 Suggests:       libvisual-plugin-actor-corona
84 Suggests:       libvisual-plugin-actor-flower
85 Suggests:       libvisual-plugin-actor-gdkpixbuf
86 Suggests:       libvisual-plugin-actor-gforce
87 %{?with_gstreamer:Suggests:     libvisual-plugin-actor-gstreamer}
88 Suggests:       libvisual-plugin-actor-infinite
89 Suggests:       libvisual-plugin-actor-jakdaw
90 Suggests:       libvisual-plugin-actor-lv_analyzer
91 Suggests:       libvisual-plugin-actor-lv_gltest
92 Suggests:       libvisual-plugin-actor-lv_scope
93 Suggests:       libvisual-plugin-actor-madspin
94 Suggests:       libvisual-plugin-actor-nastyfft
95 Suggests:       libvisual-plugin-actor-oinksie
96 Suggests:       libvisual-plugin-input-alsa
97 Suggests:       libvisual-plugin-input-esd
98 Suggests:       libvisual-plugin-input-jack
99 Suggests:       libvisual-plugin-input-mplayer
100 Suggests:       libvisual-plugin-morph-alphablend
101 Suggests:       libvisual-plugin-morph-flash
102 Suggests:       libvisual-plugin-morph-slide
103 Suggests:       libvisual-plugin-morph-tentacle
104 Suggests:       python-PyKDE
105 Obsoletes:      amarok-arts
106 Obsoletes:      amarok-xmms
107 Conflicts:      kdelibs-libs < 9:3.5.9
108 # sr@Latn vs. sr@latin
109 Conflicts:      glibc-misc < 6:2.7
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
113 %define         filterout_ld    -Wl,--as-needed
114
115 %description
116 A KDE audio player.
117
118 %description -l pl.UTF-8
119 Odtwarzacz audio dla KDE.
120
121 %package -n konqueror-addon-amarok
122 Summary:        Amarok sidebar for Konqueror
123 Group:          X11/Applications/Multimedia
124 Requires:       %{name} = %{version}-%{release}
125
126 %description -n konqueror-addon-amarok
127 Amarok sidebar for Konqueror
128
129 %package akode
130 Summary:        Plugin akode
131 Summary(pl.UTF-8):      Wtyczka akode
132 Group:          X11/Applications/Multimedia
133 Requires:       %{name} = %{version}-%{release}
134 Provides:       %{name}-plugin = %{version}-%{release}
135
136 %description akode
137 Plugin akode.
138
139 %description akode -l pl.UTF-8
140 Wtyczka akode.
141
142 %package helix
143 Summary:        Helix/Realplayer playback support for amarok
144 Summary(pl.UTF-8):      Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
145 Group:          X11/Applications/Multimedia
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       helix-core
148 Provides:       %{name}-plugin = %{version}-%{release}
149
150 %description helix
151 Helix/Realplayer playback support for amarok.
152
153 %description helix -l pl.UTF-8
154 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
155
156 %package gstreamer
157 Summary:        Plugin gstreamer
158 Summary(pl.UTF-8):      Wtyczka gstreamer
159 Group:          X11/Applications/Multimedia
160 # deps, to get it working:
161 # mp3 decoder:  gstreamer-mad
162 # ogg decoder:  gstreamer-vorbis
163 # audio output driver:  gstreamer-audiosink-alsa
164 # from gstreamer-audio-effects to control volume, etc
165 # needed libs:
166 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
167 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
168 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
169 # gstreamer-musicbrainz for being able to edit id3 tags on files.
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       gstreamer-audio-effects
172 Requires:       gstreamer-audiosink
173 Requires:       gstreamer-mad
174 Requires:       gstreamer-musicbrainz
175 Requires:       gstreamer-vorbis
176 Provides:       %{name}-plugin = %{version}-%{release}
177
178 %description gstreamer
179 Plugin gstreamer.
180
181 %description gstreamer -l pl.UTF-8
182 Wtyczka gstreamer.
183
184 %package xine
185 Summary:        Plugin xine
186 Summary(pl.UTF-8):      Wtyczka xine
187 Group:          X11/Applications/Multimedia
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       xine-plugin-audio
190 Provides:       %{name}-plugin = %{version}-%{release}
191
192 %description xine
193 Plugin xine.
194
195 %description xine -l pl.UTF-8
196 Wtyczka xine.
197
198 %package zeroconf
199 Summary:        Zeroconf data
200 Summary(pl.UTF-8):      Dane dla zeroconf
201 Group:          X11/Applications/Multimedia
202 Requires:       %{name} = %{version}-%{release}
203 Requires:       kdenetwork-kdnssd
204 Provides:       %{name}-plugin = %{version}-%{release}
205
206 %description zeroconf
207 Zeroconf data.
208
209 %description zeroconf -l pl.UTF-8
210 Dane dla zeroconf.
211
212 %package scripts
213 Summary:        amaroK scripts
214 Summary(pl.UTF-8):      Skrypty amaroKa
215 Group:          X11/Applications/Multimedia
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       kdebase-kdialog
218 Requires:       python-PyQt
219 Requires:       ruby-modules
220
221 %description scripts
222 amaroK scripts allow you extend amaroK functionality.
223
224 You can learn more about scripts in amaroK from here:
225 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
226
227 %description scripts -l pl.UTF-8
228 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
229
230 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
231 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
232
233 %prep
234 %setup -q
235 %patch0 -p1
236 %patch1 -p1
237 %patch2 -p1
238 %patch3 -p1
239 %patch4 -p1
240 %patch5 -p1
241 %patch6 -p1
242 %patch7 -p1
243 %patch8 -p1
244 %patch9 -p0
245
246 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
247         amarok/src/amarok.desktop \
248
249 # see kde bug #110909
250 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
251
252 # kill env, call interpreter directly, so rpm automatics could rule
253 %{__sed} -i -e '
254         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
255         1s,#!.*bin/env.*python,#!%{__python},
256 ' amarok/src/scripts/*/*.{py,rb} amarok/src/amarok_proxy.rb
257
258 %build
259 cp -f /usr/share/automake/config.sub admin
260 %{__make} -f admin/Makefile.common cvs
261
262 # hack: passing something other than "no" or "yes" to --with-helix allows
263 # us to pass HELIX_LIBS
264 %configure \
265         HELIX_LIBS=%{_libdir}/helixplayer \
266         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
267         --disable-rpath \
268         --with%{!?with_mas:out}-mas \
269         --with%{!?with_xine:out}-xine \
270         --with%{!?with_gstreamer:out}-gstreamer10 \
271         --with%{!?with_akode:out}-akode \
272         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
273         --with%{!?with_nmm:out}-nmm \
274         --with%{!?with_mp3players:out}-libgpod \
275         --with%{!?with_mp3players:out}-libnjb \
276         --with%{!?with_mp3players:out}-libmtp \
277         --with%{!?with_mp3players:out}-ifp \
278         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
279         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
280         --disable-final \
281         --with-mp4v2 \
282         --with-qt-libraries=%{_libdir} \
283         --with%{!?with_included_sqlite:out}-included-sqlite
284
285 %{__make}
286
287 %install
288 rm -rf $RPM_BUILD_ROOT
289
290 %{__make} install \
291         DESTDIR=$RPM_BUILD_ROOT \
292         ruby_rubylibdir=%{ruby_rubylibdir} \
293         kde_htmldir=%{_kdedocdir} \
294         kde_libs_htmldir=%{_kdedocdir}
295
296 # remove bogus dir
297 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
298
299 rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
300 rm $RPM_BUILD_ROOT%{_libdir}/libamarok.{so,la}
301
302 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
303         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
304 %find_lang amarok --all-name --with-kde
305
306 %clean
307 rm -rf $RPM_BUILD_ROOT
308
309 %post -p /sbin/ldconfig
310
311 %postun -p /sbin/ldconfig
312
313 %files -f amarok.lang
314 %defattr(644,root,root,755)
315 %doc AUTHORS ChangeLog README
316 %attr(755,root,root) %{_bindir}/amarok
317 %attr(755,root,root) %{_bindir}/amarokapp
318 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
319 %attr(755,root,root) %{_bindir}/amarok_libvisual
320 # used by last.fm and daap
321 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
322 # used by daap
323 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
324 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
325 %attr(755,root,root) %ghost %{_libdir}/libamarok.so.0
326 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
327 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
328 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
329 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
330 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
331 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
332 %dir %{_datadir}/apps/amarok
333 %dir %{_datadir}/apps/amarok/scripts
334 %{_datadir}/apps/amarok/*.rc
335 %{_datadir}/apps/amarok/data
336 %{_datadir}/apps/amarok/icons
337 %{_datadir}/apps/amarok/images
338 %{_datadir}/apps/amarok/themes
339 %{_datadir}/apps/profiles/amarok.profile.xml
340 %{_datadir}/config/amarokrc
341 %{_datadir}/config.kcfg/amarok.kcfg
342 %{_datadir}/services/amarok_generic-mediadevice.desktop
343 %{_datadir}/services/amarok_void-engine_plugin.desktop
344 %{_datadir}/services/amarok_daap-mediadevice.desktop
345 %{_datadir}/services/amarok_massstorage-device.desktop
346 %{_datadir}/services/amarok_nfs-device.desktop
347 %{_datadir}/services/amarok_smb-device.desktop
348 %{_datadir}/services/amaroklastfm.protocol
349 %{_datadir}/services/amarokitpc.protocol
350 %{_datadir}/services/amarokpcast.protocol
351 %{_datadir}/servicetypes/amarok_codecinstall.desktop
352 %{_datadir}/servicetypes/amarok_plugin.desktop
353 %{_desktopdir}/kde/amarok.desktop
354 %{_iconsdir}/*/*/apps/amarok.*
355
356 # TODO: move to subpackage
357 %dir %{ruby_rubylibdir}/amarok
358 # used by daap
359 %{ruby_rubylibdir}/amarok/codes.rb
360 # used by daap and lyrics_lyrc
361 %{ruby_rubylibdir}/amarok/debug.rb
362
363 # TODO: move to subpackage
364 %if %{with mp3players}
365 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
366 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
367 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
368 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
369 %{_datadir}/services/amarok_ifp-mediadevice.desktop
370 %{_datadir}/services/amarok_ipod-mediadevice.desktop
371 %{_datadir}/services/amarok_mtp-mediadevice.desktop
372 %{_datadir}/services/amarok_njb-mediadevice.desktop
373 %endif
374
375 %files -n konqueror-addon-amarok
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
378 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
379 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
380 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
381 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
382 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
383 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
384
385 %if %{with akode}
386 %files akode
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
389 %{_datadir}/services/amarok_aKode-engine.desktop
390 %endif
391
392 %if %{with gstreamer}
393 %files gstreamer
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
396 %{_datadir}/config.kcfg/gstconfig.kcfg
397 %{_datadir}/services/amarok_gst10engine_plugin.desktop
398 %endif
399
400 %if %{with helix}
401 %files helix
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
404 %{_datadir}/config.kcfg/helixconfig.kcfg
405 %{_datadir}/services/amarok_helixengine_plugin.desktop
406 %endif
407
408 %if %{with xine}
409 %files xine
410 %defattr(644,root,root,755)
411 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
412 %{_datadir}/config.kcfg/xinecfg.kcfg
413 %{_datadir}/services/amarok_xine-engine.desktop
414 %endif
415
416 %if 0
417 %if %{with zeroconf}
418 %files zeroconf
419 %defattr(644,root,root,755)
420 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
421 %endif
422 %endif
423
424 %files scripts
425 %defattr(644,root,root,755)
426 %dir %{_datadir}/apps/amarok/scripts/common
427 %{_datadir}/apps/amarok/scripts/common/Publisher.py
428 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
429
430 %dir %{_datadir}/apps/amarok/scripts/templates
431 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
432 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
433 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
434
435 # amarok searches for executable programs for scripts
436 # to figure out which files need to have execute permission, use this
437 # find command:
438 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
439
440 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
441 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
442 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
443
444 %dir %{_datadir}/apps/amarok/scripts/playlist2html
445 %{_datadir}/apps/amarok/scripts/playlist2html/README
446 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
447 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
448 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
449 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.spec
450 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.spec
451
452
453 %dir %{_datadir}/apps/amarok/scripts/webcontrol
454 %{_datadir}/apps/amarok/scripts/webcontrol/README
455 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
456 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
457 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
458 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
459 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
460 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
461 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
462 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
463 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
464 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
465 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
466 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
467 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
468 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
469 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
470 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
471 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
472 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
473 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
474
475 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
476 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
477 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
478 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
479 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
480
481 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
482 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
483 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
484 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
485 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
486
487 %dir %{_datadir}/apps/amarok/scripts/score_default
488 %{_datadir}/apps/amarok/scripts/score_default/COPYING
489 %{_datadir}/apps/amarok/scripts/score_default/README
490 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
491 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
492 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
493 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
494 %{_datadir}/apps/amarok/scripts/score_impulsive/README
495 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
496 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
497
498 %if 0
499 %dir %{_datadir}/apps/amarok/scripts/amarok_live
500 %{_datadir}/apps/amarok/scripts/amarok_live/README
501 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
502 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
503 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
504 %endif
This page took 0.06688 seconds and 3 git commands to generate.