]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
260fb2b0e2dc9f930af2c42406c5996c97cba037
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - does not run
5 #
6
7 %define         state   stable
8 %define         qtver   4.7.1
9 %define         kdever  4.5.5
10
11 Summary:        A KDE audio player
12 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        2.4.1
15 Release:        0.1
16 License:        GPL v2+ and LGPL v2.1+
17 Group:          X11/Applications/Multimedia
18 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  4c65c5cd4d7bd267bdbef8e912fd6cb6
20 Patch0:         %{name}-disable_qtscriptbindings_check_fix.patch
21 URL:            http://amarok.kde.org/
22 BuildRequires:  QtNetwork-devel >= %{qtver}
23 BuildRequires:  QtSql-devel >= %{qtver}
24 BuildRequires:  automoc4 >= 0.9.88
25 BuildRequires:  cmake >= 2.8.0
26 BuildRequires:  curl-devel
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel
29 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
30 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
31 BuildRequires:  libaio-devel
32 BuildRequires:  libgpod-devel >= 0.7.0
33 BuildRequires:  liblastfm-devel
34 BuildRequires:  libmtp-devel >= 0.3.0
35 BuildRequires:  libofa-devel
36 BuildRequires:  libwrap-devel
37 BuildRequires:  loudmouth-devel
38 BuildRequires:  mysql-devel >= 5.1.31-3
39 BuildRequires:  pcre-devel
40 BuildRequires:  pkgconfig
41 BuildRequires:  qca-devel
42 BuildRequires:  qt4-build >= %{qtver}
43 BuildRequires:  qt4-qmake >= %{qtver}
44 BuildRequires:  qtscriptbindings
45 BuildRequires:  rpmbuild(macros) >= 1.600
46 BuildRequires:  soprano-devel
47 BuildRequires:  strigi-devel >= 0.7.0
48 BuildRequires:  taglib-devel >= 1.6
49 BuildRequires:  taglib-extras-devel >= 1.0.0
50 BuildRequires:  xorg-lib-libXpm-devel
51 Requires(post,postun):  /sbin/ldconfig
52 Requires:       kde4-kdemultimedia-audiocd
53 Requires:       kde4-phonon
54 Requires:       qtscriptbindings
55 Suggests:       libvisual-plugin-actor-JESS
56 Suggests:       libvisual-plugin-actor-bumpscope
57 Suggests:       libvisual-plugin-actor-corona
58 Suggests:       libvisual-plugin-actor-flower
59 Suggests:       libvisual-plugin-actor-gdkpixbuf
60 Suggests:       libvisual-plugin-actor-gforce
61 Suggests:       libvisual-plugin-actor-gstreamer
62 Suggests:       libvisual-plugin-actor-infinite
63 Suggests:       libvisual-plugin-actor-jakdaw
64 Suggests:       libvisual-plugin-actor-lv_analyzer
65 Suggests:       libvisual-plugin-actor-lv_gltest
66 Suggests:       libvisual-plugin-actor-lv_scope
67 Suggests:       libvisual-plugin-actor-madspin
68 Suggests:       libvisual-plugin-actor-nastyfft
69 Suggests:       libvisual-plugin-actor-oinksie
70 Suggests:       libvisual-plugin-input-alsa
71 Suggests:       libvisual-plugin-input-jack
72 Suggests:       libvisual-plugin-input-mplayer
73 Suggests:       libvisual-plugin-morph-alphablend
74 Suggests:       libvisual-plugin-morph-flash
75 Suggests:       libvisual-plugin-morph-slide
76 Suggests:       libvisual-plugin-morph-tentacle
77 Obsoletes:      amarok-arts
78 Obsoletes:      amarok-xmms
79 # It should require mysql-embeded
80 Requires:       mysql >= 5.1.31-3
81 Conflicts:      mysql < 5.1.31-3
82 # sr@Latn vs. sr@latin
83 Conflicts:      glibc-misc < 6:2.7
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 A KDE audio player.
88
89 %description -l pl.UTF-8
90 Odtwarzacz audio dla KDE.
91
92 %package scripts
93 Summary:        amaroK scripts
94 Summary(pl.UTF-8):      Skrypty amaroKa
95 Group:          X11/Applications/Multimedia
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       kde4-kdebase-kdialog
98
99 %description scripts
100 amaroK scripts allow you extend amaroK functionality.
101
102 You can learn more about scripts in amaroK from here:
103 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
104
105 %description scripts -l pl.UTF-8
106 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
107
108 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
109 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %build
116 install -d build
117 cd build
118 %cmake \
119         -DWITH_MYSQL_EMBEDDED=OFF \
120         ../
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} -C build install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         kde_htmldir=%{_kdedocdir} \
130         kde_libs_htmldir=%{_kdedocdir}
131
132 # remove unsupported locale
133 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
134
135 # remove .so symlinks so that noone gets the stupid idea to package them
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
137
138 %find_lang %{name} --all-name --with-kde
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post           -p /sbin/ldconfig
144 %postun         -p /sbin/ldconfig
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog README
149 %attr(755,root,root) %{_bindir}/amarok
150 %attr(755,root,root) %{_bindir}/amarokpkg
151 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
152 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
153 %attr(755,root,root) %{_bindir}/amarok_afttagger
154 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
155 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
157 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
159 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
161 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
163 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
165 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
166 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
167 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
168 %attr(755,root,root) %{_libdir}/libampache_account_login.so
169 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
170 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
171 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
172 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
173 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
174 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
208 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
209 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
210 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
214 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
215 %dir %{_datadir}/apps/amarok
216 %dir %{_datadir}/apps/amarok/scripts
217 %{_datadir}/apps/amarok/data
218 %{_datadir}/apps/amarok/icons
219 %{_datadir}/apps/amarok/images
220 %{_datadir}/apps/amarok/amarok.notifyrc
221 %{_datadir}/apps/desktoptheme
222 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
223 %{_datadir}/config.kcfg/amarokconfig.kcfg
224 %{_datadir}/config/amarok.knsrc
225 %{_datadir}/config/amarokapplets.knsrc
226 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
227 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
228 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
229 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
230 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
231 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
232 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
233 %{_desktopdir}/kde4/amarok_containers.desktop
234 %{_datadir}/kde4/services/amarok.protocol
235 %{_datadir}/kde4/services/amaroklastfm.protocol
236 %{_datadir}/kde4/services/amarokitpc.protocol
237 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
238 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
239 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
240 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
241 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
242 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
243 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
244 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
245 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
246 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
247 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
248 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
250 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
251 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
252 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
253 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
254 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
255 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
256 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
257 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
258 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
259 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
260 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
261 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
262 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
263 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
264 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
265 %{_datadir}/kde4/services/amarok_device_massstorage.desktop
266 %{_datadir}/kde4/services/amarok_device_nfs.desktop
267 %{_datadir}/kde4/services/amarok_device_smb.desktop
268 %{_datadir}/kde4/services/amarok_service_ampache.desktop
269 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
270 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
271 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
272 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
273 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
274 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
275 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
276 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
277 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
278 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
279 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
280 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
281 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
282 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
283 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
284 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
285 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
286 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
287 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
288 %{_desktopdir}/kde4/amarok.desktop
289 %{_iconsdir}/*/*/apps/amarok.*
290 %{_datadir}/config/amarok_homerc
291
292 %files scripts
293 %defattr(644,root,root,755)
294 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
295 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
296 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
297 %dir %{_datadir}/apps/amarok/scripts/script_console
298 %{_datadir}/apps/amarok/scripts/script_console/main.js
299 %{_datadir}/apps/amarok/scripts/script_console/script.spec
300 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
301 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
302 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
303 %dir %{_datadir}/apps/amarok/scripts/librivox_service
304 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
305 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
306 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
307 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
308 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
309 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
310 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
311 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.037806 seconds and 2 git commands to generate.