]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- updated BRs and Rs
[packages/amarok.git] / amarok.spec
1 # TODO
2 # - try not to link with static mysql
3
4 %define         state   stable
5 %define         qtver   4.6.2
6 %define         kdever  4.4.4
7
8 Summary:        A KDE audio player
9 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        2.3.1
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
16 # Source0-md5:  6679adaf5cc757b1515a9f03cdcb6066
17 Patch0:         %{name}-disable_qtscriptbindings_check_fix.patch
18 URL:            http://amarok.kde.org/
19 BuildRequires:  QtNetwork-devel >= %{qtver}
20 BuildRequires:  QtSql-devel >= %{qtver}
21 BuildRequires:  automoc4 >= 0.9.88
22 BuildRequires:  cmake >= 2.8.0
23 BuildRequires:  curl-devel
24 BuildRequires:  gettext-devel
25 BuildRequires:  glib2-devel
26 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
27 BuildRequires:  kde4-kdemultimedia-devel >= %{kdever}
28 BuildRequires:  libgpod-devel >= 0.7.0
29 BuildRequires:  liblastfm-devel
30 BuildRequires:  libmtp-devel >= 0.3.0
31 BuildRequires:  loudmouth-devel
32 BuildRequires:  mysql-devel >= 5.1.31-3
33 BuildRequires:  pcre-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  qca-devel
36 BuildRequires:  qt4-build >= %{qtver}
37 BuildRequires:  qt4-qmake >= %{qtver}
38 BuildRequires:  qtscriptbindings
39 BuildRequires:  rpmbuild(macros) >= 1.129
40 BuildRequires:  strigi-devel >= 0.7.0
41 BuildRequires:  taglib-devel >= 1.6
42 BuildRequires:  taglib-extras-devel >= 1.0.0
43 BuildRequires:  xorg-lib-libXpm-devel
44 Requires(post,postun):  /sbin/ldconfig
45 Requires:       kde4-kdemultimedia-audiocd
46 Requires:       kde4-phonon
47 Requires:       qtscriptbindings
48 Suggests:       libvisual-plugin-actor-JESS
49 Suggests:       libvisual-plugin-actor-bumpscope
50 Suggests:       libvisual-plugin-actor-corona
51 Suggests:       libvisual-plugin-actor-flower
52 Suggests:       libvisual-plugin-actor-gdkpixbuf
53 Suggests:       libvisual-plugin-actor-gforce
54 Suggests:       libvisual-plugin-actor-gstreamer
55 Suggests:       libvisual-plugin-actor-infinite
56 Suggests:       libvisual-plugin-actor-jakdaw
57 Suggests:       libvisual-plugin-actor-lv_analyzer
58 Suggests:       libvisual-plugin-actor-lv_gltest
59 Suggests:       libvisual-plugin-actor-lv_scope
60 Suggests:       libvisual-plugin-actor-madspin
61 Suggests:       libvisual-plugin-actor-nastyfft
62 Suggests:       libvisual-plugin-actor-oinksie
63 Suggests:       libvisual-plugin-input-alsa
64 Suggests:       libvisual-plugin-input-esd
65 Suggests:       libvisual-plugin-input-jack
66 Suggests:       libvisual-plugin-input-mplayer
67 Suggests:       libvisual-plugin-morph-alphablend
68 Suggests:       libvisual-plugin-morph-flash
69 Suggests:       libvisual-plugin-morph-slide
70 Suggests:       libvisual-plugin-morph-tentacle
71 Obsoletes:      amarok-arts
72 Obsoletes:      amarok-xmms
73 # It should require mysql-embeded
74 Requires:       mysql >= 5.1.31-3
75 Conflicts:      mysql < 5.1.31-3
76 # sr@Latn vs. sr@latin
77 Conflicts:      glibc-misc < 6:2.7
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 A KDE audio player.
82
83 %description -l pl.UTF-8
84 Odtwarzacz audio dla KDE.
85
86 %package scripts
87 Summary:        amaroK scripts
88 Summary(pl.UTF-8):      Skrypty amaroKa
89 Group:          X11/Applications/Multimedia
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       kde4-kdebase-kdialog
92
93 %description scripts
94 amaroK scripts allow you extend amaroK functionality.
95
96 You can learn more about scripts in amaroK from here:
97 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
98
99 %description scripts -l pl.UTF-8
100 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
101
102 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
103 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 install -d build
111 cd build
112 %cmake \
113         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
114         -DLIB_INSTALL_DIR=%{_libdir} \
115         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
116 %if "%{_lib}" == "lib64"
117         -DLIB_SUFFIX=64 \
118 %endif
119         ../
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} -C build install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         kde_htmldir=%{_kdedocdir} \
129         kde_libs_htmldir=%{_kdedocdir}
130
131 # remove bogus dir
132 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
133
134 # remove unsupported locale
135 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
136
137 %find_lang %{name} --all-name --with-kde
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post           -p /sbin/ldconfig
143 %postun         -p /sbin/ldconfig
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog README
148 %attr(755,root,root) %{_bindir}/amarok
149 %attr(755,root,root) %{_bindir}/amarokpkg
150 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
151 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
152 %attr(755,root,root) %{_bindir}/amarok_afttagger
153 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
154 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
156 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
158 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
159 %attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
160 %attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
161 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
162 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
163 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
164 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
165 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
166 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
167 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
168 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
169 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
170 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
171 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
172 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
173 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
174 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
179 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
180 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
181 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
182 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
199 %dir %{_datadir}/apps/amarok
200 %attr(755,root,root) %{_libdir}/libamaroklib.so
201 %attr(755,root,root) %{_libdir}/libamarokocsclient.so
202 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
203 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so
205 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
206 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libamarokpud.so
208 %dir %{_datadir}/apps/amarok/scripts
209 %{_datadir}/apps/amarok/data
210 %{_datadir}/apps/amarok/icons
211 %{_datadir}/apps/amarok/images
212 %{_datadir}/apps/amarok/amarok.notifyrc
213 %{_datadir}/apps/desktoptheme
214 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
215 %{_datadir}/config.kcfg/amarokconfig.kcfg
216 %{_datadir}/config/amarok.knsrc
217 %{_datadir}/config/amarokapplets.knsrc
218 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
219 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
220 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
221 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
222 %{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
223 %{_datadir}/kde4/services/amarok.protocol
224 %{_datadir}/kde4/services/amaroklastfm.protocol
225 %{_datadir}/kde4/services/amarokitpc.protocol
226 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
227 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
228 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
229 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
230 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
231 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
232 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
233 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
234 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
235 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
236 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
237 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
238 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
239 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
240 %{_datadir}/kde4/services/amarok_service_ampache.desktop
241 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
242 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
243 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
244 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
245 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
246 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
247 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
248 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
250 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
251 %{_datadir}/kde4/services/amarok_massstorage-device.desktop
252 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
253 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
254 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
255 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
256 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
257 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
258 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
259 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
260 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
261 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
262 %{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
263 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
264 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
265 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
266 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
267 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
268 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
269 %{_desktopdir}/kde4/amarok.desktop
270 %{_iconsdir}/*/*/apps/amarok.*
271 %{_datadir}/config/amarok_homerc
272
273 %files scripts
274 %defattr(644,root,root,755)
275 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
276 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
277 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
278 %dir %{_datadir}/apps/amarok/scripts/script_console
279 %{_datadir}/apps/amarok/scripts/script_console/main.js
280 %{_datadir}/apps/amarok/scripts/script_console/script.spec
281 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
282 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
283 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
284 %dir %{_datadir}/apps/amarok/scripts/librivox_service
285 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
286 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
287 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
288 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
289 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
290 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
291 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
292 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.046817 seconds and 3 git commands to generate.