]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
2285c19a28e9d98d97fc4b39cd60b5c93a943746
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - amarok now requires his own database which is not automaticly created 
5 # Add spec:
6 # libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
7 #     Enable gpodder.net service
8 # -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
9 # /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
10 %define         state   stable
11 %define         qtver   4.7.1
12 %define         kdever  4.5.5
13
14 Summary:        A KDE audio player
15 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
16 Name:           amarok
17 Version:        2.5.0
18 Release:        1
19 License:        GPL v2+ and LGPL v2.1+
20 Group:          X11/Applications/Multimedia
21 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
22 # Source0-md5:  b7983eaa33e4771769ae9e330c811995
23 Patch0:         %{name}-upnp-dep.patch
24 URL:            http://amarok.kde.org/
25 BuildRequires:  QtNetwork-devel >= %{qtver}
26 BuildRequires:  QtSql-devel >= %{qtver}
27 BuildRequires:  automoc4 >= 0.9.88
28 BuildRequires:  cmake >= 2.8.0
29 BuildRequires:  curl-devel
30 BuildRequires:  ffmpeg-devel >= 0.7.1
31 BuildRequires:  gettext-devel
32 BuildRequires:  glib2-devel
33 BuildRequires:  herqq-devel
34 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
35 BuildRequires:  libaio-devel
36 BuildRequires:  libgpod-devel >= 0.7.0
37 BuildRequires:  liblastfm-devel
38 BuildRequires:  libmtp-devel >= 1.0.4
39 BuildRequires:  libofa-devel
40 BuildRequires:  libwrap-devel
41 BuildRequires:  loudmouth-devel
42 BuildRequires:  mysql-devel >= 5.1.31-3
43 BuildRequires:  pcre-devel
44 BuildRequires:  pkgconfig
45 BuildRequires:  qca-devel
46 BuildRequires:  qjson-devel >= 0.5
47 BuildRequires:  qt4-build >= %{qtver}
48 BuildRequires:  qt4-qmake >= %{qtver}
49 BuildRequires:  qtscriptbindings
50 BuildRequires:  rpmbuild(macros) >= 1.600
51 BuildRequires:  soprano-devel
52 BuildRequires:  strigi-devel >= 0.7.0
53 BuildRequires:  taglib-devel >= 1.7
54 BuildRequires:  taglib-extras-devel >= 1.0.0
55 BuildRequires:  xorg-lib-libXpm-devel
56 Requires(post,postun):  /sbin/ldconfig
57 Requires:       kde4-kdemultimedia-audiocd
58 Requires:       kde4-phonon
59 Requires:       qtscriptbindings
60 Suggests:       libvisual-plugin-actor-JESS
61 Suggests:       libvisual-plugin-actor-bumpscope
62 Suggests:       libvisual-plugin-actor-corona
63 Suggests:       libvisual-plugin-actor-flower
64 Suggests:       libvisual-plugin-actor-gdkpixbuf
65 Suggests:       libvisual-plugin-actor-gforce
66 Suggests:       libvisual-plugin-actor-gstreamer
67 Suggests:       libvisual-plugin-actor-infinite
68 Suggests:       libvisual-plugin-actor-jakdaw
69 Suggests:       libvisual-plugin-actor-lv_analyzer
70 Suggests:       libvisual-plugin-actor-lv_gltest
71 Suggests:       libvisual-plugin-actor-lv_scope
72 Suggests:       libvisual-plugin-actor-madspin
73 Suggests:       libvisual-plugin-actor-nastyfft
74 Suggests:       libvisual-plugin-actor-oinksie
75 Suggests:       libvisual-plugin-input-alsa
76 Suggests:       libvisual-plugin-input-jack
77 Suggests:       libvisual-plugin-input-mplayer
78 Suggests:       libvisual-plugin-morph-alphablend
79 Suggests:       libvisual-plugin-morph-flash
80 Suggests:       libvisual-plugin-morph-slide
81 Suggests:       libvisual-plugin-morph-tentacle
82 Obsoletes:      amarok-arts
83 Obsoletes:      amarok-xmms
84 # It should require mysql-embeded
85 Requires:       mysql >= 5.1.31-3
86 Conflicts:      mysql < 5.1.31-3
87 # sr@Latn vs. sr@latin
88 Conflicts:      glibc-misc < 6:2.7
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %description
92 A KDE audio player.
93
94 %description -l pl.UTF-8
95 Odtwarzacz audio dla KDE.
96
97 %package scripts
98 Summary:        amaroK scripts
99 Summary(pl.UTF-8):      Skrypty amaroKa
100 Group:          X11/Applications/Multimedia
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       kde4-kdebase-kdialog
103
104 %description scripts
105 amaroK scripts allow you extend amaroK functionality.
106
107 You can learn more about scripts in amaroK from here:
108 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
109
110 %description scripts -l pl.UTF-8
111 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
112
113 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
114 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %build
121 install -d build
122 cd build
123 %cmake \
124         -DWITH_MYSQL_EMBEDDED=OFF \
125         ../
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} -C build install \
133         DESTDIR=$RPM_BUILD_ROOT \
134         kde_htmldir=%{_kdedocdir} \
135         kde_libs_htmldir=%{_kdedocdir}
136
137 # remove unsupported locale
138 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
139
140 # remove .so symlinks so that noone gets the stupid idea to package them
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
142
143 %find_lang %{name} --all-name --with-kde
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post           -p /sbin/ldconfig
149 %postun         -p /sbin/ldconfig
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog README
154 %attr(755,root,root) %{_bindir}/amarok
155 %attr(755,root,root) %{_bindir}/amarokpkg
156 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
157 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
158 %attr(755,root,root) %{_bindir}/amarok_afttagger
159 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
160 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
162 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
164 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
166 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
168 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
170 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
171 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
172 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
173 %attr(755,root,root) %{_libdir}/libampache_account_login.so
174 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
175 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
176 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
179 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
181 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_spectrum_analyzer.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_spectrum_analyzer.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
205 %attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
206 %attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
207 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
208 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
213 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
214 %attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
215 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
216 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
217 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
218 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
219 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
220 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
221 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
222 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
223 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
224 %dir %{_datadir}/apps/amarok
225 %dir %{_datadir}/apps/amarok/scripts
226 %{_datadir}/apps/amarok/data
227 %{_datadir}/apps/amarok/icons
228 %{_datadir}/apps/amarok/images
229 %{_datadir}/apps/amarok/amarok.notifyrc
230 %{_datadir}/apps/desktoptheme
231 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
232 %{_datadir}/config.kcfg/amarokconfig.kcfg
233 %{_datadir}/config/amarok.knsrc
234 %{_datadir}/config/amarokapplets.knsrc
235 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
236 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
237 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
238 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
239 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
240 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
241 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
242 %{_desktopdir}/kde4/amarok_containers.desktop
243 %{_datadir}/kde4/services/amarok.protocol
244 %{_datadir}/kde4/services/amaroklastfm.protocol
245 %{_datadir}/kde4/services/amarokitpc.protocol
246 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
247 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
248 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
249 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
250 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
251 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
252 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
253 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
254 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
255 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
256 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
257 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
258 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
259 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
260 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
261 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
262 %{_datadir}/kde4/services/amarok-context-applet-spectrum-analyzer.desktop
263 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
264 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
265 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
266 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
267 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
268 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
269 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
270 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
271 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
272 %{_datadir}/kde4/services/amarok-data-engine-spectrum-analyzer.desktop
273 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
274 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
275 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
276 %{_datadir}/kde4/services/amarok_device_massstorage.desktop
277 %{_datadir}/kde4/services/amarok_device_nfs.desktop
278 %{_datadir}/kde4/services/amarok_device_smb.desktop
279 %{_datadir}/kde4/services/amarok_service_amazonstore.desktop
280 %{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
281 %{_datadir}/kde4/services/amarok_service_ampache.desktop
282 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
283 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
284 %{_datadir}/kde4/services/amarok_service_lastfm.desktop
285 %{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
286 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
287 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
288 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
289 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
290 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
291 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
292 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
293 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
294 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
295 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
296 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
297 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
298 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
299 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
300 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
301 %{_desktopdir}/kde4/amarok.desktop
302 %{_iconsdir}/*/*/apps/amarok.*
303 %{_datadir}/config/amarok_homerc
304 %attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
305 %{_datadir}/apps/kconf_update/amarok.upd
306
307 %files scripts
308 %defattr(644,root,root,755)
309 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
310 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
311 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
312 %dir %{_datadir}/apps/amarok/scripts/script_console
313 %{_datadir}/apps/amarok/scripts/script_console/main.js
314 %{_datadir}/apps/amarok/scripts/script_console/script.spec
315 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
316 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
317 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
318 %dir %{_datadir}/apps/amarok/scripts/librivox_service
319 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
320 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
321 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
322 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
323 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
324 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
325 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
326 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
This page took 0.038012 seconds and 2 git commands to generate.