]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- version for kde4-kdeextragear-multimedia on HEAD
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 # - ProjectM (see README)
10 # - karma & MFS (see README)
11 #
12 # Conditional builds:
13 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
14 %bcond_without  mas             # disable MAS audio backend
15 %bcond_without  xine            # disable xine engine
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
18 %bcond_without  helix           # disable HelixPlayer engine
19 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
20 %bcond_with     nmm             # enable NMM audio backend
21 %bcond_with     mysql           # enable MySQL support
22 %bcond_with     pgsql           # enable PostgreSQL support
23 #
24 %ifarch i386
25 %undefine       with_helix
26 %endif
27
28 Summary:        A KDE audio player
29 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
30 Name:           amarok
31 Version:        1.4.10
32 Release:        1
33 License:        GPL
34 Group:          X11/Applications/Multimedia
35 Source0:        ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  3bdbf26181bf5e5925f48968caba7ac2
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         %{name}-sparc.patch
41 Patch4:         kde-ac260-lt.patch
42 Patch5:         kde-common-PLD.patch
43 Patch6:         %{name}-gcc4.patch
44 Patch7:         %{name}-titleorder.patch
45 Patch8:         %{name}-mongrel.patch
46 Patch9:         %{name}-libmtp.patch
47 URL:            http://amarok.kde.org/
48 BuildRequires:  SDL-devel
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  autoconf
51 BuildRequires:  automake
52 BuildRequires:  dbus-glib-devel
53 BuildRequires:  gettext-devel
54 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
55 BuildRequires:  kdebase-devel
56 %{?with_akode:BuildRequires:    kdemultimedia-akode}
57 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
58 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.6.0}
59 %{?with_mp3players:BuildRequires:       libifp-devel >= 1.0.0.2}
60 BuildRequires:  libltdl-devel
61 %{?with_mp3players:BuildRequires:       libmtp-devel >= 0.3.0}
62 %{?with_mp3players:BuildRequires:       libnjb-devel >= 2.2.4}
63 %{?with_pgsql:BuildRequires:            libpqxx-devel}
64 BuildRequires:  libtunepimp-devel >= 0.5.1-6
65 BuildRequires:  libvisual-devel >= 0.4.0
66 BuildRequires:  mpeg4ip-devel >= 1:1.6
67 %{?with_mysql:BuildRequires:            mysql-devel}
68 BuildRequires:  pcre-devel
69 BuildRequires:  pkgconfig
70 BuildRequires:  rpm-pythonprov
71 BuildRequires:  rpmbuild(macros) >= 1.129
72 BuildRequires:  ruby-devel >= 1.8
73 BuildRequires:  sed >= 4.0
74 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
75 BuildRequires:  taglib-devel >= 1.4
76 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
77 Requires(post): /sbin/ldconfig
78 Requires:       %{name}-plugin = %{version}-%{release}
79 Requires:       kdebase-core >= 9:3.1.93
80 Requires:       kdelibs-libs >= 9:3.5.9
81 Requires:       ruby-mongrel
82 Suggests:       kdemultimedia(audiocd) >= 9:3.1.93
83 Suggests:       libvisual-plugin-actor-JESS
84 Suggests:       libvisual-plugin-actor-bumpscope
85 Suggests:       libvisual-plugin-actor-corona
86 Suggests:       libvisual-plugin-actor-flower
87 Suggests:       libvisual-plugin-actor-gdkpixbuf
88 Suggests:       libvisual-plugin-actor-gforce
89 Suggests:       libvisual-plugin-actor-gstreamer
90 Suggests:       libvisual-plugin-actor-infinite
91 Suggests:       libvisual-plugin-actor-jakdaw
92 Suggests:       libvisual-plugin-actor-lv_analyzer
93 Suggests:       libvisual-plugin-actor-lv_gltest
94 Suggests:       libvisual-plugin-actor-lv_scope
95 Suggests:       libvisual-plugin-actor-madspin
96 Suggests:       libvisual-plugin-actor-nastyfft
97 Suggests:       libvisual-plugin-actor-oinksie
98 Suggests:       libvisual-plugin-input-alsa
99 Suggests:       libvisual-plugin-input-esd
100 Suggests:       libvisual-plugin-input-jack
101 Suggests:       libvisual-plugin-input-mplayer
102 Suggests:       libvisual-plugin-morph-alphablend
103 Suggests:       libvisual-plugin-morph-flash
104 Suggests:       libvisual-plugin-morph-slide
105 Suggests:       libvisual-plugin-morph-tentacle
106 Suggests:       python-PyKDE
107 Obsoletes:      amarok-arts
108 Obsoletes:      amarok-xmms
109 # sr@Latn vs. sr@latin
110 Conflicts:      glibc-misc < 6:2.7
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
114 %define         filterout_ld    -Wl,--as-needed
115
116 %description
117 A KDE audio player.
118
119 %description -l pl.UTF-8
120 Odtwarzacz audio dla KDE.
121
122 %package akode
123 Summary:        Plugin akode
124 Summary(pl.UTF-8):      Wtyczka akode
125 Group:          X11/Applications/Multimedia
126 Requires:       %{name} = %{version}-%{release}
127 Provides:       %{name}-plugin = %{version}-%{release}
128
129 %description akode
130 Plugin akode.
131
132 %description akode -l pl.UTF-8
133 Wtyczka akode.
134
135 %package helix
136 Summary:        Helix/Realplayer playback support for amarok
137 Summary(pl.UTF-8):      Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
138 Group:          X11/Applications/Multimedia
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       helix-core
141 Provides:       %{name}-plugin = %{version}-%{release}
142
143 %description helix
144 Helix/Realplayer playback support for amarok.
145
146 %description helix -l pl.UTF-8
147 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
148
149 %package gstreamer
150 Summary:        Plugin gstreamer
151 Summary(pl.UTF-8):      Wtyczka gstreamer
152 Group:          X11/Applications/Multimedia
153 # deps, to get it working:
154 # mp3 decoder:  gstreamer-mad
155 # ogg decoder:  gstreamer-vorbis
156 # audio output driver:  gstreamer-audiosink-alsa
157 # from gstreamer-audio-effects to control volume, etc
158 # needed libs:
159 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
160 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
161 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
162 # gstreamer-musicbrainz for being able to edit id3 tags on files.
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       gstreamer-audio-effects
165 Requires:       gstreamer-audiosink
166 Requires:       gstreamer-mad
167 Requires:       gstreamer-musicbrainz
168 Requires:       gstreamer-vorbis
169 Provides:       %{name}-plugin = %{version}-%{release}
170
171 %description gstreamer
172 Plugin gstreamer.
173
174 %description gstreamer -l pl.UTF-8
175 Wtyczka gstreamer.
176
177 %package xine
178 Summary:        Plugin xine
179 Summary(pl.UTF-8):      Wtyczka xine
180 Group:          X11/Applications/Multimedia
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       xine-plugin-audio
183 Provides:       %{name}-plugin = %{version}-%{release}
184
185 %description xine
186 Plugin xine.
187
188 %description xine -l pl.UTF-8
189 Wtyczka xine.
190
191 %package zeroconf
192 Summary:        Zeroconf data
193 Summary(pl.UTF-8):      Dane dla zeroconf
194 Group:          X11/Applications/Multimedia
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       kdenetwork-kdnssd
197 Provides:       %{name}-plugin = %{version}-%{release}
198
199 %description zeroconf
200 Zeroconf data.
201
202 %description zeroconf -l pl.UTF-8
203 Dane dla zeroconf.
204
205 %package scripts
206 Summary:        amaroK scripts
207 Summary(pl.UTF-8):      Skrypty amaroKa
208 Group:          X11/Applications/Multimedia
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       kdebase-kdialog
211 Requires:       python-PyQt
212 Requires:       ruby-modules
213
214 %description scripts
215 amaroK scripts allow you extend amaroK functionality.
216
217 You can learn more about scripts in amaroK from here:
218 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
219
220 %description scripts -l pl.UTF-8
221 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
222
223 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
224 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
225
226 %prep
227 %setup -q
228 %patch0 -p1
229 %patch1 -p1
230 %patch2 -p1
231 %patch3 -p1
232 %patch4 -p1
233 %patch5 -p1
234 %patch6 -p1
235 %patch7 -p1
236 %patch8 -p1
237 %patch9 -p0
238
239 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
240         amarok/src/amarok.desktop \
241
242 # see kde bug #110909
243 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
244
245 # kill env, call interpreter directly, so rpm automatics could rule
246 %{__sed} -i -e '
247         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
248         1s,#!.*bin/env.*python,#!%{__python},
249 ' amarok/src/scripts/*/*.{py,rb} amarok/src/amarok_proxy.rb
250
251 %build
252 cp -f /usr/share/automake/config.sub admin
253 %{__make} -f admin/Makefile.common cvs
254
255 # hack: passing something other than "no" or "yes" to --with-helix allows
256 # us to pass HELIX_LIBS
257 %configure \
258         HELIX_LIBS=%{_libdir}/helixplayer \
259         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
260         --disable-rpath \
261         --with%{!?with_mas:out}-mas \
262         --with%{!?with_xine:out}-xine \
263         --with%{!?with_gstreamer:out}-gstreamer10 \
264         --with%{!?with_akode:out}-akode \
265         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
266         --with%{!?with_nmm:out}-nmm \
267         --with%{!?with_mp3players:out}-libgpod \
268         --with%{!?with_mp3players:out}-libnjb \
269         --with%{!?with_mp3players:out}-libmtp \
270         --with%{!?with_mp3players:out}-ifp \
271         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
272         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
273         --disable-final \
274         --with-mp4v2 \
275         --with-qt-libraries=%{_libdir} \
276         --with%{!?with_included_sqlite:out}-included-sqlite
277
278 %{__make}
279
280 %install
281 rm -rf $RPM_BUILD_ROOT
282
283 %{__make} install \
284         DESTDIR=$RPM_BUILD_ROOT \
285         ruby_rubylibdir=%{ruby_rubylibdir} \
286         kde_htmldir=%{_kdedocdir} \
287         kde_libs_htmldir=%{_kdedocdir}
288
289 # remove bogus dir
290 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
291
292 rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
293 rm $RPM_BUILD_ROOT%{_libdir}/libamarok.{so,la}
294
295 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
296         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
297 %find_lang amarok --all-name --with-kde
298
299 %clean
300 rm -rf $RPM_BUILD_ROOT
301
302 %post -p /sbin/ldconfig
303
304 %postun -p /sbin/ldconfig
305
306 %files -f amarok.lang
307 %defattr(644,root,root,755)
308 %doc AUTHORS ChangeLog README
309 %attr(755,root,root) %{_bindir}/amarok
310 %attr(755,root,root) %{_bindir}/amarokapp
311 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
312 %attr(755,root,root) %{_bindir}/amarok_libvisual
313 # used by last.fm and daap
314 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
315 # used by daap
316 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
317 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
318 %attr(755,root,root) %ghost %{_libdir}/libamarok.so.0
319 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
320 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
321 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
322 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
323 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
324 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
325 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
326 %dir %{_datadir}/apps/amarok
327 %dir %{_datadir}/apps/amarok/scripts
328 %{_datadir}/apps/amarok/*.rc
329 %{_datadir}/apps/amarok/data
330 %{_datadir}/apps/amarok/icons
331 %{_datadir}/apps/amarok/images
332 %{_datadir}/apps/amarok/themes
333 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
334 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
335 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
336 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
337 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
338 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
339 %{_datadir}/apps/profiles/amarok.profile.xml
340 %{_datadir}/config/amarokrc
341 %{_datadir}/config.kcfg/amarok.kcfg
342 %{_datadir}/services/amarok_generic-mediadevice.desktop
343 %{_datadir}/services/amarok_void-engine_plugin.desktop
344 %{_datadir}/services/amarok_daap-mediadevice.desktop
345 %{_datadir}/services/amarok_massstorage-device.desktop
346 %{_datadir}/services/amarok_nfs-device.desktop
347 %{_datadir}/services/amarok_smb-device.desktop
348 %{_datadir}/services/amaroklastfm.protocol
349 %{_datadir}/services/amarokitpc.protocol
350 %{_datadir}/services/amarokpcast.protocol
351 %{_datadir}/servicetypes/amarok_codecinstall.desktop
352 %{_datadir}/servicetypes/amarok_plugin.desktop
353 %{_desktopdir}/kde/amarok.desktop
354 %{_iconsdir}/*/*/apps/amarok.*
355
356 # TODO: move to subpackage
357 %dir %{ruby_rubylibdir}/amarok
358 # used by daap
359 %{ruby_rubylibdir}/amarok/codes.rb
360 # used by daap and lyrics_lyrc
361 %{ruby_rubylibdir}/amarok/debug.rb
362
363 # TODO: move to subpackage
364 %if %{with mp3players}
365 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
366 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
367 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
368 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
369 %{_datadir}/services/amarok_ifp-mediadevice.desktop
370 %{_datadir}/services/amarok_ipod-mediadevice.desktop
371 %{_datadir}/services/amarok_mtp-mediadevice.desktop
372 %{_datadir}/services/amarok_njb-mediadevice.desktop
373 %endif
374
375 %if %{with akode}
376 %files akode
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
379 %{_datadir}/services/amarok_aKode-engine.desktop
380 %endif
381
382 %if %{with gstreamer}
383 %files gstreamer
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
386 %{_datadir}/config.kcfg/gstconfig.kcfg
387 %{_datadir}/services/amarok_gst10engine_plugin.desktop
388 %endif
389
390 %if %{with helix}
391 %files helix
392 %defattr(644,root,root,755)
393 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
394 %{_datadir}/config.kcfg/helixconfig.kcfg
395 %{_datadir}/services/amarok_helixengine_plugin.desktop
396 %endif
397
398 %if %{with xine}
399 %files xine
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
402 %{_datadir}/config.kcfg/xinecfg.kcfg
403 %{_datadir}/services/amarok_xine-engine.desktop
404 %endif
405
406 %if 0
407 %if %{with zeroconf}
408 %files zeroconf
409 %defattr(644,root,root,755)
410 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
411 %endif
412 %endif
413
414 %files scripts
415 %defattr(644,root,root,755)
416 %dir %{_datadir}/apps/amarok/scripts/common
417 %{_datadir}/apps/amarok/scripts/common/Publisher.py
418 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
419
420 %dir %{_datadir}/apps/amarok/scripts/templates
421 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
422 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
423 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
424
425 # amarok searches for executable programs for scripts
426 # to figure out which files need to have execute permission, use this
427 # find command:
428 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
429
430 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
431 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
432 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
433
434 %dir %{_datadir}/apps/amarok/scripts/playlist2html
435 %{_datadir}/apps/amarok/scripts/playlist2html/README
436 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
437 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
438 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
439 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.spec
440 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.spec
441
442
443 %dir %{_datadir}/apps/amarok/scripts/webcontrol
444 %{_datadir}/apps/amarok/scripts/webcontrol/README
445 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
446 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
447 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
448 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
449 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
450 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
451 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
452 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
453 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
454 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
455 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
456 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
457 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
458 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
459 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
460 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
461 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
462 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
463 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
464
465 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
466 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
467 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
468 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
469 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
470
471 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
472 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
473 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
474 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
475 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
476
477 %dir %{_datadir}/apps/amarok/scripts/score_default
478 %{_datadir}/apps/amarok/scripts/score_default/COPYING
479 %{_datadir}/apps/amarok/scripts/score_default/README
480 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
481 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
482 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
483 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
484 %{_datadir}/apps/amarok/scripts/score_impulsive/README
485 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
486 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
487
488 %if 0
489 %dir %{_datadir}/apps/amarok/scripts/amarok_live
490 %{_datadir}/apps/amarok/scripts/amarok_live/README
491 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
492 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
493 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
494 %endif
This page took 0.0548380000000001 seconds and 3 git commands to generate.