]> git.pld-linux.org Git - packages/amanda.git/commitdiff
- reorgnize glib_init to be compatible with glib-2.24+
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 5 May 2010 22:15:58 +0000 (22:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    amanda-glib2.24.patch -> 1.1
    amanda.spec -> 1.196

amanda-glib2.24.patch [new file with mode: 0644]
amanda.spec

diff --git a/amanda-glib2.24.patch b/amanda-glib2.24.patch
new file mode 100644 (file)
index 0000000..a0456ff
--- /dev/null
@@ -0,0 +1,54 @@
+--- amanda/trunk/common-src/glib-util.c        2009/10/16 22:06:51     2182
++++ amanda/trunk/common-src/glib-util.c        2010/05/03 21:42:31     2982
+@@ -1,5 +1,5 @@
+ /*
+- * Copyright (c) 2007,2008,2009 Zmanda, Inc.  All Rights Reserved.
++ * Copyright (c) 2007, 2008, 2009, 2010 Zmanda, Inc.  All Rights Reserved.
+  *
+  * This program is free software; you can redistribute it and/or modify it
+  * under the terms of the GNU General Public License version 2 as published
+@@ -38,26 +38,15 @@
+     if (did_glib_init) return;
+     did_glib_init = TRUE;
+-    /* Initialize glib's type system */
+-    g_type_init();
+-
+     /* set up libcurl (this must happen before threading 
+      * is initialized) */
+ #ifdef HAVE_LIBCURL
+ # ifdef G_THREADS_ENABLED
+-    g_assert(!g_thread_supported());
++    g_assert(!g_thread_supported()); /* assert threads aren't initialized yet */
+ # endif
+     g_assert(curl_global_init(CURL_GLOBAL_ALL) == 0);
+ #endif
+-    /* And set up glib's threads */
+-#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
+-    if (g_thread_supported()) {
+-        return;
+-    }
+-    g_thread_init(NULL);
+-#endif
+-
+     /* do a version check */
+ #if GLIB_CHECK_VERSION(2,6,0)
+     {
+@@ -71,6 +60,16 @@
+       }
+     }
+ #endif
++
++    /* Initialize glib's type system.  On glib >= 2.24, this will initialize
++     * threads, so it must be done after curl is initialized. */
++    g_type_init();
++
++    /* And set up glib's threads */
++#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
++    if (!g_thread_supported())
++      g_thread_init(NULL);
++#endif
+ }
+ typedef enum {
index 4cfba96b8969eba110e4e2d1d62cc54f2a661741..b31a297812e266fcd626fb4701b7b235f082c0bd 100644 (file)
@@ -10,7 +10,7 @@ Summary:      A network-capable tape backup solution
 Summary(pl.UTF-8):     Sieciowo zorientowany system tworzenia kopii zapasowych
 Name:          amanda
 Version:       2.6.1p2
-Release:       1
+Release:       1.1
 License:       BSD
 Group:         Networking/Utilities
 Source0:       http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
@@ -28,6 +28,7 @@ Patch5:               %{name}-tapetypes.patch
 Patch6:                %{name}-FHS.patch
 Patch7:                %{name}-no-buildtime-ipv6.patch
 Patch8:                %{name}-heimdal.patch
+Patch9:                %{name}-glib2.24.patch
 URL:           http://www.amanda.org/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
@@ -192,6 +193,7 @@ typu streamer).
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 %build
 %{__aclocal} -I config -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
This page took 0.099452 seconds and 4 git commands to generate.