]> git.pld-linux.org Git - packages/alsa-plugins.git/commitdiff
- fix building with ffmpeg 3.x auto/th/alsa-plugins-1.1.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 21 Mar 2016 11:28:38 +0000 (12:28 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 21 Mar 2016 11:28:38 +0000 (12:28 +0100)
- rel 2

alsa-plugins.spec
ffmpeg3.patch [new file with mode: 0644]

index 0413390cbaa4c5dd99161b75344aebccb6c6f62f..c3038095ec8f64df90a349961b6ffc155a98e4d1 100644 (file)
@@ -2,12 +2,13 @@ Summary:      Advanced Linux Sound Architecture - plugins
 Summary(pl.UTF-8):     Advanced Linux Sound Architecture - wtyczki
 Name:          alsa-plugins
 Version:       1.1.0
-Release:       1
+Release:       2
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       ftp://ftp.alsa-project.org/pub/plugins/%{name}-%{version}.tar.bz2
 # Source0-md5: b123e42ed881b9adbc99e4040f257c39
 Source1:       %{name}-pulse.conf
+Patch0:                ffmpeg3.patch
 URL:           http://www.alsa-project.org/
 BuildRequires: alsa-lib-devel >= 1.0.18
 BuildRequires: automake
@@ -194,6 +195,7 @@ Wtyczka wejścia-wyjścia PCM usb_stream dla systemu ALSA.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 cp -f /usr/share/automake/config.sub .
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
new file mode 100644 (file)
index 0000000..3adf1d7
--- /dev/null
@@ -0,0 +1,29 @@
+--- alsa-plugins-1.1.0/a52/pcm_a52.c.orig      2015-10-27 14:34:06.000000000 +0100
++++ alsa-plugins-1.1.0/a52/pcm_a52.c   2016-03-21 12:25:16.452315942 +0100
+@@ -39,7 +39,7 @@
+ #endif
+ #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(53, 34, 0)
+-#include <libavutil/audioconvert.h>
++//#include <libavutil/audioconvert.h>
+ #include <libavutil/mem.h>
+ #define USE_AVCODEC_FRAME
+ #endif
+@@ -513,7 +513,7 @@
+               rec->inbuf = NULL;
+       }
+ #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(54, 28, 0)
+-      avcodec_free_frame(&rec->frame);
++      av_frame_free(&rec->frame);
+ #else
+       av_freep(&rec->frame);
+ #endif
+@@ -557,7 +557,7 @@
+ {
+       struct a52_ctx *rec = io->private_data;
+ #ifdef USE_AVCODEC_FRAME
+-      rec->frame = avcodec_alloc_frame();
++      rec->frame = av_frame_alloc();
+       if (!rec->frame)
+               return -ENOMEM;
+       if (av_samples_alloc(rec->frame->data, rec->frame->linesize,
This page took 0.097983 seconds and 4 git commands to generate.