]> git.pld-linux.org Git - packages/alsa-patch-bay.git/blob - alsa-patch-bay.spec
- relative symlink within one directory
[packages/alsa-patch-bay.git] / alsa-patch-bay.spec
1 #
2 # Conditional build:
3 %bcond_without  fltk    # without FLTK UI
4 %bcond_without  gtkmm   # without gtkmm UI
5 %bcond_without  ladcca  # with ladcca support
6 #
7 Summary:        Graphical patch bay for the ALSA sequencer and JACK
8 Summary(pl.UTF-8):      Graficzny interfejs dla sekwencera ALSY i JACK-a
9 Name:           alsa-patch-bay
10 Version:        1.0.0
11 Release:        3
12 License:        GPL
13 Group:          X11/Applications/Sound
14 Source0:        http://pkl.net/~node/software/%{name}-%{version}.tar.gz
15 # Source0-md5:  3aa458f6bee8b83b2cf7330707d72430
16 Patch0:         %{name}-Makefile.patch
17 Patch1:         %{name}-desktop_pl.patch
18 Patch2:         %{name}-missing_m4.patch
19 Patch3:         %{name}-pic.patch
20 Patch4:         %{name}-make-jN.patch
21 Patch5:         %{name}-ac.patch
22 URL:            http://pkl.net/~node/alsa-patch-bay.html
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_fltk:BuildRequires:     fltk-devel >= 1.1}
26 %{?with_gtkmm:BuildRequires:    gtkmm22-devel}
27 BuildRequires:  jack-audio-connection-kit-devel >= 0.80.0
28 %{?with_ladcca:BuildRequires:   ladcca-devel}
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 Requires:       %{name}-ui = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 ALSA Patch Bay is a GUI patchbay for the ALSA sequencer and
36 the JACK audio subsystems. In easy way connects ports of MIDI and
37 audio devices like sequencer, external keyboard, soft synth and
38 many others.
39
40 %description -l pl.UTF-8
41 ALSA Patch Bay to graficzny interfejs dla podsystemów sequencera
42 ALSY oraz dźwiękowego JACK-a. W łatwy sposób łączy porty urządzeń
43 MIDI i audio jak sekwencer, zewnętrzne klawisze, synteza programowa
44 i wiele innych.
45
46 %package driver-alsa
47 Summary:        ALSA audio driver for ALSA Patch Bay
48 Summary(pl.UTF-8):      Sterownik dźwięku ALSA dla ALSA Patch Bay
49 Group:          X11/Applications/Sound
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       %{name}-ui = %{version}-%{release}
52
53 %description driver-alsa
54 ALSA audio driver for ALSA Patch Bay.
55
56 %description driver-alsa -l pl.UTF-8
57 Sterownik dźwięku ALSA dla ALSA Patch Bay.
58
59 %package driver-jack
60 Summary:        JACK audio driver for ALSA Patch Bay
61 Summary(pl.UTF-8):      Sterownik dźwięku JACK-a dla ALSA Patch Bay
62 Group:          X11/Applications/Sound
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       %{name}-driver-alsa = %{version}-%{release}
65 Requires:       %{name}-ui = %{version}-%{release}
66 Provides:       jack-patch-bay
67
68 %description driver-jack
69 JACK audio driver for ALSA Patch Bay.
70
71 %description driver-jack -l pl.UTF-8
72 Sterownik dźwięku JACK-a dla ALSA Patch Bay.
73
74 %package ui-fltk
75 Summary:        FLTK-based GUI for ALSA Patch Bay
76 Summary(pl.UTF-8):      Oparte na FLTK GUI do ALSA Patch Bay
77 Group:          X11/Applications/Sound
78 Requires:       %{name} = %{version}-%{release}
79 Provides:       %{name}-ui = %{version}-%{release}
80
81 %description ui-fltk
82 FLTK-based graphical user interface for ALSA Patch Bay.
83
84 %description ui-fltk -l pl.UTF-8
85 Oparty na FLTK graficzny interfejs użytkownika do ALSA Patch Bay.
86
87 %package ui-gtkmm
88 Summary:        GTKmm-based GUI for ALSA Patch Bay
89 Summary(pl.UTF-8):      Oparte na GTKmm GUI do ALSA Patch Bay
90 Group:          X11/Applications/Sound
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       gtkmm22
93 Provides:       %{name}-ui = %{version}-%{release}
94
95 %description ui-gtkmm
96 GTKmm-based GUI for ALSA Patch Bay.
97
98 %description ui-gtkmm -l pl.UTF-8
99 Oparte na GTKmm GUI do ALSA Patch Bay.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108 %patch5 -p1
109
110 %build
111 %{__libtoolize}
112 %{__autoheader}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__automake}
116 %configure \
117         %{!?with_fltk:--disable-fltk --disable-fltk-test} \
118         %{!?with_gtkmm:--disable-gtkmm} \
119         %{!?with_ladcca:--disable-ladcca} \
120         --disable-static
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 ln -sf alsa-patch-bay $RPM_BUILD_ROOT%{_bindir}/jack-patch-bay
131
132 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/ui/*.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc NEWS AUTHORS README
140 %dir %{_libdir}/%{name}
141 %dir %{_libdir}/%{name}/driver
142 %dir %{_libdir}/%{name}/ui
143 %{_pixmapsdir}/*.png
144
145 %files driver-alsa
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/alsa-patch-bay
148 %attr(755,root,root) %{_libdir}/%{name}/driver/alsa.so
149 %{_desktopdir}/alsa-patch-bay.desktop
150
151 %files driver-jack
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/jack-patch-bay
154 %attr(755,root,root) %{_libdir}/%{name}/driver/jack.so
155 %{_desktopdir}/jack-patch-bay.desktop
156
157 %if %{with fltk}
158 %files ui-fltk
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/%{name}/ui/fltk.so
161 %endif
162
163 %if %{with gtkmm}
164 %files ui-gtkmm
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/%{name}/ui/gtkmm.so
167 %endif
This page took 0.111065 seconds and 3 git commands to generate.