]> git.pld-linux.org Git - packages/alsa-patch-bay.git/blob - alsa-patch-bay.spec
- BRs updated, ladcca by default on, rel.1
[packages/alsa-patch-bay.git] / alsa-patch-bay.spec
1 #
2 # Conditional build:
3 %bcond_without  fltk    # without FLTK UI
4 %bcond_without  gtkmm   # without gtkmm UI
5 %bcond_without  ladcca  # with ladcca support
6 #
7 Summary:        Graphical patch bay for the ALSA sequencer and JACK
8 Summary(pl):    Graficzny interfejs dla sekwencera ALSY i JACK-a
9 Name:           alsa-patch-bay
10 Version:        1.0.0
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Sound
14 Source0:        http://pkl.net/~node/software/%{name}-%{version}.tar.gz
15 # Source0-md5:  3aa458f6bee8b83b2cf7330707d72430
16 Patch0:         %{name}-Makefile.patch
17 Patch1:         %{name}-desktop_pl.patch
18 Patch2:         %{name}-missing_m4.patch
19 URL:            http://pkl.net/~node/alsa-patch-bay.html
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_fltk:BuildRequires:     fltk-devel >= 1.1}
23 %{?with_gtkmm:BuildRequires:    gtkmm22-devel}
24 BuildRequires:  jack-audio-connection-kit-devel >= 0.80.0
25 %{?with_ladcca:BuildRequires:   ladcca-devel}
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 Requires:       %{name}-ui = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 ALSA Patch Bay is a GUI patchbay for the ALSA sequencer and
33 the JACK audio subsystems. In easy way connects ports of MIDI and
34 audio devices like sequencer, external keyboard, soft synth and
35 many others.
36
37 %description -l pl
38 ALSA Patch Bay to graficzny interfejs dla podsystemów sequencera
39 ALSY oraz d¼wiêkowego JACK-a. W ³atwy sposób ³±czy porty urz±dzeñ
40 MIDI i audio jak sekwencer, zewnêtrzne klawisze, synteza programowa
41 i wiele innych.
42
43 %package driver-alsa
44 Summary:        ALSA audio driver for ALSA Patch Bay
45 Summary(pl):    Sterownik d¼wiêku ALSA dla ALSA Patch Bay
46 Group:          X11/Applications/Sound
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       %{name}-ui = %{version}-%{release}
49
50 %description driver-alsa
51 ALSA audio driver for ALSA Patch Bay.
52
53 %description driver-alsa -l pl
54 Sterownik d¼wiêku ALSA dla ALSA Patch Bay.
55
56 %package driver-jack
57 Summary:        JACK audio driver for ALSA Patch Bay
58 Summary(pl):    Sterownik d¼wiêku JACK-a dla ALSA Patch Bay
59 Group:          X11/Applications/Sound
60 Provides:       jack-patch-bay
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       %{name}-driver-alsa = %{version}-%{release}
63 Requires:       %{name}-ui = %{version}-%{release}
64
65 %description driver-jack
66 JACK audio driver for ALSA Patch Bay.
67
68 %description driver-jack -l pl
69 Sterownik d¼wiêku JACK-a dla ALSA Patch Bay.
70
71 %package ui-fltk
72 Summary:        FLTK-based GUI for ALSA Patch Bay
73 Summary(pl):    Oparte na FLTK GUI do ALSA Patch Bay
74 Group:          X11/Applications/Sound
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-ui = %{version}-%{release}
77
78 %description ui-fltk
79 FLTK-based graphical user interface for ALSA Patch Bay.
80
81 %description ui-fltk -l pl
82 Oparty na FLTK graficzny interfejs u¿ytkownika do ALSA Patch Bay.
83
84 %package ui-gtkmm
85 Summary:        GTKmm-based GUI for ALSA Patch Bay
86 Summary(pl):    Oparte na GTKmm GUI do ALSA Patch Bay
87 Group:          X11/Applications/Sound
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       gtkmm22
90 Provides:       %{name}-ui = %{version}-%{release}
91
92 %description ui-gtkmm
93 GTKmm-based GUI for ALSA Patch Bay.
94
95 %description ui-gtkmm -l pl
96 Oparte na GTKmm GUI do ALSA Patch Bay.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 %build
105 %{__libtoolize}
106 %{__autoheader}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__automake}
110 %configure \
111         %{!?with_fltk:--disable-fltk --disable-fltk-test} \
112         %{!?with_gtkmm:--disable-gtkmm} \
113         %{!?with_ladcca:--disable-ladcca}
114         
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc NEWS AUTHORS README
129 %dir %{_libdir}/%{name}
130 %dir %{_libdir}/%{name}/driver
131 %dir %{_libdir}/%{name}/ui
132 %{_pixmapsdir}/*.png
133
134 %files driver-alsa
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/alsa-patch-bay
137 %attr(755,root,root) %{_libdir}/%{name}/driver/alsa.so
138 %{_desktopdir}/alsa-patch-bay.desktop
139
140 %files driver-jack
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/jack-patch-bay
143 %attr(755,root,root) %{_libdir}/%{name}/driver/jack.so
144 %{_desktopdir}/jack-patch-bay.desktop
145
146 %if %{with fltk}
147 %files ui-fltk
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/%{name}/ui/fltk.so
150 %endif
151
152 %if %{with gtkmm}
153 %files ui-gtkmm
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/%{name}/ui/gtkmm.so
156 %endif
This page took 0.130453 seconds and 3 git commands to generate.