]> git.pld-linux.org Git - packages/alsa-patch-bay.git/blob - alsa-patch-bay.spec
- 1.0.0
[packages/alsa-patch-bay.git] / alsa-patch-bay.spec
1 #
2 # Conditional build:
3 %bcond_without fltk     # without FLTK UI
4 %bcond_without gtkmm    # without gtkmm UI
5 %bcond_with ladcca      # with ladcca support
6 #
7 Summary:        Graphical patch bay for the ALSA sequencer and JACK
8 Summary(pl):    Graficzny interfejs dla sekwencera ALSY i JACKa
9 Name:           alsa-patch-bay
10 Version:        1.0.0
11 Release:        0.1
12 License:        GPL
13 Group:          X11/Applications/Sound
14 Source0:        http://pkl.net/~node/software/%{name}-%{version}.tar.gz
15 # Source0-md5:  3aa458f6bee8b83b2cf7330707d72430
16 Patch0:         %{name}-Makefile.patch
17 Patch1:         %{name}-desktop_pl.patch
18 Patch2:         %{name}-missing_m4.patch
19 URL:            http://pkl.net/~node/alsa-patch-bay.html
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_fltk:BuildRequires:     fltk-devel >= 1.1}
23 %{?with_gtkmm:BuildRequires:    gtkmm-devel >= 2.0.0}
24 BuildRequires:  jack-audio-connection-kit-devel >= 0.80.0
25 %{?with_ladcca:BuildRequires:   ladcca-devel}
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 Requires:       %{name}-ui
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 ALSA Patch Bay is a GUI patchbay for the ALSA sequencer and
33 the JACK audio subsystems. In easy way connects ports of MIDI and
34 audio devices like sequencer, external keyboard, soft synth and
35 many others.
36
37 %description -l pl
38 ALSA Patch Bay to graficzny interfejs dla podsystemów sequencera
39 ALSY oraz d¼wiêkowego JACKa. W ³atwy sposób ³±czy porty urz±dzeñ
40 MIDI i audio jak sekwencer, zewnêtrzne klawisze, synteza programowa
41 i wiele innych.
42
43 %package driver-alsa
44 Summary:        ALSA audio driver for ALSA Patch Bay
45 Summary(pl):    Sterownik d¼wiêku ALSA dla ALSA Patch Bay
46 Group:          X11/Applications/Sound
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       %{name}-ui
49
50 %description driver-alsa
51 ALSA audio driver for ALSA Patch Bay.
52
53 %description driver-alsa -l pl
54 Sterownik d¼wiêku ALSA dla ALSA Patch Bay.
55
56 %package driver-jack
57 Summary:        JACK audio driver for ALSA Patch Bay
58 Summary(pl):    Sterownik d¼wiêku JACK dla ALSA Patch Bay
59 Group:          X11/Applications/Sound
60 Provides:       jack-patch-bay
61 Requires:       %{name}-driver-alsa
62 Requires:       %{name}-ui
63 Requires:       %{name} = %{version}-%{release}
64
65 %description driver-jack
66 JACK audio driver for ALSA Patch Bay.
67
68 %description driver-jack -l pl
69 Sterownik d¼wiêku JACK dla ALSA Patch Bay.
70
71 %package ui-fltk
72 Summary:        FLTK-based GUI for ALSA Patch Bay
73 Summary(pl):    Oparte na FLTK GUI do ALSA Patch Bay
74 Group:          X11/Applications/Sound
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-ui
77
78 %description ui-fltk
79 FLTK-based graphical user interface for ALSA Patch Bay.
80
81 %description ui-fltk -l pl
82 Oparty na FLTK graficzny interfejs u¿ytkownika do ALSA Patch Bay.
83
84 %package ui-gtkmm
85 Summary:        GTKmm-based GUI for ALSA Patch Bay
86 Summary(pl):    Oparte na GTKmm GUI do ALSA Patch Bay
87 Group:          X11/Applications/Sound
88 Requires:       %{name} = %{version}-%{release}
89 Provides:       %{name}-ui
90
91 %description ui-gtkmm
92 GTKmm-based GUI for ALSA Patch Bay.
93
94 %description ui-gtkmm -l pl
95 Oparte na GTKmm GUI do ALSA Patch Bay.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102
103 %build
104 %{__libtoolize}
105 %{__autoheader}                                                                 
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__automake}
109 %configure \
110         %{!?with_fltk:--disable-fltk --disable-fltk-test} \
111         %{!?with_gtkmm:--disable-gtkmm} \
112         %{?without_ladcca:--disable-ladcca} \
113         
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc NEWS AUTHORS README
128 %dir %{_libdir}/%{name}
129 %dir %{_libdir}/%{name}/driver
130 %dir %{_libdir}/%{name}/ui
131 %{_pixmapsdir}/*.png
132
133 %files driver-alsa
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/alsa-patch-bay
136 %attr(755,root,root) %{_libdir}/%{name}/driver/alsa.so
137 %{_desktopdir}/alsa-patch-bay.desktop
138
139 %files driver-jack
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/jack-patch-bay
142 %attr(755,root,root) %{_libdir}/%{name}/driver/jack.so
143 %{_desktopdir}/jack-patch-bay.desktop
144
145 %if %{with fltk}
146 %files ui-fltk
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/%{name}/ui/fltk.so
149 %endif
150
151 %if %{with gtkmm}
152 %files ui-gtkmm
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/%{name}/ui/gtkmm.so
155 %endif
This page took 0.080279 seconds and 3 git commands to generate.