]> git.pld-linux.org Git - packages/alsa-lib.git/commitdiff
- gcc4 fix. auto/th/alsa-lib-1_0_8-3
authorPaweł Sikora <pluto@pld-linux.org>
Tue, 3 May 2005 12:58:10 +0000 (12:58 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    alsa-lib-gcc4.patch -> 1.1
    alsa-lib.spec -> 1.111

alsa-lib-gcc4.patch [new file with mode: 0644]
alsa-lib.spec

diff --git a/alsa-lib-gcc4.patch b/alsa-lib-gcc4.patch
new file mode 100644 (file)
index 0000000..fcf656b
--- /dev/null
@@ -0,0 +1,40 @@
+--- alsa-lib-1.0.8/src/pcm/pcm_dmix.c.orig     2005-01-11 18:42:49.000000000 +0100
++++ alsa-lib-1.0.8/src/pcm/pcm_dmix.c  2005-05-03 14:47:10.000000000 +0200
+@@ -53,12 +53,13 @@
+  *
+  */
++static int shm_sum_discard(snd_pcm_direct_t *dmix);
++
+ /*
+  *  sum ring buffer shared memory area 
+  */
+ static int shm_sum_create_or_connect(snd_pcm_direct_t *dmix)
+ {
+-      static int shm_sum_discard(snd_pcm_direct_t *dmix);
+       struct shmid_ds buf;
+       int tmpid, err;
+       size_t size;
+--- alsa-lib-1.0.8/src/conf.c.orig     2004-10-05 17:33:04.000000000 +0200
++++ alsa-lib-1.0.8/src/conf.c  2005-05-03 14:53:20.000000000 +0200
+@@ -2494,9 +2494,11 @@
+  *               specified by \p result.
+  * \return Zero if successful, otherwise a negative error code.
+  */
++
++static int snd_config_hooks(snd_config_t *config, snd_config_t *private_data);
++
+ int snd_config_search_hooks(snd_config_t *config, const char *key, snd_config_t **result)
+ {
+-      static int snd_config_hooks(snd_config_t *config, snd_config_t *private_data);
+       SND_CONFIG_SEARCH(config, key, result, \
+                                       err = snd_config_hooks(config, NULL); \
+                                       if (err < 0) \
+@@ -2516,7 +2518,6 @@
+  */
+ int snd_config_searcha_hooks(snd_config_t *root, snd_config_t *config, const char *key, snd_config_t **result)
+ {
+-      static int snd_config_hooks(snd_config_t *config, snd_config_t *private_data);
+       SND_CONFIG_SEARCHA(root, config, key, result,
+                                       snd_config_searcha_hooks,
+                                       err = snd_config_hooks(config, NULL); \
index 0382484d55b4f4d1d74a1f955ad107658fe3a15c..f9bcf884b4c10b7c2d9fe141e5b6b70a5c265ba3 100644 (file)
@@ -6,12 +6,13 @@ Summary(ru):  
 Summary(uk):   â¦Â̦ÏÔÅËÁ API ÄÌÑ ÒÏÂÏÔÉ Ú ÄÒÁÊ×ÅÒÏÍ ALSA
 Name:          alsa-lib
 Version:       1.0.8
-Release:       2
+Release:       3
 License:       LGPL
 Group:         Libraries
 Source0:       ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.bz2
 # Source0-md5: c677299ed39d069c9a4b6a999e34ffe7
 Patch0:                %{name}-alpha.patch
+Patch1:                %{name}-gcc4.patch
 URL:           http://www.alsa-project.org/
 BuildRequires: alsa-driver-devel
 BuildRequires: autoconf
@@ -154,6 +155,7 @@ Bibliotecas est
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.052833 seconds and 4 git commands to generate.