]> git.pld-linux.org Git - packages/alpine.git/commitdiff
- fix errors introduced by -Werror-security auto/th/alpine-2.00.84-9 auto/ti/alpine-2.00.84-9
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 7 Dec 2012 07:21:13 +0000 (08:21 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 7 Dec 2012 07:21:13 +0000 (08:21 +0100)
- rel 9

alpine.spec
format-security.patch [new file with mode: 0644]

index ab191b8f79884a0b37ae8a1966a169ea430f5f33..48ca8eef9141c86b4fedc3f91fccde40e3263da0 100644 (file)
@@ -10,7 +10,7 @@ Summary:      University of Washington Alpine mail user agent
 Summary(pl.UTF-8):     Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
 Name:          alpine
 Version:       %{ver}.%{patchlevel}
-Release:       8
+Release:       9
 Epoch:         1
 License:       Apache v2.0
 Group:         Applications/Mail
@@ -33,6 +33,7 @@ Patch7:               %{name}-home_etc.patch
 Patch8:                %{name}-RFC1522_MAXW.patch
 Patch9:                mimedesc.patch
 Patch10:       re-alpine-2.01.smime-signandencrypt.patch
+Patch11:       format-security.patch
 URL:           http://www.washington.edu/alpine/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -136,6 +137,7 @@ ajuda de acordo com o contexto está disponível.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 %build
 rm -f libtool missing
diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..d4f73d4
--- /dev/null
@@ -0,0 +1,33 @@
+--- alpine-2.00/pith/ldap.c~   2008-04-08 00:58:40.000000000 +0200
++++ alpine-2.00/pith/ldap.c    2012-12-07 08:16:50.304560842 +0100
+@@ -778,7 +778,7 @@
+        */
+       switch(args){
+         case 0:
+-          snprintf(filter, sizeof(filter), filt_format);
++          snprintf(filter, sizeof(filter), "%s", filt_format);
+           break;
+         case 1:
+           snprintf(filter, sizeof(filter), filt_format, scp);
+--- alpine-2.00/imap/src/osdep/unix/flocklnx.c~        2008-06-04 20:18:34.000000000 +0200
++++ alpine-2.00/imap/src/osdep/unix/flocklnx.c 2012-12-07 08:13:57.761233591 +0100
+@@ -57,7 +57,7 @@
+     case ENOLCK:              /* lock table is full */
+       sprintf (tmp,"File locking failure: %s",strerror (errno));
+       mm_log (tmp,WARN);      /* give the user a warning of what happened */
+-      if (!logged++) syslog (LOG_ERR,tmp);
++      if (!logged++) syslog (LOG_ERR,"File locking failure: %s",strerror (errno));
+                               /* return failure if non-blocking lock */
+       if (op & LOCK_NB) return -1;
+       sleep (5);              /* slow down in case it loops */
+--- alpine-2.00/alpine/mailcmd.c~      2011-02-08 05:34:16.000000000 +0100
++++ alpine-2.00/alpine/mailcmd.c       2012-12-07 08:18:38.574557022 +0100
+@@ -7963,7 +7963,7 @@
+             case 13 :                 /* Match my addresses */
+               me++;
+-              snprintf(sstring, sizeof(sstring), not ? _(dont_match_me) : _(match_me));
++              snprintf(sstring, sizeof(sstring), "%s", not ? _(dont_match_me) : _(match_me));
+               continue;
+             case 14 :                 /* Subject: default */
This page took 0.400786 seconds and 4 git commands to generate.