]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- cleanups in patches
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 Summary:        University of Washington Pine mail user agent
6 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
7 Name:           alpine
8 %define         ver             0.99999
9 %define         patchlevel      4
10 Version:        %{ver}.%{patchlevel}
11 Release:        0.1
12 Epoch:          1
13 License:        Apache License 2.0
14 Group:          Applications/Mail
15 # Main site:
16 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17 # Source with applied patches from http://staff.washington.edu/chappa/alpine/ 
18 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19 # Source0-md5:  055a67734af8190a709949f40211c3ed
20 Source1:        pico.desktop
21 Source2:        %{name}.desktop
22 Source3:        %{name}.png
23 Patch0:         %{name}-index_display.patch
24 Patch1:         %{name}-doc.patch
25 Patch2:         %{name}-filter.patch
26 Patch3:         %{name}-quote.patch
27 Patch4:         %{name}-fhs.patch
28 Patch5:         %{name}-segfix.patch
29 Patch6:         %{name}-libc-client.patch
30 Patch7:         %{name}-fixhome.patch
31 Patch8:         %{name}-ssl.patch
32 Patch9:         %{name}-no_1777_warning.patch
33 Patch10:        %{name}-home_etc.patch
34 URL:            http://www.washington.edu/alpine/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  home-etc-devel
38 BuildRequires:  krb5-devel
39 BuildRequires:  ncurses-devel
40 BuildRequires:  openldap-devel >= 2.4.6
41 BuildRequires:  openssl-devel
42 BuildRequires:  pam-devel
43 # Only for web-frontend:
44 #BuildRequires: tcl-devel
45 Obsoletes:      pine
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         alpineconfdir   /etc/%{name}
49 %define         filterout_ld    -Wl,--as-needed
50
51 %description
52 Alpine -- an Alternatively Licensed Program for Internet News & Email
53 -- is a tool for reading, sending, and managing electronic messages.
54 Alpine is the successor to Pine and was developed by Computing &
55 Communications at the University of Washington. Though originally
56 designed for inexperienced email users, Alpine supports many advanced
57 features, and an ever-growing number of configuration and
58 personal-preference options.
59
60 %description -l pl.UTF-8
61 Alpine, czyli Alternatively Licensed Program for Internet News & Email
62 (alternatywnie licencjonowany program do newsów i poczty internetowej)
63 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
64 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
65 wydział Computing & Communications (Obliczeń i komunikacji) na
66 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
67 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
68 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
69 ciągle rośnie.
70
71 %package -n pico
72 Summary:        Simple text editor in the style of the Pine Composer
73 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
74 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
75 Group:          Applications/Editors
76
77 %description -n pico
78 Pico is a simple, display-oriented text editor based on the Alpine
79 message system composer. As with Pine, commands are displayed at the
80 bottom of the screen, and context-sensitive help is provided. As
81 characters are typed they are immediately inserted into the text.
82
83 %description -n pico -l pl.UTF-8
84 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
85 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
86 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
87 włączane do tekstu.
88
89 %description -n pico -l pt_BR.UTF-8
90 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
91 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
92 e ajuda de acordo com o contexto está disponível.
93
94 %package -n pilot
95 Summary:        Simple file system browser in the style of the Alpine Composer
96 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
97 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
98 Group:          Applications/Shells
99
100 %description -n pilot
101 Pilot is a simple, display-oriented file system browser based on the
102 Alpine message system composer. As with Alpine, commands are displayed at
103 the bottom of the screen, and context-sensitive help is provided.
104
105 %description -n pilot -l pl.UTF-8
106 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
107 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
108 dole ekranu oraz jest dostępna pomoc kontekstowa.
109
110 %description -n pilot -l pt_BR.UTF-8
111 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
112 como no Pine, comandos são apresentados na parte de baixo da tela, e
113 ajuda de acordo com o contexto está disponível.
114
115 %prep
116 %setup -q -n %{name}-%{ver}
117 %patch0 -p1
118 %patch1 -p1
119 %patch2 -p1
120 %patch3 -p1
121 %patch4 -p1
122 %patch5 -p1
123 %patch6 -p1
124 %patch7 -p1
125 %patch8 -p1
126 %patch9 -p1
127 %patch10 -p1
128
129 %build
130 rm -f libtool missing
131 %{__libtoolize}
132 %{__aclocal} -I m4
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         --enable-quotas \
138         --without-tcl \
139         --with-smtp-msa=%{_libdir}/sendmail \
140         --with-spellcheck-prog=aspell \
141         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
142         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
143         --with-krb5-dir=%{_prefix} \
144         --with-ldap-dir=%{_prefix} \
145         --with-system-mail-directory=/var/mail \
146         --with-passfile=.pine.pwd
147
148 %{__make} \
149         GCCOPTLEVEL="%{rpmcflags}"
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
159 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
160 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
161
162 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
163
164 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
165 cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
166 #
167 # Alpine system-wide enforced configuration file - customize as needed
168 #
169 # This file holds the system-wide enforced values for alpine configuration
170 # settings. Any values set in it will override values set in the
171 # system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
172 # the user's own configuration file (~/.pinerc).
173 # For more information on the format of this file, read the
174 # comments at the top of %{alpineconfdir}/alpine.conf
175
176 EOF
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %files
182 %defattr(644,root,root,755)
183 %doc README doc/tech-notes.txt
184 %dir %{alpineconfdir}
185 %config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
186 %config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
187 %attr(755,root,root) %{_bindir}/%{name}
188 %attr(755,root,root) %{_bindir}/pine
189 %attr(755,root,root) %{_bindir}/rpload
190 %attr(755,root,root) %{_bindir}/rpdump
191 %{_mandir}/man1/%{name}.1*
192 %{_mandir}/man1/rpload.1*
193 %{_mandir}/man1/rpdump.1*
194 %{_desktopdir}/%{name}.desktop
195 %{_pixmapsdir}/%{name}.png
196
197 %files -n pico
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/pico
200 %{_desktopdir}/pico.desktop
201 %{_mandir}/man1/pico*
202
203 %files -n pilot
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_bindir}/pilot
206 %{_mandir}/man1/pilot*
This page took 0.083349 seconds and 4 git commands to generate.