]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- regenerate ac/am
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - alpine should obsolete pine, link pine -> alpine should be made
4 # - pine -> alpine config converter
5 # - review patches from pine:
6 #   - home_etc support
7 #   - ....many more
8 Summary:        University of Washington Pine mail user agent
9 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
10 Name:           alpine
11 Version:        0.999
12 Release:        0.4
13 Epoch:          1
14 License:        Apache License 2.0
15 Group:          Applications/Mail
16 Source0:        ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17 # Source0-md5:  082de388a998c1faa2385ebdfd6800f5
18 Source1:        pico.desktop
19 # http://staff.washington.edu/chappa/alpine/info/all.html
20 Patch0:         http://staff.washington.edu/chappa/alpine/patches/%{name}-%{version}/all.patch.gz
21 URL:            http://www.washington.edu/alpine
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  krb5-devel
25 BuildRequires:  ncurses-devel
26 BuildRequires:  openldap-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  pam-devel
29 BuildRequires:  tcl-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         alpineconfdir   /etc/%{name}
33
34 %description
35 Alpine -- an Alternatively Licensed Program for Internet News & Email
36 -- is a tool for reading, sending, and managing electronic messages.
37 Alpine is the successor to Pine and was developed by Computing &
38 Communications at the University of Washington. Though originally
39 designed for inexperienced email users, Alpine supports many advanced
40 features, and an ever-growing number of configuration and
41 personal-preference options.
42
43 %description -l pl.UTF-8
44 Alpine, czyli Alternatively Licensed Program for Internet News & Email
45 (alternatywnie licencjonowany program do newsów i poczty internetowej)
46 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
47 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
48 wydział Computing & Communications (Obliczeń i komunikacji) na
49 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
50 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
51 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
52 ciągle rośnie.
53
54 %package -n pico
55 Summary:        Simple text editor in the style of the Pine Composer
56 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
57 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
58 Group:          Applications/Editors
59
60 %description -n pico
61 Pico is a simple, display-oriented text editor based on the Alpine
62 message system composer. As with Pine, commands are displayed at the
63 bottom of the screen, and context-sensitive help is provided. As
64 characters are typed they are immediately inserted into the text.
65
66 %description -n pico -l pl.UTF-8
67 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
68 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
69 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
70 włączane do tekstu.
71
72 %description -n pico -l pt_BR.UTF-8
73 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
74 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
75 e ajuda de acordo com o contexto está disponível.
76
77 %package -n pilot
78 Summary:        Simple file system browser in the style of the Alpine Composer
79 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
80 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
81 Group:          Applications/Shells
82
83 %description -n pilot
84 Pilot is a simple, display-oriented file system browser based on the
85 Alpine message system composer. As with Alpine, commands are displayed at
86 the bottom of the screen, and context-sensitive help is provided.
87
88 %description -n pilot -l pl.UTF-8
89 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
90 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
91 dole ekranu oraz jest dostępna pomoc kontekstowa.
92
93 %description -n pilot -l pt_BR.UTF-8
94 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
95 como no Pine, comandos são apresentados na parte de baixo da tela, e
96 ajuda de acordo com o contexto está disponível.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 %build
103 %{__autoconf}
104 %{__aclocal} -I m4
105 %{__automake}
106 %configure \
107         --enable-quotas \
108         --with-smtp-msa=%{_libdir}/sendmail \
109         --with-spellcheck-prog=aspell \
110         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
111         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
112         --with-krb5-dir=%{_prefix} \
113         --with-ldap-dir=%{_prefix} \
114         --with-system-mail-directory=/var/mail
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir}}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %doc README doc/tech-notes.txt
132 %dir %{alpineconfdir}
133 %attr(755,root,root) %{_bindir}/alpine
134 %attr(755,root,root) %{_bindir}/rpload
135 %attr(755,root,root) %{_bindir}/rpdump
136 #%attr(755,root,root) %{_bindir}/mailutil
137 #%attr(2755,root,mail) %{_sbindir}/mlock
138 %{_mandir}/man1/alpine.1*
139 #%{_mandir}/man1/rpload.1*
140 #%{_mandir}/man1/rpdump.1*
141 #%{_mandir}/man1/mailutil.1*
142
143 %files -n pico
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/pico
146 %{_desktopdir}/pico.desktop
147 %{_mandir}/man1/pico*
148
149 %files -n pilot
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/pilot
152 %{_mandir}/man1/pilot*
This page took 0.099715 seconds and 4 git commands to generate.